Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: 404 error after batch add files  (Read 5665 times)

0 Members and 1 Guest are viewing this topic.

tonyjburton

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
404 error after batch add files
« on: July 10, 2013, 07:09:29 pm »

I've recently installed Coppermine after my old install seemed to have some issues, I've been re-uploading my images via ftp as I always do and it's been going ok until this afternoon. When I upload 20+ images at once they upload but I get a 404 error after, when it tries to load editpics.php?album=***.

I've been looking for any kind of solution but not found anything, any help would be really appreciated as I believe this is out of my depth.
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4843
    • Windsurf.me
Re: 404 error after batch add files
« Reply #1 on: July 10, 2013, 07:14:00 pm »

It is really hard to do anything without at least a link. Do uploads work if you batch add lest than 20? Do single file uploads work?

A 404 error is a page not found error. It could be that your server is running into a limit such as a memory limit (if less than 20 works ok that is most likely) and something is not setup correctly on the server so it is directing instead of to the actual error message to a 404 page.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

tonyjburton

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: 404 error after batch add files
« Reply #2 on: July 10, 2013, 07:20:23 pm »

Hi yes sorry here is the link http://www.sweetchin.com/gallery/

Yes it works less than 20, even the large batches that I mentioned 20+ get uploaded it's just when you've selected the album you want and then "insert selected files" it redirects to editpics.php and that's when I get the 404.

Example - http://www.sweetchin.com/gallery/editpics.php?album=284
Logged

tonyjburton

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: 404 error after batch add files
« Reply #3 on: July 10, 2013, 07:29:27 pm »

Also just looked and the server has 4GB of memory, only 1.2GB is being used. So It doesn't sound like it would be an memory limit  :-\
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4843
    • Windsurf.me
Re: 404 error after batch add files
« Reply #4 on: July 10, 2013, 07:57:21 pm »

There is a php memory limit, not the hard actual amount.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

tonyjburton

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: 404 error after batch add files
« Reply #5 on: July 10, 2013, 08:14:28 pm »

Just spoke to my friend who owns the server space and he sent me the server stats:

Resource Limits        max_execution_time                30
Resource Limits        max_input_time                60
Resource Limits        memory_limit                1024M
Oh and File Uploads        upload_max_filesize        Maximum allowed size for uploaded files.        256M
Logged

tonyjburton

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: 404 error after batch add files
« Reply #6 on: July 11, 2013, 10:51:21 am »

Any solutions on this, very strange it is. I mean images are uploading, but it's an annoying error. Not sure how serious it is, or how to fix it  :-\
Logged

tonyjburton

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: 404 error after batch add files
« Reply #7 on: July 12, 2013, 11:07:55 am »

Hi I'm still getting this error, any solutions to help?
Logged

tonyjburton

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: 404 error after batch add files
« Reply #8 on: July 12, 2013, 11:53:13 am »

Would it be possible to PM an admin my login so they can take a look? I mean I only installed Coppermine a couple of weeks ago and I get this error  :-\
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4843
    • Windsurf.me
Re: 404 error after batch add files
« Reply #9 on: July 12, 2013, 12:28:11 pm »

Not a lot else I can suggest TBH. It is almost certainly a server related issue as either batch add works or it does not. If it begins to fail with a larger number of files then that points to a server problem. Try increasing max execution and max input times and see if that helps.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: 404 error after batch add files
« Reply #10 on: August 21, 2013, 11:28:51 am »

Please attach a screenshot where we can see the error message and the browser's address bar.
Logged
Pages: [1]   Go Up
 

Page created in 0.021 seconds with 21 queries.