Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: the same pictures in every folder, but the folder is empty  (Read 3426 times)

0 Members and 1 Guest are viewing this topic.

zededd

  • Coppermine newbie
  • Offline Offline
  • Posts: 12

Hello there. I did a search but couldn't find a relevant thread to examine and potentially hijack...

my gallery is: gallery.zedslabs.com [NSFW!]
I uploaded three images to one folder, only to find they are in EVERY folder... but if i go to remove them from that folder, they aren't actually there...
I recently updated to the most recent version (i think... it didn't go well for AGES) but was having this problem before.

also, can anyone recommend a good anti-bot plugin? got the same damned comments awaiting approval every day and all I can do is block the IP.
I can't shell out for askimet and looking through here for anything to do with spam is like trying to empty the Atlantic with a tea-cup...
« Last Edit: August 23, 2013, 04:36:06 pm by Αndré »
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: the same pictures in every folder, but the folder is empty
« Reply #1 on: August 23, 2013, 04:37:05 pm »

As your gallery (which is not safe for work by the way - I just added a warning next to your link) contains a lot of images, please post some more details if this issue still exists. If not, please report how you fixed it and mark your thread as resolved.
Logged

zededd

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: the same pictures in every folder, but the folder is empty
« Reply #2 on: August 27, 2013, 12:42:18 pm »

sorry about the nsfw tag... i didn't think at the time...
Unfortunately, nothing I have done seems to help. only now, i have half of one folder's contents in ALL my folders... I can't see a reason, or remove them from the folders they're not meant to be in. eventually, i'm just going to remove them and re-upload them and see what happens.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: the same pictures in every folder, but the folder is empty
« Reply #3 on: August 27, 2013, 01:07:55 pm »

As you haven't provided more details, I can just direct you to the docs. I assume it's related to the album keyword feature. Please search the docs to understand how it works.
Logged

zededd

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: the same pictures in every folder, but the folder is empty
« Reply #4 on: August 27, 2013, 01:25:43 pm »

what details do you need? i have no experience in bugfixing coppermine and am doing the best I can, but since I can't find anything in the docs, i've posted here.
all the albums have my username as a keyword. since almost all the pictures I have uploaded have similar keywords, i don't see how these ones are being difficult as opposed to anything else
Logged

zededd

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: the same pictures in every folder, but the folder is empty
« Reply #6 on: August 27, 2013, 02:38:04 pm »

yes, i said I checked it... but removing ALL keywords from these files made no change.
on that note... is it possible to remove the album keywords option? i'll be frank, i would rather not have that feature active but nothing I do is changing anything.
unless I upload a file just to test this out, then start deleting things or changing settings till it breaks, I can't find anything specific about disabling this... but that's another story.

I am still trying to stop these pictures appearing in folders they have no reason to appear in.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: the same pictures in every folder, but the folder is empty
« Reply #7 on: August 27, 2013, 02:41:02 pm »

Have you tested to remove the keyword from the album(s)? Please post links to affected albums and pictures (i.e. pictures that shouldn't be displayed in a particular album).
Logged

zededd

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: the same pictures in every folder, but the folder is empty
« Reply #8 on: August 27, 2013, 02:50:34 pm »

ah! I found out why things have been going wrong...
someone I trusted to do admin work changed the format of the key-words and didn't tell me...
as a result, my name as an artist (that was included on all my uploads at the time) was removed, but the new ones I uploaded weren't. while EVERY folder I added had my name on it.
I would have had 8 folders, all containing my whole gallery if they'd not done this... sorry for the confusion, I really thought I had sorted this tagging issue.

Sorry about the bother... I really had no idea that the album keywords were being this much of a problem.
Is there a way to disable them for the whole gallery? I'm being plagued with messages of this and it would save me telling every new member. it's getting very fiddly to use this system how I want.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: the same pictures in every folder, but the folder is empty
« Reply #9 on: August 27, 2013, 03:10:30 pm »

The easiest way is probably to remove the keywords from the albums, as they don't have any other purpose.
Logged

zededd

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: the same pictures in every folder, but the folder is empty
« Reply #10 on: August 27, 2013, 03:22:04 pm »

I tried that... but when I save the changes, my name just appears there, just like before
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: the same pictures in every folder, but the folder is empty
« Reply #11 on: August 27, 2013, 03:23:33 pm »

So you're currently not able to remove the keyword from the album? If you don't want to mess around with the reason, I suggest to remove it with a tool like phpMyAdmin directly in your database (in the albums table).
Logged

zededd

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: the same pictures in every folder, but the folder is empty
« Reply #12 on: August 27, 2013, 03:31:56 pm »

i should probably just try this and not waste your time asking... but someone else might want to know in the future...
Is it possible to change it to something that will NEVER be used in a picture tag? something like "debugtagnotforuse"?

I'll be trying this out when I have more time at my disposal... I would rather not alter anything I could accidentally ruin the gallery with until I have more experience.

Thank you for your assistance with this. I will mark this as solved, but I would like to hear your reply.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: the same pictures in every folder, but the folder is empty
« Reply #13 on: August 27, 2013, 03:39:21 pm »

There are 2 possibilities:
1. Remove the album keyword feature
2. Disable the possibility to change the album keyword at the album properties page (e.g. after you've cleared them)

I haven't checked which option is easier, but I'm quite sure you have to edit core files for both solutions.
Logged

zededd

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: the same pictures in every folder, but the folder is empty
« Reply #14 on: August 27, 2013, 03:46:52 pm »

ok... i'm not too sure I want to edit too much, but I'll see what I can do... (hopefully, i won't be posting 'silly moron didn't back up and has now broken his gallery' next)

Thanks once again for your help. Sorry i didn't re-check the obvious, i really didn't realise it had been changed without my knowing...
Logged
Pages: [1]   Go Up
 

Page created in 0.024 seconds with 19 queries.