Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: A valid form token could not be found  (Read 42133 times)

0 Members and 1 Guest are viewing this topic.

EndlessQuest

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 47
A valid form token could not be found
« on: January 24, 2013, 08:54:15 pm »

Hi All, I have a problem with my site www.richards-fotos.nl/coppermine/index.php

If If I try to upload a picture to the gallery, I get an error message saying "A valid form token could not be found"

I just upgraded to the latest version (1.5.22?) so I assume this is causing the problem, but I am unable to figure out why. Tried searching the forums but to no avail.

Who can help me?
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Logged

EndlessQuest

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 47
Re: A valid form token could not be found
« Reply #2 on: January 24, 2013, 09:25:35 pm »

Hello André,

I followed the steps in the link you posted and as for the permission settings, they are all 777
Then I did the steps under "Enable troubleshooting settings"
When switching tot the simple uploading method, I do nog get any error message.
I checked the "server sided limitations" but none of these errors occur.

Am I correct in assuming that I now have to follow the steps under "Asking for support on upload issues"? Eg creating test user group and account etc.?
Logged

EndlessQuest

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 47
Re: A valid form token could not be found
« Reply #3 on: January 24, 2013, 09:39:44 pm »

I'm having issues when uploading on my Coppermine driven gallery www.richards-fotos.nl/coppermine/index.php
When using http uploads and the suggested settings for upload troubleshooting in place, I do not get an error message

When using advanced/multiple uploads I get the error message;
 
Code: [Select]
A valid form token could not be found
Here's the test user account data:
    Username: tester
    Password: tester
 
I have no idea what else to do.
Thanks in advance for your suggestions
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: A valid form token could not be found
« Reply #4 on: January 24, 2013, 09:41:30 pm »

Test upload with flash uploader works for me as expected. Please clear your browser cache or try with a different browser / machine.
Logged

EndlessQuest

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 47
Re: A valid form token could not be found
« Reply #5 on: January 24, 2013, 09:55:58 pm »

I tried with IE 9 and no problem

Emptied Chrome (my regular browser) cache an problem solved.

So no problem anymore.

I am interested to understand what might have caused this problem. Any theory?
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: A valid form token could not be found
« Reply #6 on: January 24, 2013, 09:59:45 pm »

In cpg1.5.22 the form token check was added to the flash uploader:
Added form token check to flash uploader (thread)

Your cached version doesn't contain the required form token, thus the check must fail. Depending on your cache settings it probably will fail again soon.
Logged
Pages: [1]   Go Up
 

Page created in 0.017 seconds with 19 queries.