Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: server i/o and file resize issues  (Read 6958 times)

0 Members and 1 Guest are viewing this topic.

Swansea_Jack

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 49
server i/o and file resize issues
« on: January 18, 2013, 03:46:46 pm »

Hi Andre

as per previous thread ...

Im now getting a server i/o error uploading batch files and on a single file upload there is no resizing taking place, the file is displayed at 3 or 4 times the size it should be.  Should add that the file is 4000x3000 pixels and about 5.9mb

if you look at the underwater world gallery on my website, www.peter-burns.co.uk/coppermine/index.php?theme=pbphotography, you will see what i mean.

the previous version was 1.5.16
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4885
    • Windsurf.me
Re: server i/o and file resize issues
« Reply #1 on: January 18, 2013, 04:05:22 pm »

This is almost certainly down to limits on your server. You would need to look at the server logs to see exactly what the error is.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: server i/o and file resize issues
« Reply #2 on: January 18, 2013, 04:08:19 pm »

Please post all file resizing related Coppermine settings.
Logged

Swansea_Jack

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 49
Re: server i/o and file resize issues
« Reply #3 on: January 18, 2013, 04:20:04 pm »

Phill - ive just emailed them with a copy of my original post on here - will wait to see what they come back with.

Andre - excuse my ignorance but is there an easy way of getting that info or will a screen shot do ?
Logged

Swansea_Jack

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 49
Re: server i/o and file resize issues
« Reply #4 on: January 18, 2013, 04:26:04 pm »

sorry screen shot attached this time
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: server i/o and file resize issues
« Reply #5 on: January 18, 2013, 04:49:48 pm »

Both settings for intermediate-sized and full-sized pictures are set to 8000px. Why do you expect that Coppermine resizes a file with the dimensions 4000x3000 (e.g. http://www.peter-burns.co.uk/coppermine/displayimage.php?pid=657)?
Logged

Swansea_Jack

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 49
Re: server i/o and file resize issues
« Reply #6 on: January 18, 2013, 06:25:36 pm »

when it was working on my previous gallery i would have the thumbnail, the when that was clicked it went to a larger screen about 800 x 600 still within the borders of the screen  (intermediate i believe), then if that was clicked on the image would appear on its own, in its own window.

what sizes should i have the config set to ?
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4885
    • Windsurf.me
Re: server i/o and file resize issues
« Reply #7 on: January 18, 2013, 07:09:01 pm »

The width or height of intermediate picture - 800 and not 8000
Logged
It is a mistake to think you can solve any major problems just with potatoes.

Swansea_Jack

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 49
Re: server i/o and file resize issues
« Reply #8 on: January 18, 2013, 07:33:31 pm »

ok ill give it a go - thanks
Logged

Swansea_Jack

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 49
Re: server i/o and file resize issues
« Reply #9 on: January 18, 2013, 07:45:16 pm »

right ive changed it to 800 but im still getting the server I/O when using batch uploads.  ive tried it with files at 800x600 and less than 1mb as well as full size images and not getting anywhere.

any more suggestions ?
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: server i/o and file resize issues
« Reply #10 on: January 18, 2013, 07:58:03 pm »

http://forum.coppermine-gallery.net/index.php/topic,55415.msg270618.html#msg270618

This thread is a really good example why that board rule is so important: I tell you how to fix one issue and you wonder why it doesn't fix the other issue. However, Phill already told you what to do.
Logged

Swansea_Jack

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 49
Re: server i/o and file resize issues
« Reply #11 on: January 18, 2013, 08:32:45 pm »

i was under the impression from this thread and the previous one, that the server I/O error was linked to the file size issues.  ive enclosed the server logs in case there is anything in there.

i appreciate your time and assistance
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4885
    • Windsurf.me
Re: server i/o and file resize issues
« Reply #12 on: January 18, 2013, 09:35:57 pm »

Without knowing the exact time you got the error the logs are not usable. I certainly cannot spend the time to look through a few thousand server messages for the particular one that details the problem. The logs are tie coded so knowing the time of the error allows the right one to be found.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

Swansea_Jack

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 49
Re: server i/o and file resize issues
« Reply #13 on: January 19, 2013, 11:23:29 am »

apologies.

this is the current log of upload attempts.

first attempt was a batch upload of files, all under 1mb, the second was a single file at full size and the third was a single, small image.  all started around 9.45 and completed around 10.10.

thank you again for your assistance
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4885
    • Windsurf.me
Re: server i/o and file resize issues
« Reply #14 on: January 19, 2013, 04:11:17 pm »

Nothing really in those particualr logs. Linux has numerous logs and tracking down your problem might not be easy as it seems to change everytime you tell us about it. I've been unable to replicate your errors when uploading to your gallery.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

Swansea_Jack

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 49
Re: server i/o and file resize issues
« Reply #15 on: January 19, 2013, 07:38:23 pm »

Hi Phill

it looks as though ive narrowed it down and it MAY be a problem with Firefox (Im running version 18.0.1).  Ive just downloaded a copy of Opera and it seems to work fine with that, no server I/O errors, multiple file (flash) uploads work OK.

could you tell me what browser you used to upload to my gallery please ?

as long as i can upload using Opera ill mark the thread as solved

Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4885
    • Windsurf.me
Re: server i/o and file resize issues
« Reply #16 on: January 19, 2013, 10:04:26 pm »

I used IE9 that time. I was going to test with other browsers but you have the limit for users set quite low so my quota ran out.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

Swansea_Jack

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 49
Re: server i/o and file resize issues
« Reply #17 on: January 20, 2013, 11:30:53 am »

Hi Phill

Ive reset the quotas to unlimited for the testme account, if its any help.  Ie9 also works (even though it takes ages between the clicking on the upload files button and actually getting to select files), so it does look like there is an issue with Firefox 18.0.1

Im happy to mark this as resolved unless there is anything else that needs changing.

Thanks
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4885
    • Windsurf.me
Re: server i/o and file resize issues
« Reply #18 on: January 20, 2013, 03:10:55 pm »

Works in FF 18 for me as you can see, I uploaded a load of images of mine (please delete them) and there were no errors.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

Swansea_Jack

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 49
Re: server i/o and file resize issues
« Reply #19 on: January 20, 2013, 04:32:16 pm »

ok no probs - guess it must be FF on my pc then.  ill get it removed and reinstalled.

as long as i can use Opera to batch upload its fine.

ill delete the album shortly.

thanks again
Logged
Pages: [1]   Go Up
 

Page created in 0.038 seconds with 20 queries.