Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Plugin issues  (Read 6403 times)

0 Members and 1 Guest are viewing this topic.

JJ1973

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 57
Plugin issues
« on: December 12, 2012, 10:39:55 pm »

I have recently just upgraded my gallery to the latest standalone upgrade which is 1.5.20 and when I go to use certain plugins, like the facebook plugin, and the online stats plugin, I notice that it changes my theme every time. It goes to this generic looking theme for some reason, just a white screen with photos and text links. No way to go back and change it unless I push the back button on my browser. Has this happened to anyone else and is there a way to fix it so I can use both of these plugins without any problems??

J
Logged

lurkalot

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 931
  • +Tinyportal Support team.
Re: Plugin issues
« Reply #1 on: December 12, 2012, 11:11:46 pm »

What version did you upgrade from?, and are the plugins you're using for Coppermine 1.5.x ?  If you upgraded from 1.4.xx to 1.5.20 then you need to replace the plugins for the latest versions as well.
Logged
Running SMF 2.0.15  / Tinyportal 1.6.4, bridged with Coppermine 1.6.06, plus cpmfetch 2.0.0

JJ1973

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 57
Re: Plugin issues
« Reply #2 on: December 13, 2012, 12:36:37 am »

From 1.4 and I did update them. I did everything the upgrade said to do. Just for some reason the plug ins do not work right and I need to get them up and running because I used them a lot on my previous version when they were offered.
Logged

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1510
  • aka 'i-imagine'
    • Home Page
Re: Plugin issues
« Reply #3 on: December 13, 2012, 01:24:14 am »

...my theme...

  • Post a link to your Coppermine (board rules)
  • Try a default theme - Curve
  • Add / remove the plugins, one by one
  • Move the plugins up / down the list
  • Make certain that no theme related files are out of place (ex. in the gallery root)


JJ1973

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 57
Re: Plugin issues
« Reply #4 on: December 13, 2012, 05:20:40 am »

www.bettedavisphotos.com

I did use a default theme like curve and redesigned it.

I have reinstalled the plugins from the cpg 1.5 package.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Plugin issues
« Reply #5 on: December 13, 2012, 02:59:10 pm »

when I go to use certain plugins, like the facebook plugin, and the online stats plugin, I notice that it changes my theme every time.

Please post a list of all affected plugins and also attach a screenshot how exactly your gallery looks if you install that plugins.
Logged

JJ1973

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 57
Re: Plugin issues
« Reply #6 on: December 15, 2012, 02:12:47 am »

facebook, online stats, socialshare, lightbox. The only time the facebook option comes up is when it is looking like this in the snapshot and this happens when I manage the plug ins and make it in API mode and without API mode it does nothing. Just makes it look like it should, but without the plugins added. Only time plug ins are added is when it looks like the attached photo.
Logged

JJ1973

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 57
Re: Plugin issues
« Reply #7 on: December 15, 2012, 11:49:41 pm »

I have provided the info and the attachment requested. I would appreciate some technical support on how to fix my plug in issue as it was not solved. THANKS.
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4849
    • Windsurf.me
Re: Plugin issues
« Reply #8 on: December 15, 2012, 11:55:23 pm »

You have mentioned 4 plugins. Which particular one causes the problem or is it only when all 4 are enabled that you see the problem.

So if you disable them all there is no issue. Enable 1 then see if the problem persists, if not disable it then try with the next. We need to first work out exactly which plugin is causing your problem. My guess would be the light box.

It is quite hard for us to guess as we cannot see the problem live for ourselves. From the screenshot it would appear that the CSS is not loading.

One final question, are you using the 1.5 versions of the plugins?
Logged
It is a mistake to think you can solve any major problems just with potatoes.

JJ1973

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 57
Re: Plugin issues
« Reply #9 on: December 16, 2012, 06:53:57 pm »

Hi yes. Using the plugins that come with the 1.5 package. It happens when I upload all 4. And I see this problem when I upload them from API setting. Otherwise, if I don't, it shows  nothing. It just shows the gallery as it looks without any plugins installed.

Not sure if it is a template issue, I have not tried the plugins with any other templates. Should I try uploading the plugins using a different theme or would that not matter???

J
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Plugin issues
« Reply #10 on: December 18, 2012, 01:24:09 pm »

The Plugins "facebook", "socialshare" and "lightbox" are user contributed plugins, which doesn't come with the cpg1.5.x package.

It happens when I upload all 4.
Please try if it also happens when you just install the lightbox plugin.
Logged
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 20 queries.