Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: 1 2 [3] 4   Go Down

Author Topic: Migrating coppermine gallery to another server  (Read 51161 times)

0 Members and 1 Guest are viewing this topic.

ohara

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 37
Re: Migrating coppermine gallery to another server
« Reply #40 on: December 21, 2012, 12:37:04 pm »

Has the code for the login box changed? As it doesn't seem to work in 1.5.x and just shows {LOGIN_FORM} on the page. Also, why does it show {JAVASCRIPT} in the very top left of the page?

Why does my custom theme have a theme selection box and a choose your language box when it shouldn't? How can I get rid of them?

Logged

ohara

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 37
Re: Migrating coppermine gallery to another server
« Reply #41 on: December 21, 2012, 01:02:43 pm »

I have enabled guest access and debugging, can anyone take a look please?

Now at http://dedi.smileserv.co.uk/~sott/smilenew/index.php

:)
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Migrating coppermine gallery to another server
« Reply #42 on: December 21, 2012, 03:52:08 pm »

This thread is very messy. As far as I can see you upgraded your gallery to cpg1.5.20 and now make your theme fully compatible with cpg1.5.x, right?

If so, what's the actual issue? Is there still an issue at all?
Logged

ohara

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 37
Re: Migrating coppermine gallery to another server
« Reply #43 on: December 21, 2012, 10:02:08 pm »

I don't think the theme is the root cause of all my problems though, even using the curve theme I get errors like this:

Quote
Fatal error: Cannot redeclare cpgGetMicroTime() (previously declared in /home/sott/public_html/smilenew/include/init.inc.php:25) in /home/sott/public_html/smilenew/include/init.inc.php on line 27
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Migrating coppermine gallery to another server
« Reply #44 on: December 21, 2012, 10:21:35 pm »

If you need support, please post some directions where exactly it happens. Additionally, make sure that there are no old cpg1.4.x files in your Coppermine folders (check especially the bridge folder).
Logged

ohara

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 37
Re: Migrating coppermine gallery to another server
« Reply #45 on: December 22, 2012, 09:52:11 am »

Do you think I'll actually ever get this to work? Because I don't want to waste time and money forever in vain trying to fix something that is too broken to fix.

I didn't create the custom theme that I use and I am not a coder so I don't think I'll ever be able to update it for 1.5.x

There are a couple of plugins which I rely on too which don't seem to be compatible with 1.5.x so I think I'll just downgrade the version of PHP on my server and stay on cpg1.4.7

Thanks for the help that everyone has tried to give here but I really am at my wits end with this now and I just want my gallery to work on my new server and I now firmly believe that it will never be able to be upgraded to 1.5.x and retain its current functionality.

Merry Christmas all
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4726
    • Windsurf.me
Re: Migrating coppermine gallery to another server
« Reply #46 on: December 22, 2012, 04:47:17 pm »

You really are at risk using 1.4.7. At the very least update to the last of the 1.4 line.

As for plugins that you cannot find for 1.5.x which ones in particular?
Logged
It is a mistake to think you can solve any major problems just with potatoes.

ohara

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 37
Re: Migrating coppermine gallery to another server
« Reply #47 on: December 22, 2012, 09:11:33 pm »

I need CPGMassImport and photo shop.
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4726
    • Windsurf.me
Logged
It is a mistake to think you can solve any major problems just with potatoes.

ohara

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 37
Re: Migrating coppermine gallery to another server
« Reply #49 on: December 25, 2012, 03:18:57 am »

I'm still having one major problem - I can't actually add any photos!

searchnew.php does not work and neither does the mass import plugin!
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Migrating coppermine gallery to another server
« Reply #50 on: December 28, 2012, 10:51:40 am »

Last attempt: please post sufficient information if you expect helpful answers. I currently don't know which Coppermine version you're talking about, what exactly you have done and what exactly doesn't work. We need detailed error messages what doesn't work or what happens when you do/click something.
Logged

ohara

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 37
Re: Migrating coppermine gallery to another server
« Reply #51 on: December 28, 2012, 11:31:49 am »

Ok, big load of information. This is the situation as it stands now.

I have not attempted to do any upgrades to the ORIGINAL gallery install.
I downgraded PHP to 5.2 on my new server, unpacked the backup of the original install and it works perfectly (version 1.4.8).
I have managed to upgrade the new install to 1.4.20
If I go to 1.4.21 it breaks the main category images - was BBcode in category descriptions removed in this version?
Apart from my custom login box, everything else works fine.

I talked to the person who originally made the custom theme that I am using and she explained the situation. It was intended that certain sub-categories would have their own themes. As this was apparently not supported in 1.4.8, some custom coding was done in order to achieve it. There was also some hard coding done in order to allow adverts at the side of the page (also not supported in 1.4.8 I am told). These modifications were done by a user I believe to be of this forum, possibly a member of the development team (I can't remember the name but will find out) in return for payment.

Obviously my end goal is to get the gallery up to date on the latest version of 1.5. Due to the custom coding done on my gallery, this is not something I would be able to achieve by myself, and my theme would obviously need re-writing. If anyone would be willing to take on this challenge (basically getting my gallery onto the current version of cpg, looking and working exactly like it does now) then I will be happy to offer payment.

I am fairly confident that this is the largest install of coppermine gallery currently in the world and it has been going for over 7 years without fault. We have over 150,000 registered users. 1290274 files in 19501 albums and 192 categories with 57461 comments viewed 18862714 times. I was informed by the person who originally made the theme that at one point our gallery was actually being used by your development team for testing due to its sheer size.

I would be very grateful if anyone can help me get this sorted. I have this morning transitioned over to using the new server, the name servers should be updating sometime around now so  my new site is pretty much live.

Thanks, and I hope you all had a great christmas.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Migrating coppermine gallery to another server
« Reply #52 on: December 28, 2012, 11:45:13 am »

If I go to 1.4.21 it breaks the main category images - was BBcode in category descriptions removed in this version?
Yes, see announcement thread.


Unfortunately your big load of information doesn't clearly state if your current issues
I'm still having one major problem - I can't actually add any photos!

searchnew.php does not work and neither does the mass import plugin!
apply to your restored cpg1.4.8 backup, to any updated version of cpg1.4.x or the latest version of cpg1.5.x.
Logged

ohara

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 37
Re: Migrating coppermine gallery to another server
« Reply #53 on: December 29, 2012, 05:53:38 am »

Sorry for not being clear enough. You can ignore everything up to my previous post as that is the situation now. Everything works except for the custom login form. It's version 1.4.20
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4726
    • Windsurf.me
Re: Migrating coppermine gallery to another server
« Reply #54 on: December 29, 2012, 10:43:34 am »

So as eveerything works is there anything else needed from our side until you upgrade to 1.5.x?
Logged
It is a mistake to think you can solve any major problems just with potatoes.

ohara

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 37
Re: Migrating coppermine gallery to another server
« Reply #55 on: December 30, 2012, 09:53:20 am »

Yeah - I need to be able to resolve the login form not working and also how to keep my images in the category descriptions without using BBcode (HTML obviously isn't allowed either).

My aim is to get to 1.4.27 for now and once I have rewritten the theme, go to 1.5.x
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Migrating coppermine gallery to another server
« Reply #56 on: January 02, 2013, 01:45:44 pm »

Everything works except for the custom login form.

As far as I know Stramm's modpack and maybe some other mods/plugins provided such a login form for cpg1.4.x, maybe you created it yourself. I don't understand why you don't
post sufficient information if you expect helpful answers.

As we already said, cpg1.4.x is unsupported. However, if I remember correctly there are already some threads that deal with custom login forms and also how to undo the BBCode fix. If you don't find the thread for the latter issue, just have a look at the cpg1.4.21 announcement thread, follow the link to the fix and undo that security fix. Regarding the first issue, if you used Stramm's modpack you have to re-apply it after the upgrade to cpg1.4.27.
Logged

ohara

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 37
Re: Migrating coppermine gallery to another server
« Reply #57 on: January 02, 2013, 08:00:45 pm »

Ah yes I think you're right. It did say "Modified by Stramm" at the bottom of my gallery before I went to 1.4.19

How can I get images in category descriptions without BBCode?
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4726
    • Windsurf.me
Re: Migrating coppermine gallery to another server
« Reply #58 on: January 02, 2013, 11:58:00 pm »

The thread Andre refers to restores the bbcode functionality. The rerason it was removed was because of a potential security risk. However 1.5.x fixes much of that and also brings in many features of the modpack.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

ohara

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 37
Re: Migrating coppermine gallery to another server
« Reply #59 on: January 04, 2013, 04:06:37 pm »

Right I'm now on 1.4.27. There's just a couple of things I need to sort before the jump to 1.5.

BBcode in the category descriptions still doesn't work.
Logged
Pages: 1 2 [3] 4   Go Up
 

Page created in 0.029 seconds with 20 queries.