Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: fatal error after updating from 1.4.25 to 1.5.20  (Read 4547 times)

0 Members and 1 Guest are viewing this topic.

mach_gr

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
fatal error after updating from 1.4.25 to 1.5.20
« on: November 02, 2012, 08:17:14 pm »

Hi folks, hoping someone can help a newbie to forum please. Have 3 websites running CPG. Have updated one of then fine. However the other two have occurred a fatal error (the same for both).

fatal error
call to undefined function check_rebuild_tree() in home/mywebsites/public.html/gallery/update.php on line 583

mywebsites = domain
gallery = folder where cpg installed

I have retried updating 3 times for each website, but same each time.

Any advice would be appreciated
Logged

Jeff Bailey

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1322
  • Fishing relaxes me.
    • Bailey Family Co.
Logged
Thinking is the hardest work there is, which is probably the reason why so few engage in it. - Henry Ford

mach_gr

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: fatal error after updating from 1.4.25 to 1.5.20
« Reply #2 on: November 03, 2012, 09:07:25 pm »

Hi Jeff

Many thanks, tried your suggestion. Still need to check all config settings but looks like all working fine now.

My only comment would be that I followed all the instructions (including notes) in the unzipped download folder Coppermine/cpg15x/docs/en/upgrading.htm yet the upgrade failed. The instructions do differ from what you advised me to do via the link you provided, so maybe the instructions need revising.

Anyway, again many thanks
Logged

mach_gr

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: fatal error after updating from 1.4.25 to 1.5.20
« Reply #3 on: November 04, 2012, 07:16:08 pm »

Managed to go through config settings for all 3 websites and Yes looks like all updated and working fine. Many Thanks again.
Logged

Jeff Bailey

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1322
  • Fishing relaxes me.
    • Bailey Family Co.
Re: fatal error after updating from 1.4.25 to 1.5.20
« Reply #4 on: November 05, 2012, 09:36:57 pm »

Glad it worked and thank you for coming back and confirming.

AFAIK it's not in the docs because it occurs so infrequently.
From the same thread I linked to:
It is not all instances that do. Sometimes files get left over from mods etc, sometimes write permissions on the odd file get changed on the server and  your ftp app doesn't replace them. In my mind it is always good to do a cleanup this way.

Please resolve your thread.
Resolve your threads
If you have found an answer to your question, resolve your thread. Don't just post "I have found the answer", but tell others what you actually did to solve your issues. Posting a link to the page where you found the answer might help. Describing what you did might help as well. Finally, you can tag your answer as "solved" by clicking on the "Topic Solved" button on the bar at the left hand side at the bottom of your thread.
Logged
Thinking is the hardest work there is, which is probably the reason why so few engage in it. - Henry Ford
Pages: [1]   Go Up
 

Page created in 0.015 seconds with 19 queries.