Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Moderation not working on user uploads  (Read 5250 times)

0 Members and 1 Guest are viewing this topic.

SpikeTheLobster

  • Coppermine newbie
  • Offline Offline
  • Posts: 18
Moderation not working on user uploads
« on: October 18, 2012, 12:24:40 am »

I've had a bit of a hunt through and can't see an answer to this anywhere. I'm confused, so I'll lay out the background.

I have a site with two albums, Gallery and Upload_Here. Obviously, users are supposed to register and upload to the latter rather than the former. I have the basic groups set up by default (Admin, Registered, Guests). Registered users have "Public albums upload" set to "Allowed: Yes" and "Approval: Yes". The Gallery album (public) is set to "Visitors can upload files: No".

The odd thing is that registered users can upload into the Gallery album directly and I don't get any notification (which is switched on in the config) and everything goes straight into the album with no approval.

I don't get it. With those settings, shouldn't they go into an approval queue and wait until I moderate them?  ???
Logged

Jeff Bailey

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1322
  • Fishing relaxes me.
    • Bailey Family Co.
Logged
Thinking is the hardest work there is, which is probably the reason why so few engage in it. - Henry Ford

SpikeTheLobster

  • Coppermine newbie
  • Offline Offline
  • Posts: 18
Re: Re: Moderation not working on user uploads
« Reply #2 on: October 21, 2012, 11:39:30 am »

Please post a link.
http://forum.coppermine-gallery.net/index.php/topic,55415.msg270616.html#msg270616

The gallery will not be suitable for all viewers, so I'd rather not do that publicly.

Those settings should work. Please provide the following:
http://documentation.coppermine-gallery.net/en/upload_troubleshooting.htm#upload_support

Should I PM or something?

(Apologies for delay - moved house, everything's a complete mess!)
Logged

Jeff Bailey

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1322
  • Fishing relaxes me.
    • Bailey Family Co.
Re: Moderation not working on user uploads
« Reply #3 on: October 22, 2012, 09:08:30 pm »

If its on the internet it's public, for the best results you should post the information with [NSFW] next to the links.
I am unavailable to help with [NSFW] sites.
Congrats on the house.
Logged
Thinking is the hardest work there is, which is probably the reason why so few engage in it. - Henry Ford

SpikeTheLobster

  • Coppermine newbie
  • Offline Offline
  • Posts: 18
Re: Moderation not working on user uploads
« Reply #4 on: November 07, 2012, 11:40:22 am »

I figured it out.

The permissions DO work... but all they have to do is create their own user gallery and upload everything to there. No moderation. No checking. Totally circumvents all admin input.

Solution: http://forum.coppermine-gallery.net/index.php/topic,23012.msg105900.html

Now I just have to figure out how to get all the pics from personal albums into the main Gallery and remove the albums so they can no longer be used to circumvent moderation...!

Logged

Jeff Bailey

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1322
  • Fishing relaxes me.
    • Bailey Family Co.
Re: Moderation not working on user uploads
« Reply #5 on: November 07, 2012, 11:50:41 pm »

Thank you for resolving your thread.
Logged
Thinking is the hardest work there is, which is probably the reason why so few engage in it. - Henry Ford
Pages: [1]   Go Up
 

Page created in 0.018 seconds with 19 queries.