Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: 1.4.12 -> 1.5.20 upgrade questions.  (Read 4227 times)

0 Members and 1 Guest are viewing this topic.

Paul Van Benschoten

  • Coppermine newbie
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 2
1.4.12 -> 1.5.20 upgrade questions.
« on: July 08, 2012, 10:33:20 pm »

This is probably a dumb question, I do not have much Coppermine or SQL knowledge.

I created a Coppermine photogallery several years ago in 2007. This is my first real upgrade. I have used the system administration panel on my web host to export my SQL database to my home PC. I am in the process of FTPing the entire Coppermine folder from my host to my home PC.

Now to my question.

My SQL database has names like cpg1411_albums ... cpg1411_vote_stats.  Will these names still be valid after moving to 1.5.20 ?  I do not see anything in my Coppermine config panel that lets me choose the prefix used by Coppermine. Will I be able to select this during the install of 1.5.20?

Is this question answered in the upgrade documentation? Obviously, I have not read the whole thing yet.

Thank you,
Paul Van Benschoten
Logged
--
Paul Van Benschoten

Paul Van Benschoten

  • Coppermine newbie
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 2
Re: 1.4.12 -> 1.5.20 upgrade questions.
« Reply #1 on: July 08, 2012, 11:06:09 pm »

Does this answer my question?


Quote
Run the mysql database queries that reside in the file sql/update.sql (replacing the generic table prefix with the one you actually chose during initial install)

That statement is from the Update Script section of http://documentation.coppermine-gallery.net/en/upgrading.htm

--
Paul Van Benschoten
Logged
--
Paul Van Benschoten

lurkalot

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 931
  • +Tinyportal Support team.
Re: 1.4.12 -> 1.5.20 upgrade questions.
« Reply #2 on: July 09, 2012, 09:15:50 am »

Does this answer my question?


That statement is from the Update Script section of http://documentation.coppermine-gallery.net/en/upgrading.htm

--
Paul Van Benschoten

Running the updater should take care of all this for you, http://documentation.coppermine-gallery.net/en/upgrading.htm#updater_what_it_does

If you're performing a upgrade from 1.4.x to 1.5.x then you need to backup your Database, and your Albums folder (as a precaution) your include/config.inc.php file.  Your plugins folder and your themes folder, (again as a precaution shold something go wrong) 

Make sure you're logged into coppermine as admin, turn off all your plugins as these won't work with 1.5.x same goes for your themes. I would remove those folders or rename them for now, so you could delete them afterwards.

Download a fresh copy of 1.5.x  Extract it to you desktop.  Remove the albums folder from the files you just extracted.  Upload the rest of the folders and files to your server overwriting the existing ones.  Then run the upgrade from your browser address bar, http://yoursite.tld/your_coppermine_folder/update.php

 
Logged
Running SMF 2.0.15  / Tinyportal 1.6.4, bridged with Coppermine 1.6.06, plus cpmfetch 2.0.0
Pages: [1]   Go Up
 

Page created in 0.018 seconds with 19 queries.