Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: "Users" section issue, unable to click into the users section as an admin  (Read 5058 times)

0 Members and 1 Guest are viewing this topic.

Touge.ca

  • Coppermine newbie
  • Offline Offline
  • Posts: 13

I m having issue with my coppermine photos album,

when I logged in as an admin, and click into "users", it shows the
below message instead of the users account and info.

It was not like this before..just happened recently.

is there anyway I can get it fixed?  should I upgrade it from 1.5.16 to 1.5.20?

------------------------------------------------------------
Internal Server Error

The server encountered an internal error or misconfiguration and was
unable to complete your request.

Please contact the server administrator, webmaster@touge.ca and
inform them of the time the error occurred, and anything you might
have done that may have caused the error.

More information about this error may be available in the server
error log.

Additionally, a 404 Not Found error was encountered while trying to
use an ErrorDocument to handle the request.
------------------------------------------------------------

thanks
Logged

Touge.ca

  • Coppermine newbie
  • Offline Offline
  • Posts: 13

I can still batch upload files, no problem, and quite of the other features has no problems too.

only the "Users" button has problem.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765

should I upgrade it from 1.5.16 to 1.5.20?
Yes, please.
Logged

Touge.ca

  • Coppermine newbie
  • Offline Offline
  • Posts: 13

Yes, please.

hi Andre,

just uploaded to 1.5.20...

but the Users section still not working... other sections working ok..

any hints would be greatly appreciated.

thanks

Kevin

Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765

Unfortunately this is a quite meaningless HTTP error code, so please do as suggested:
Internal Server Error

The server encountered an internal error or misconfiguration and was
unable to complete your request.

Please contact the server administrator, webmaster@touge.ca and
inform them of the time the error occurred, and anything you might
have done that may have caused the error.

More information about this error may be available in the server
error log.


Additionally, a 404 Not Found error was encountered while trying to
use an ErrorDocument to handle the request.


A link to your gallery and some information about configuration / bridging might also help.
Logged

Touge.ca

  • Coppermine newbie
  • Offline Offline
  • Posts: 13

Unfortunately this is a quite meaningless HTTP error code, so please do as suggested:

A link to your gallery and some information about configuration / bridging might also help.

hi Andre,

my gallery is http://www.touge.ca/photos

what kind of configuration/bridging info do you want?

Under "Bridge Wizard: choose application to bridge Coppermine with "
I haven't choose any application to bridge Coppermine with.

For config info, which settings do you need?

can I pm/email you a login to see the problem?


thanks

Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765

Under "Bridge Wizard: choose application to bridge Coppermine with "
I haven't choose any application to bridge Coppermine with.
So your gallery is not bridged, well.


can I pm/email you a login to see the problem?
Just sent you a PM. To perform some tests with the user manager, FTP access would be very helpful.
Logged

Touge.ca

  • Coppermine newbie
  • Offline Offline
  • Posts: 13

So your gallery is not bridged, well.

Just sent you a PM. To perform some tests with the user manager, FTP access would be very helpful.

emailed you. 

thanks a lot.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765

In bridge/udb_base.inc.php you'll find that query:
Code: [Select]
        $sql = "SELECT {$f['user_id']} AS user_id, {$f['username']} AS user_name, {$f['email']} AS user_email, {$f['regdate']} AS user_regdate, {$f['lastvisit']} AS user_lastvisit, {$f['active']} AS user_active, "
               . "COUNT(pid) AS pic_count, ROUND(SUM(total_filesize)/1024) AS disk_usage, group_name, group_quota, user_group_list "
               . "FROM {$this->usertable} AS u "
               . "INNER JOIN `{$C['dbname']}`.{$C['TABLE_USERGROUPS']} AS g ON u.{$f['usertbl_group_id']} = g.group_id "
               . "LEFT JOIN `{$C['dbname']}`.{$C['TABLE_PICTURES']} AS p ON p.owner_id = u.{$f['user_id']} "
               . $options['search']
               . "GROUP BY user_id " . "ORDER BY " . $sort_codes[$options['sort']] . " "
               . "LIMIT {$options['lower_limit']}, {$options['users_per_page']};";

I replaced
Code: [Select]
. "COUNT(pid) AS pic_count, ROUND(SUM(total_filesize)/1024) AS disk_usage, group_name, group_quota "with
Code: [Select]
. "group_name, group_quota "and the user manager loads. Obviously, that code change breaks the file count and disk usage. But it seems that your database isn't powerful enough to run the stock query.
Logged

Touge.ca

  • Coppermine newbie
  • Offline Offline
  • Posts: 13

Thanks a bunch Andre,

how can I determine if my database is powerful enough? or How can I upgrade it?
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765

I already wrote that via email, but here again.

Execute the following queries with a tool like phpMyAdmin. Maybe you get a more detailed error message (or non at all).

1. (probably won't work):
Quote
SELECT user_id AS user_id, user_name AS user_name, user_email AS user_email, UNIX_TIMESTAMP(user_regdate) AS user_regdate, UNIX_TIMESTAMP(user_lastvisit) AS user_lastvisit, user_active AS user_active, COUNT(pid) AS pic_count, ROUND(SUM(total_filesize)/1024) AS disk_usage, group_name, group_quota FROM `phantomb_copp1`.cpg_users AS u INNER JOIN `phantomb_copp1`.cpg_usergroups AS g ON u.user_group = g.group_id LEFT JOIN `phantomb_copp1`.cpg_pictures AS p ON p.owner_id = u.user_id GROUP BY user_id ORDER BY user_regdate DESC LIMIT 0, 25;


2. (should work):
Quote
SELECT user_id AS user_id, user_name AS user_name, user_email AS user_email, UNIX_TIMESTAMP(user_regdate) AS user_regdate, UNIX_TIMESTAMP(user_lastvisit) AS user_lastvisit, user_active AS user_active, group_name, group_quota FROM `phantomb_copp1`.cpg_users AS u INNER JOIN `phantomb_copp1`.cpg_usergroups AS g ON u.user_group = g.group_id LEFT JOIN `phantomb_copp1`.cpg_pictures AS p ON p.owner_id = u.user_id GROUP BY user_id ORDER BY user_regdate DESC LIMIT 0, 25;


How can I upgrade it?
Ask your hosting provider. Maybe you can increase some limits yourself, or they'll do. Maybe you have to search for another hosting provider.
Logged
Pages: [1]   Go Up
 

Page created in 0.055 seconds with 19 queries.