Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: The problem with the template of "Reynolds"  (Read 6365 times)

0 Members and 1 Guest are viewing this topic.

adibar

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
The problem with the template of "Reynolds"
« on: April 11, 2012, 11:12:19 am »

Continuing thread: http://forum.coppermine-gallery.net/index.php/topic,63890.msg359853.html#msg359853
After loading the 1.5 version modified by me like, "Reynolds" (no problem functioning version 4.1.16) I get the following error:
Code: [Select]
Template error
Failed to find block 'view_log_files' (#<!-- BEGIN view_log_files -->(.*?)<!-- END view_log_files -->#s) in :
                    <ul>

                            <li><a href="admin.php" title="{ADMIN_TITLE}" class="navmenu">{ADMIN_LNK}</a></li>
                            <li><a href="catmgr.php" title="{CATEGORIES_TITLE}" class="navmenu">{CATEGORIES_LNK}</a></li>
                            <li><a href="albmgr.php{CATL}" title="{ALBUMS_TITLE}" class="navmenu">{ALBUMS_LNK}</a></li>
                            <li><a href="groupmgr.php" title="{GROUPS_TITLE}" class="navmenu">{GROUPS_LNK}</a></li>
                            <li><a href="usermgr.php" title="{USERS_TITLE}" class="navmenu">{USERS_LNK}</a></li>
                            <li><a href="banning.php" title="{BAN_TITLE}" class="navmenu">{BAN_LNK}</a></li>
                            <li><a href="reviewcom.php" title="{COMMENTS_TITLE}" class="navmenu">{COMMENTS_LNK}</a></li>

                            <li><a href="picmgr.php" title="{PICTURES_TITLE}" class="navmenu">{PICTURES_LNK}</a></li>
                            <li><a href="searchnew.php" title="{SEARCHNEW_TITLE}" class="navmenu">{SEARCHNEW_LNK}</a></li>
                            <li><a href="util.php" title="{UTIL_TITLE}" class="navmenu">{UTIL_LNK}</a></li>
                           
<!-- BEGIN documentation -->
                            <li><a href="{DOCUMENTATION_HREF}" title="{DOCUMENTATION_TITLE}" target="cpg_documentation" class="navmenu">{DOCUMENTATION_LNK}</a></li>
<!-- END documentation -->
                    </ul>
Please help in solving it.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: The problem with the template of "Reynolds"
« Reply #1 on: April 12, 2012, 10:08:34 am »

Please attach your whole theme as zip file to your next reply. Of course you can also try to fix that issue yourself, by adding the mandatory template block 'view_log_files' to your menu template (just search for the displayed code in your theme's theme.php file and add something like
Code: [Select]
            <!-- BEGIN view_log_files -->
                <div class="admin_menu admin_float"><a href="viewlog.php" title="{VIEW_LOG_FILES_TITLE}">{VIEW_LOG_FILES_ICO}{VIEW_LOG_FILES_LNK}</a></div>
            <!-- END view_log_files -->
Logged

adibar

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: The problem with the template of "Reynolds"
« Reply #2 on: April 15, 2012, 05:38:29 pm »

Which line do I add this code?
I enclose the style files.
Logged

adibar

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: The problem with the template of "Reynolds"
« Reply #3 on: April 15, 2012, 05:55:25 pm »

OK.
In theme.php, in section
// HTML template for gallery admin menu
before the section
// HTML template for user admin menu
I added the following lines and it started working.

Code: [Select]
<!-- BEGIN view_log_files -->
                                        <li><a href="viewlog.php" title="{VIEW_LOG_FILES_TITLE}"><span>{VIEW_LOG_FILES_ICO}{VIEW_LOG_FILES_LNK}</span></a></li>
                                    <!-- END view_log_files -->
<!-- BEGIN exif_manager -->
                                        <li><a href="exifmgr.php" title="{EXIFMGR_TITLE}"><span>{EXIFMGR_ICO}{EXIFMGR_LNK}</span></a></li>
                                    <!-- END exif_manager -->
<!-- BEGIN overall_stats -->
                                        <li><a href="stat_details.php?type=hits&amp;sort=sdate&amp;dir=&amp;sdate=1&amp;ip=1&amp;search_phrase=0&amp;referer=0&amp;browser=1&amp;os=1&amp;mode=fullscreen&amp;page=1&amp;amount=50" title="{OVERALL_STATS_TITLE}" ><span>{OVERALL_STATS_ICO}{OVERALL_STATS_LNK}</span></a></li>
                                    <!-- END overall_stats -->
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: The problem with the template of "Reynolds"
« Reply #4 on: April 16, 2012, 09:14:15 am »

Please
tag your answer as "solved" by clicking on the "Topic Solved" button on the bar at the left hand side at the bottom of your thread.
Logged

adibar

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: The problem with the template of "Reynolds"
« Reply #5 on: June 18, 2012, 10:43:25 am »

Welcome back
The problem came back again. The script gives the message again:
Notice: Undefined offset: 8192 in /include/debugger.inc.php on line 112
The attached zipped style.
Please help.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: The problem with the template of "Reynolds"
« Reply #6 on: June 18, 2012, 03:10:23 pm »

This seems to be another issue. Your first issue was a template error. If you still get a template error, please post the error message.
Logged

adibar

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: The problem with the template of "Reynolds"
« Reply #7 on: June 19, 2012, 09:54:53 am »

I wrote
Notice: Undefined offset: 8192 in /include/debugger.inc.php on line 112

See for yourself: www.bartniccy.pl
Insertion of the code given by you does not help.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: The problem with the template of "Reynolds"
« Reply #8 on: June 19, 2012, 10:44:35 am »

Please try to replace all Coppermine core files (like doing a regular cpg1.5.x update). include/debugger.inc.php on line 112 is a blank line in cpg1.5.x, so I assume at least that file has been corrupted or you're still using cpg1.4.x, as I wasn't able to find some cpg1.5.x find in your gallery.


Insertion of the code given by you does not help.
That's not surprising, as this is a completely different issue.
Logged

adibar

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: The problem with the template of "Reynolds"
« Reply #9 on: June 19, 2012, 11:10:19 am »

Of course I'm using version 1.4 because the style of this version are not compatible with 1.5 - completely loses control. For this reason, not doing the update.

Going back to my file /include/debugger.inc.php
Starting from line 104 to 115 is as follows (line 112 causing the error is in bold):

Code: [Select]
        // NOTE: E_ERROR, E_PARSE, E_CORE_ERROR, E_CORE_WARNING, E_COMPILE_ERROR and E_COMPILE_WARNING
        // error levels will be handled as per the error_reporting settings.
        if ($errno == E_USER_ERROR) {
            if (USER_IS_ADMIN) {
                $errmsg = $errortype[$errno]." $filename line $linenum: ".$errmsg;
            } else {
                $errmsg = "A error occured while processing this page.<br />Please report the following error to the owner of this website.<br /><br /><strong>$errmsg</strong>";
            }
            [b]cpg_die(CRITICAL_ERROR, $errmsg, $filename, $linenum);[/b]
        }

        // set of errors for which a var trace will be saved

Its removal also does not work.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: The problem with the template of "Reynolds"
« Reply #10 on: June 19, 2012, 12:02:47 pm »

There's no support for cpg1.4.x since a lot of months. If you don't want to update, you have to solve that issue yourself.
Logged
Pages: [1]   Go Up
 

Page created in 0.022 seconds with 20 queries.