Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: korrekten title="" und alt="" für die Bilder vergeben  (Read 2719 times)

0 Members and 1 Guest are viewing this topic.

dp-wurzel

  • Coppermine novice
  • *
  • Country: 00
  • Offline Offline
  • Posts: 24
    • Fotos und Bilder gratis downloaden
korrekten title="" und alt="" für die Bilder vergeben
« on: May 18, 2012, 10:17:17 am »

Guten Morgen,

In der 1.4 Version hatte ich es so eingerichtet das für alle Bilder(auch für Filmstreifen und Thumbnails) korrekte title="" und alt="" angezeigt wurde. Ich glaube ich hatte {TITLE} in der "displayimage.php" dafür verwendt. Ich finde leider in der neuen Version die Stelle bzw. die Datei nicht wo ich das ändern kann. Und Google indexiert jetzt immer die Bilder mit "Klicken für Bild in voller Größe" statt dem Title, was natürlich nicht optimal ist. Ich habe jetzt täglich ca.200 Bersucher Verlust die sonst über die Bildersuche kamen.

Kann mir jemand sagen was ich ändern muss?

MfG dp-wurzel

Logged

dp-wurzel

  • Coppermine novice
  • *
  • Country: 00
  • Offline Offline
  • Posts: 24
    • Fotos und Bilder gratis downloaden
Re: korrekten title="" und alt="" für die Bilder vergeben
« Reply #1 on: May 18, 2012, 01:47:08 pm »

OK für die "Normal-Bilder" hab ich es in der theme.php gefunden und funktioniert jetzt auch. Mir fehlen aber noch Filmstrip und Thumbnails. Da wird als alt="" immer der Dateiname angezeigt. Da hätte ich auch gerne einen richtigen Alt-Text und Title. Jemand eine Idee wo ich das ändern kann?

MfG dp-wurzel
Logged

Αndré

  • Administrator
  • Coppermine addict
  • ****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: korrekten title="" und alt="" für die Bilder vergeben
« Reply #2 on: May 21, 2012, 02:04:11 pm »

für die "Normal-Bilder" hab ich es in der theme.php gefunden und funktioniert jetzt auch
Löse Deine Anfragen auf
Wenn Du eine Antwort auf Deine Frage gefunden hast, dann löse bitte Deinen Thread auf. Beantworte ihn nicht nur mit "ich habe die Lösung gefunden", sondern beschreibe auch, was Du getan hast, um Dein Problem zu lösen (zum Nutzen Anderer). Das posten eines Links, der zu der Seite führt, die Deine Lösung beinhaltet ist hilfreich. Zu beschreiben, was genau Du getan hast ist hilfreich.


Mir fehlen aber noch Filmstrip
http://forum.coppermine-gallery.net/index.php/topic,74799.0.html
Logged

dp-wurzel

  • Coppermine novice
  • *
  • Country: 00
  • Offline Offline
  • Posts: 24
    • Fotos und Bilder gratis downloaden
Re: korrekten title="" und alt="" für die Bilder vergeben
« Reply #3 on: May 21, 2012, 10:33:57 pm »

Hallo,
hm...ich würd ja gern auflösen, weiß aber nicht, ob das wirklich so korrekt ist. Funktioniert jedenfalls ..  :-\
Ich hab einfach in der Theme.php die Zeile:
Code: [Select]
$pic_html .= "<img src=\"" . $picture_url . "\" {$image_size['geom']} class=\"image\" border=\"0\" alt=\"{$lang_display_image_php['view_fs']}\" /><br />";an gepasst und durch:
Code: [Select]
$pic_html .= "<img src=\"" . $picture_url . "\" {$image_size['geom']} class=\"image\" border=\"0\" alt=\"{TITLE}\" title=\"{TITLE}\" /><br />";{TITLE} gibt ja den Bildnamen zurück.

Falls man den Abschnitt:
Code: [Select]
/******************************************************************************
** Section <<<theme_html_picture>>> - START
******************************************************************************/
nicht in seiner Theme.php hat, wie immer aus der >themes>sample>theme.php rauskopieren und in die eigene Template "theme.php" reinkopieren.
Verbesserungen/Korrekturen nehm ich gern....
Den Rest hab ich übrigens jetzt so gemacht wie es in dem anderen Artikel zu lesen war. Danke!! Hat funktioniert.

MfG dp-wurzel
Logged
Pages: [1]   Go Up
 

Page created in 0.018 seconds with 20 queries.