Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Update from 1.5.12 to .20. Getting jibberish in the header  (Read 4279 times)

0 Members and 1 Guest are viewing this topic.

rvsuper8

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Update from 1.5.12 to .20. Getting jibberish in the header
« on: April 09, 2012, 06:05:14 pm »

completed the update.
All went fine.
Looks like Im getting information or warnings in the header.
In config/maint I do not have any notices turned on.
Info can be seen here.
http://teamrv.us/coppermine/

Thanks for your help.
Mike

Logged

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1504
  • aka 'i-imagine'
    • Home Page
Re: Update from 1.5.12 to .20. Getting jibberish in the header
« Reply #1 on: April 10, 2012, 12:36:37 am »

Wow - that is a new one to me.  :)

Have you run update.php and versioncheck.php?
    - Have you tried re-uploading all of the cpg files?
    - Are there any files out of place?
        - the structure and location of the files and folders should be
        the same as what you downloaded and unzipped

Do you have anything listed as a Custom header in Config?

Any plugins running?

rvsuper8

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Update from 1.5.12 to .20. Getting jibberish in the header
« Reply #2 on: April 10, 2012, 12:42:05 am »

Update. Yes. Ran complete.
Version check. Yes. Happy green check marks all the way down showing .20
All files copied over and the rest of the system seems to be working just fine.
No custom headers
No plug ins running and I have them turned off.

Logged

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1504
  • aka 'i-imagine'
    • Home Page
Re: Update from 1.5.12 to .20. Getting jibberish in the header
« Reply #3 on: April 10, 2012, 01:11:44 am »

Wow (again) - it looks like it is loading sections
of a language file before it starts creating the cpg page(s).

I have tried a few that should not show influences from themes and config settings.

So please try as a test...

Create a file called test.php with this code:

Code: [Select]
<?php
echo 'testing';
?>


Save, upload to your gallery root directory, and run it.
Reply with the result.
 

rvsuper8

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Update from 1.5.12 to .20. Getting jibberish in the header
« Reply #4 on: April 10, 2012, 01:59:43 am »

returned testing.
You can see at
http://teamrv.us/coppermine/test.php
Logged

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1504
  • aka 'i-imagine'
    • Home Page
Re: Update from 1.5.12 to .20. Getting jibberish in the header
« Reply #5 on: April 10, 2012, 02:50:24 am »

I am stuck for an answer, so if I were at your keyboard then,

1) Check for any .htaccess files that out of place

2) Unzip the cpg 1.5.20 with something that absolutely doesn't add / change any of the files
(I use Peazip)
and
Re-upload the cpg 1.5.20 package in binary mode with an FTP app that does the same as above

I assume you have no custom / modified files installed. 

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: Update from 1.5.12 to .20. Getting jibberish in the header
« Reply #6 on: April 12, 2012, 10:26:55 am »

Your gallery is currently running cpg1.5.12 and works as expected to me, so I guess you reverted the update?
Logged

rvsuper8

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Update from 1.5.12 to .20. Getting jibberish in the header
« Reply #7 on: April 12, 2012, 02:23:33 pm »

Yes I reverted back until I can figure out whats going on with it.
My plan is to try the upgrade again.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: Update from 1.5.12 to .20. Getting jibberish in the header
« Reply #8 on: April 12, 2012, 02:55:47 pm »

If you don't want to mess up your live gallery, create a copy (preferably on the same server) and apply the update on the copy.
Logged
Pages: [1]   Go Up
 

Page created in 0.018 seconds with 19 queries.