Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Recover from failed bridging  (Read 5850 times)

0 Members and 1 Guest are viewing this topic.

egfg

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
Recover from failed bridging
« on: March 31, 2012, 11:03:24 am »

 link to your site: http://www.egfg.org/photos/
 a test user account: Guest
 and what you have set in the bridge manager : I can't login to look at it!

Problem: "you can not log in as admin to switch it off again"

O.K. here's what's going on. Years ago I successfully bridged Coppermine & phpBB2. It still works fine. I just upgraded phpBB2 to phpBB3, and I now have two separate Message Boards.
When I try to use the Bridge Manager, it wants me to logon, as stated below:
Code: [Select]

if you are not logged in...and you access the URL of your bridge manager (http://www.egfg.org/photos/bridgemgr.php)
...you are prompted to enter your admin account details - use the admin account you used to install coppermine with in the first place (the
 standalone admin account). This will not log you in, but switch integration off, so you can fix improper bridging settings then.
Well, I'm using the only administrator account that I have - and I can't logon to Bridge Manager with it.

What I want to do is remove the bridge from phpBB2 and point it to the new Message Board (phpBB3).

Would this effectively remove bridging (without breaking anything)?
Code: [Select]
DROP TABLE IF EXISTS `cpg_bridge`;
CREATE TABLE `cpg_bridge` (
  `name` varchar(40) NOT NULL default '0',
  `value` varchar(255) NOT NULL default '',
  UNIQUE KEY `name` (`name`)
) ENGINE=MyISAM DEFAULT CHARSET=latin1;
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Recover from failed bridging
« Reply #1 on: April 03, 2012, 01:02:53 pm »

In your MySQL database, go to the config table, find bridge_enable and set it to '0'.
Logged

egfg

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
Re: Recover from failed bridging
« Reply #2 on: April 04, 2012, 08:54:15 pm »

Thank you.
I've had nothing but trouble upgrading from phpBB2 to phpBB3. Coppermine is "sort of" working now.

I have a new issue with bridging, although the bridge appears to work. When I execute bridge/phpbb3.inc.php I am able to Disable bridging just fine,however, when I Enable bridging for phpBB3, I get the following  error message...

Fatal error: Cannot redeclare class cpg_udb in {hidden puposely -egfg}/bridge/phpbb3.inc.php on line 41

Notes: I have edited phpbb3.inc.php to add   $this->admingroups = array(16);
          I had password trouble with MySQL and phpMyAdmin. I believe they are now in synch and I set them back to what Coppermine had originally.
       
Logged

egfg

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
Re: Recover from failed bridging
« Reply #4 on: April 05, 2012, 09:24:46 am »

I did a bunch of testing tonight, learned some things, still not sure why it does that?!

- I made 2 brand new databases and propagated them with Coppermine database backups. One of them was from 3/17 (before doing the phpBB2 to phpBB3 upgrade). The other was from a backup of today's Coppermine data.

- I reapplied all the source files for Coppermine 1.5.20, then re-edited phpBB3.init.php (for the admin #16).

- I swapped databases through config.php (several times).

- Then I tried all kinds of bridging enables, disables, etc...

Results: On two separate ocassions, the bridgemgr.php script ran completely without failing. I know the first time was when I used the 3/17 restored database. However, I can't repeat the results. Most of the time I get the error message about cpg_udb. Don't know what else I can do? Bridging works, but it just bugs me!

Ha! I just got an email about a reply to this post...as I'm typing.
Logged

egfg

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
Re: Recover from failed bridging
« Reply #5 on: April 05, 2012, 09:33:14 am »

Sorry if that is two questions. It was the same "problem" to me. I consider the first question solved. I'll start a new thread for the other.
Logged
Pages: [1]   Go Up
 

Page created in 0.017 seconds with 19 queries.