Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Some albums not appearing for users?  (Read 3922 times)

0 Members and 1 Guest are viewing this topic.

Caith

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Some albums not appearing for users?
« on: March 25, 2012, 11:08:07 pm »

Forum URL: http://crossdressers-forum.com/forums/index.php
Gallery URL: http://crossdressers-forum.com/galleria/index.php
(PM me for phpBB3 forum login information)

When logged into our phpBB3 forum as an administrator, I can see all users' albums.  A very minor item I noticed on the front page of the gallery, the two sets of statistics for users and albums don't agree with each other.  A more pressing problem is, our users cannot see all of the other users' albums.  Our gallery was recently upgraded from an older 1.3.2 version of CPG, so this could have something to do with the issue.  We've also recently upgraded our phpBB discussion forum from 2.0.23 to 3.0.10.  During that upgrade, I un-bridged the gallery and then re-bridged it to the new phpBB 3.0.10 forums, and immediately edited all of the groups' permissions.

Is there something in the cpg_albums table that allows or prevents one user from seeing another user's album?  Or is the issue more complex than that?  I'm reasonably proficient with SQL and have phpMyAdmin access to the database.  As noted above, please PM me for login information.  Thank you.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: Some albums not appearing for users?
« Reply #1 on: March 26, 2012, 02:05:33 pm »

As guest I can see 69 users with total 73 albums (which is exactly what the stats pages tell me).

our users cannot see all of the other users' albums
Please post some album IDs (or links to those albums). You can also have a look directly in your database, maybe you see something suspicious yourself.
Logged

Caith

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: Some albums not appearing for users?
« Reply #2 on: March 26, 2012, 02:51:19 pm »

Some rows in cpg_albums have VISIBILITY = 0 (zero) and others have VISIBILITY = 2.   What's confusing is, some users cannot see their own albums!  :'(  Can I set this column to a single value?  We should have over 200 albums, altogether.
Logged

Caith

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: Some albums not appearing for users?
« Reply #3 on: March 26, 2012, 02:58:15 pm »

Attached is a snapshot of the index/home page, showing the disagreement between two sets of statistics.  This difference is truly not our most pressing issue, but it illustrates there are far more albums than the 69 seen by guests and non-privileged users.
Logged

Caith

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: Some albums not appearing for users?
« Reply #4 on: March 26, 2012, 03:04:21 pm »

Here are the URLs to two of the "missing" or "invisible" galleries.  I can see them as an administrator. When logged in, user # 5426 cannot see their own photos.

/galleria/index.php?cat=15426
/galleria/index.php?cat=12140
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: Some albums not appearing for users?
« Reply #5 on: March 26, 2012, 03:57:01 pm »

Visibility '0' means "no restrictions" (at least that's the case in unbridged galleries). Create a backup or dump of your database and try to set all albums' visibility to '0'.
Logged

Caith

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: Some albums not appearing for users?
« Reply #6 on: March 26, 2012, 04:04:10 pm »

Thank you, Andre'.  This morning I have reset selected galleries to VISIBILITY = 0, and they are again appearing as before.  I suspect the much older version of CPG we were running did not properly honor this value, and people may have randomly changed it to no effect.  Now that v1.5.18 honors the column, their albums seemed to have disappeared.  In reality, nothing was ever lost, only the visibility to it.

I'm tempted to set ALL albums visibility to zero, but would rather not do that just yet.  I will wait and see how many other users come forward and then manually reset their individual albums upon request.  Thank you for your assistance, and I will be marking this issue as resolved immediately.  :)
Logged
Pages: [1]   Go Up
 

Page created in 0.03 seconds with 20 queries.