Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Online Stats Problem  (Read 2631 times)

0 Members and 1 Guest are viewing this topic.

nowordneeded

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 224
Online Stats Problem
« on: March 12, 2012, 04:38:37 pm »

I currently have about ten galleries I'm running CPM on and out of all of them, I only have this problem on one. The URL is: http://stephennichols.org/gallery . I am running 1.5.18 on it having upgraded last week. I didn't see the new version posted back in Jan. The problem is when I update the gallery the Online Stats plugin causes a Critical Error to occur and takes my gallery offline. But only this one. This problem started when I upgraded from 1.14.x to 1.15.x. What happens is that as long as the plug in is part of the package, it takes the gallery offline. When I delete the plugin through my FTP or remove it prior to uploading the upgrade files, it's fine. What could be causing this?

Thanks.

NWN
Logged
Sometimes my musings are too confusing for someone not inside my head.

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: Online Stats Problem
« Reply #1 on: March 12, 2012, 06:20:45 pm »

I assume you've installed the plugin sometime before the update (so it's not just "there", but you also use it)?

Please enable debug mode and post the extended error message the plugin produces.
Logged

nowordneeded

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 224
Re: Online Stats Problem
« Reply #2 on: March 15, 2012, 11:47:11 am »

Sorry I didn't reply to this before now. I've had personal issues to deal with and haven't been back online until today.

As for the plugin, no I'm not using it on this gallery. I've had to delete it from the plugins folder in order to allow the gallery to become visible. Otherwise it only shows CRITICAL ERROR in the page when I would go to access the index.php page. I should add some other information I'm sorry I omitted from my first post. I was moving the entire website from one account to another on Bravehost. I was able to do this and was also able to download the database from the other server account. However, when I went to view the gallery on the new server, I received the Critical Error page. I contacted my host to find out what I could do and they told me it might be in the plugin. I deactivated it and the gallery was fine. So when I upgraded from 1.15.16 to 1.15.18, the OnlineStats plugin was in the folder and I forgot to clear it. When I upgraded I got the Critical Error message. I went in through my FTP program and deleted the plugin and the gallery was back.

I'm not sure if I could enable debug mode on the plugin since the plugin is no longer in the folder.

NWN
Logged
Sometimes my musings are too confusing for someone not inside my head.

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: Online Stats Problem
« Reply #3 on: March 15, 2012, 12:03:57 pm »

I'd like investigate that issue. Please enable debug mode and upload the plugin to your plugins directory.
Logged

nowordneeded

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 224
Re: Online Stats Problem
« Reply #4 on: March 17, 2012, 10:56:04 am »

Done. You can find the gallery @ http://stephennichols.org/gallery . Again, I'm running 1.5.18.

Thanks.

NWN
Logged
Sometimes my musings are too confusing for someone not inside my head.

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: Online Stats Problem
« Reply #5 on: March 19, 2012, 09:55:59 am »

Error message:
Quote
While executing query 'DELETE FROM cpg14x_mod_online WHERE last_action < NOW() - INTERVAL  MINUTE' in plugins/onlinestats/codebase.php on line 122

Obviously the config value "mod_updates_duration" doesn't exist in your database, causing an error in the SQL syntax.

To fix that issue, open codebase.php, find
Code: [Select]
cpg_db_query("DELETE FROM {$CONFIG['TABLE_ONLINE']} WHERE last_action < NOW() - INTERVAL {$CONFIG['mod_updates_duration']} MINUTE");and replace with
Code: [Select]
//cpg_db_query("DELETE FROM {$CONFIG['TABLE_ONLINE']} WHERE last_action < NOW() - INTERVAL {$CONFIG['mod_updates_duration']} MINUTE");
As that line is just executed when the plugin is installed, go to the plugin manager and uninstall the onlinestats plugin. If you now replace the plugin with the unmodified files, the error shouldn't occur.
Logged

nowordneeded

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 224
Re: Online Stats Problem
« Reply #6 on: March 19, 2012, 01:09:47 pm »

The plugin is finally working. Thanks for the help Andre. I'm glad the issue is finally solved.

NWN
Logged
Sometimes my musings are too confusing for someone not inside my head.
Pages: [1]   Go Up
 

Page created in 0.021 seconds with 20 queries.