Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1] 2   Go Down

Author Topic: [SOLVED]Random pictures, comments and Rating errors  (Read 8325 times)

0 Members and 1 Guest are viewing this topic.

can93

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 38
[SOLVED]Random pictures, comments and Rating errors
« on: June 30, 2004, 01:59:18 pm »

Hello everyone, :)

I'm a french person, so excuse my english... lol

I have two problems for the moment... :-\\

When coppermine generate random images, they're clickable but show an server error 500  ???, but when i go in most popular, the image is here that mean coppermine was accepted the click but don't show the image :o...what's the problem ?

And, when i want to rate a photo an error server 500 appear...But the rate it's accepted when i see the most rated... :-\\ ???

I don't understand... please help me !!! :\'( :-*
« Last Edit: July 05, 2004, 11:20:36 am by can93 »
Logged

pinguish

  • Contributor
  • Coppermine novice
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 29
    • Pinguish - A Photographic Community
Re: Random pictures and Rating errors
« Reply #1 on: June 30, 2004, 02:04:53 pm »

whats your server address?..sound like one of the files is corrupt in some way (perhaps displayimage.php?). you could try re-uploading this file.
Logged

can93

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 38
Re: Random pictures and Rating errors
« Reply #2 on: June 30, 2004, 02:19:52 pm »

The adress have some nudity, I can post it ?
Logged

Tarique Sani

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 2712
    • http://tariquesani.net
Re: Random pictures and Rating errors
« Reply #3 on: June 30, 2004, 02:28:51 pm »

The adress have some nudity, I can post it ?
Yes ask long as you put in front of the address a warning about Nudity
Logged
SANIsoft PHP applications for E Biz

pinguish

  • Contributor
  • Coppermine novice
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 29
    • Pinguish - A Photographic Community
Re: Random pictures and Rating errors
« Reply #4 on: June 30, 2004, 02:37:01 pm »

can't look now as in work

(well i took a quick look) and too much nudity for me to have a check of the problem.
if you don't get answer i'll try to look a little later this evening when i get home.
i suspect its a file corruption when u uploaded. try to reupload the base files see if that fixes it (do not re-upload install.lock or config.inc.php)
Logged

can93

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 38
Re: Random pictures and Rating errors
« Reply #5 on: June 30, 2004, 02:59:38 pm »

I'll try to re-upload base files before, if don't obtain anything, i will post the adress...

Thanks
Logged

can93

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 38
Re: Random pictures and Rating errors
« Reply #6 on: June 30, 2004, 04:23:45 pm »

I re-uploaded the files except tje directory "albums" but the problem is always here...

And the problem is the same under Mozilla and Internet Explorer...

The error message is :

Quote
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Nobody has this problem before ?
« Last Edit: June 30, 2004, 04:30:50 pm by can93 »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Random pictures and Rating errors
« Reply #7 on: June 30, 2004, 06:30:34 pm »

I don't get the point. Did you post a link to your gallery on this thread already, as I seem to have overlooked it?
When uploading the coppermine code files to your server, did you make sure to use the proper ftp-mode? It might help as well if you compare the files on your server and your local hard drive (I recommend using a tool like FileWare's FtpSync).

GauGau
Logged

pinguish

  • Contributor
  • Coppermine novice
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 29
    • Pinguish - A Photographic Community
Re: Random pictures and Rating errors
« Reply #8 on: June 30, 2004, 06:33:52 pm »

okay good news...ii don't think its coppermine causing the problem!
its the domain and possibly htaccess setup you have?
*warning these link to adult material* (btw i can edit out the links after if u want to to keep the site a bit private for now)

your link is
1) http://www.kedmeufs.fr.st/

but i see thats forwarded to :

2) http://forig.free.fr/kedmeufs/
your coppermine isntallation knows it sat at 2)

so most of its internal links go to this domain.
i suspect you have htaccess to only allow access to the images from your domain 1)
when u click a link in coppermine its going to 2) and being rejected by the server

OR theres something in the coppermine code and the redirection code thats intefering with each other..
do u have space anywhere else u could try a smaller setup on to test?






Logged

can93

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 38
Re: Random pictures and Rating errors
« Reply #9 on: June 30, 2004, 06:56:37 pm »

Thanks for your response...

But the normal gallery it's full functionnal... i've tryed to put a htaccess but i removed it...

The 1) it's a short adress to guide to 2)... and i repeat i don't have any htacess now...

When i type the adress the number 2) no changes happen...

I don"t try it on local server, because i don't have GD or ImageMagick

I think it's the coppermine code...because the normal gallery, not the random it's functionnal, but rating and comment give the same problem but they are accepted, try it...put a comment or a vote to an image never viewed...





Logged

pinguish

  • Contributor
  • Coppermine novice
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 29
    • Pinguish - A Photographic Community
Re: Random pictures, comments and Rating errors
« Reply #10 on: June 30, 2004, 07:41:12 pm »

click the (i) atthe top when you view an image..
see that url for the image down the bottom?
this doesn't work either...but if change the url it does...not exactly sure why buts it definatly server setup.
due to the content of the site i can't spend that long looking into it :(
« Last Edit: June 30, 2004, 08:02:00 pm by pinguish »
Logged

can93

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 38
Re: Random pictures, comments and Rating errors
« Reply #11 on: June 30, 2004, 08:51:50 pm »

When i click to the (i) to see the informations, it's not the same url...  ???

I have a negative pos   example :   displayimage.php?pos=-22

What's that mean ?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Random pictures, comments and Rating errors
« Reply #12 on: July 01, 2004, 08:42:12 am »

that's expected behaviour, it's kind of an "absolute url" - reference to displayimage.php?pos=-22 will always link to pic no 22, displayimage.php?album=1&pos=22 will differ according to what sorting the user has chosen.

GauGau
Logged

can93

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 38
Re: Random pictures, comments and Rating errors
« Reply #13 on: July 01, 2004, 12:57:35 pm »

that's expected behaviour, it's kind of an "absolute url" - reference to displayimage.php?pos=-22 will always link to pic no 22, displayimage.php?album=1&pos=22 will differ according to what sorting the user has chosen.

GauGau

So, you have a solution for my problem ?

Please help me !!
Logged

can93

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 38
Re: Random pictures, comments and Rating errors
« Reply #14 on: July 01, 2004, 07:36:32 pm »

I tried to restart from the begin but the probleme is always here... i'll try to put it in an another server....


Do you think is displayimage.php ?

I deleted the filles on ftp, and the sql tables but no issues...


Please someone can help me ?
Logged

can93

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 38
Re: Random pictures, comments and Rating errors
« Reply #15 on: July 01, 2004, 10:41:30 pm »

Hello,

I've just tried on local server with Image Magick and EasyPhp, no problem appears, but what change beetween the server on the net and the local server ?


Thanks to help me


Or, if you have a english server who support PHP / Mysql / GD 2.x for install Coppermine i'm agree... with at least of 100 Mo of Disk space and No bandwith limitations, thanks again
« Last Edit: July 01, 2004, 10:52:05 pm by can93 »
Logged

can93

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 38
Re: Random pictures, comments and Rating errors
« Reply #16 on: July 01, 2004, 11:02:17 pm »

It's ok, i understand why the problem appear....

Because the album have a lot of pictures, i've tried on the same server an another albums, with less pictures, these solution function...


thanks for the support
Logged

Casper

  • VIP
  • Coppermine addict
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 5231
Re: Random pictures, comments and Rating errors
« Reply #17 on: July 02, 2004, 12:14:33 am »

We know of coppermine installations with over 200,000 pics, and no trouble.
Logged
It has been a long time now since I did my little bit here, and have done no coding or any other such stuff since. I'm back to being a noob here

can93

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 38
Re: Random pictures, comments and Rating errors
« Reply #18 on: July 02, 2004, 09:46:10 am »

We know of coppermine installations with over 200,000 pics, and no trouble.

in one step ?
Logged

pinguish

  • Contributor
  • Coppermine novice
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 29
    • Pinguish - A Photographic Community
Re: Random pictures, comments and Rating errors
« Reply #19 on: July 02, 2004, 10:59:21 am »

the way the code is written it shouldn't affect it if you have 1 album or 500.
the items you are having problems with look at the picture table (which is all pictures in EVERY album).
from what i did look at it definatly looked like a server config error (and the fact you could get it to work on your PC setup as a server tends to confirm it).
having said that if you found by adding extra albums to the server it solved the problem just run with that ;)
Logged
Pages: [1] 2   Go Up
 

Page created in 0.249 seconds with 20 queries.