Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: php.ini  (Read 54499 times)

0 Members and 1 Guest are viewing this topic.

hoksibish

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
php.ini
« on: March 15, 2012, 04:02:56 pm »

I have a new install and only have one wierd thing going on.  i installed 1.5.18 running PHP 5.3.5.  It is on a hosted server.   we get errors saying exceeded file size allowed in php.ini. the php.ini has been changed to 10mb max_uplaod and max_post has been set to 8mb.  we only get that error when files are over 2mb.  which was the orginal setting.  httpd has been restarted 3 times and the actual host was rebooted as well.  anyone have any other thoughts??

thanks in advance

hoks
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: php.ini
« Reply #1 on: March 15, 2012, 04:35:15 pm »

give it more memory (memory_limit) and keep in mind that the ~2mb files you're talking about are probably compressed ones (jpg or similar). If you're working with them (resizing -> thumbs/ intermediates) they need a lot more memory. That's depending on the size x|y and the color depth.

hoksibish

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: php.ini
« Reply #2 on: March 15, 2012, 04:38:56 pm »

i will look into that thanks..
Logged

hoksibish

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: php.ini
« Reply #3 on: March 15, 2012, 04:40:55 pm »

also phpinfo shows 2mb.... even though php.ini is 10mb.  if it was memory why would error stat file exceeded allowed?
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: php.ini
« Reply #4 on: March 15, 2012, 04:58:09 pm »

have you checked apache conf for limits?

hoksibish

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: php.ini
« Reply #5 on: March 15, 2012, 05:05:24 pm »

i will look.  but i am still curious as to why cpg shows 2mg on phpinfo even though the actuall ini shows 10mb.  any thoughts as to why cpg isnt reading the updated php.ini...

thanks in advance
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: php.ini
« Reply #6 on: March 15, 2012, 05:15:39 pm »

That's not related to Coppermine. Depending on your web server, it may be possible that there's more than 1 php.ini file. So you need to find the correct one to increase the limits. E.g. in my local testbed running XAMPP there are two php.ini files. The memory_limit doesn't matter at this point.
Logged

hoksibish

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: php.ini
« Reply #7 on: March 15, 2012, 05:20:12 pm »

that is a valid point.  on the hosting side  it is a shared environment and that the hoster had set the global php.ini to 10M, and restarted apache, however when you look at the phpinfo it still shows 2mb.  the hoster is running cpanel, if you look at phpinfo there shows 10M.  crazy huh...
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: php.ini
« Reply #8 on: March 15, 2012, 05:30:42 pm »

There's something wrong with the server setup. Coppermine uses the standard PHP function phpinfo to display the current settings. Please contact your hosting provider.
Logged

hoksibish

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: php.ini
« Reply #9 on: March 15, 2012, 05:55:14 pm »

we will reboot the box tonight and see if something maybe cached...  thanks for the posts  will let you all know.
Logged
Pages: [1]   Go Up
 

Page created in 0.018 seconds with 20 queries.