Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Please help with upgrade from 1.4. Existing critical error  (Read 3520 times)

0 Members and 1 Guest are viewing this topic.

wickeddivine

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Female
  • Posts: 22
Please help with upgrade from 1.4. Existing critical error
« on: March 11, 2012, 09:15:57 pm »

Hello,
I currently have version 1.4.12 installed.  My web hosting account was hacked this weekend, and my web host went through and "cleaned" the files.  Currently, the gallery shows this error:
"There was an error while processing a database query"
My gallery is at http://greenerpastures.us/gallery.

I'm not sure if this error is because of the hacking, or because the web host cleaned the files.  They saved all of the original hacked files in a separate folder.  Can someone please tell me how I should fix this?  I want to upgrade to the latest version.  Do you think it's safe to just proceed with a normal upgrade?  Or should I fix this error first?  The only plugin I think I was using was the bridge to SMF forum, but I'm not sure if that was really a plugin?  I say this, because the upgrade instructions mention that you should disable all plugins before proceeding.
I can't log in to enable debug mode, or disable plugins.  The gallery won't do anything but display that error message.

Any help would be greatly appreciated.  :)

Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Please help with upgrade from 1.4. Existing critical error
« Reply #1 on: March 12, 2012, 11:03:47 am »

Your gallery works as expected for me. It is currently running cpg1.4.13. You should at least upgrade to the latest cpg1.4.x release (currently cpg1.4.27) immediately, to fix the security vulnerabilities. Then you can consider upgrading to cpg1.5.x.
Logged

wickeddivine

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Female
  • Posts: 22
Re: Please help with upgrade from 1.4. Existing critical error
« Reply #2 on: March 12, 2012, 11:11:46 pm »

Hi Andre,

I've just found that it works until I click the login button, and then the critical database error appears, and doesn't go away.  Perhaps it's because I upgraded the associated forum without disabling the bridge (dumb-I didn't even think of it)?  Is there a way to disable the bridge from the database or something?

Is it a bad idea to upgrade right from 1.4.13 to the latest version?

Thank you very much.
Logged

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1503
  • aka 'i-imagine'
    • Home Page
Re: Please help with upgrade from 1.4. Existing critical error
« Reply #3 on: March 13, 2012, 01:03:13 am »

Is there a way to disable the bridge from the database or something?
1) Read the document package - click the link at the top of this page or read what came with your cpg .zip download

2) Go to: http://greenerpastures.us/gallery/bridgemgr.php

Is it a bad idea to upgrade right from 1.4.13 to the latest version?
No

Again, read the docs: http://documentation.coppermine-gallery.net/en/upgrading.htm#upgrade_14

wickeddivine

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Female
  • Posts: 22
Re: Please help with upgrade from 1.4. Existing critical error
« Reply #4 on: March 13, 2012, 11:47:52 pm »

Thank you very much for the link to the bridge manager.  I don't know if I would have found that.  About the version question, I only asked because Andre mentioned considering upgrading to 1.5, so it made me wonder if maybe I should update to 1.4.27 before I attempted to upgrade to 1.5.

Thank you so much.  I appreciate your help.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Please help with upgrade from 1.4. Existing critical error
« Reply #5 on: March 14, 2012, 09:00:20 am »

Upgrading from cpg1.4.x to cpg1.5.x may involves more tasks than just replacing some files (as it's done for an update from cpg1.4.x to cpg1.4.x), that's why I suggested to first perform the "easy" update to fix the security issues of your outdated version.
Logged
Pages: [1]   Go Up
 

Page created in 0.023 seconds with 21 queries.