Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Images not displaying (thumbs, normal, full)  (Read 4300 times)

0 Members and 1 Guest are viewing this topic.

Hanna.

  • Coppermine frequent poster
  • ***
  • Country: us
  • Offline Offline
  • Gender: Female
  • Posts: 206
  • webstar
Images not displaying (thumbs, normal, full)
« on: January 23, 2012, 12:19:51 pm »

Weeks ago I switched hosts and they backup-ed my database for Coppermine and moved it from http://67.159.44.20/~kristind/photos to http://kristindaily.org/photos/. If you hit those two pages you will see the difference pretty clear. I have tried to run update.php and admin tools to update everything but none of it works.

I'm not sure what to try next? I need the photos to work... I have over 30,000 files in there.

Please help me out!
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Images not displaying (thumbs, normal, full)
« Reply #1 on: January 23, 2012, 12:40:19 pm »

I just checked some picture paths and always got an HTTP 404 error code. Please check your albums directory if your files & folders are present at the new location.
Logged

Hanna.

  • Coppermine frequent poster
  • ***
  • Country: us
  • Offline Offline
  • Gender: Female
  • Posts: 206
  • webstar
Re: Images not displaying (thumbs, normal, full)
« Reply #2 on: January 25, 2012, 10:54:06 am »

It will take a while, but don't close this topic just yet. The database backup went through, now I just need to transfer the files? Then what? I run update.php or?

Thanks,
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Logged

Hanna.

  • Coppermine frequent poster
  • ***
  • Country: us
  • Offline Offline
  • Gender: Female
  • Posts: 206
  • webstar
Re: Images not displaying (thumbs, normal, full)
« Reply #4 on: February 05, 2012, 08:05:45 pm »

I have figured that out now. But I still have one question... Is it possible to block hotlinking for certain images on my server. In this case I'd like to protect my normal_ (prefix pics). Can somebody give me the PHP code for it or whatever? I really need it. Thanks.
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Images not displaying (thumbs, normal, full)
« Reply #5 on: February 06, 2012, 11:41:53 am »

.htaccess
Code: [Select]
<Files normal_*>
    Order deny,allow
    Deny from all
    Allow from localhost
</Files>

that'll allow local scripts to access the pics. If you do not want that, remove the line starting with Allow

Hanna.

  • Coppermine frequent poster
  • ***
  • Country: us
  • Offline Offline
  • Gender: Female
  • Posts: 206
  • webstar
Re: Re: Images not displaying (thumbs, normal, full)
« Reply #6 on: February 06, 2012, 12:56:37 pm »

.htaccess
Code: [Select]
<Files normal_*>
    Order deny,allow
    Deny from all
    Allow from localhost
</Files>

that'll allow local scripts to access the pics. If you do not want that, remove the line starting with Allow

Fantastic! It works!!! Thank you SO much!
Logged

Hanna.

  • Coppermine frequent poster
  • ***
  • Country: us
  • Offline Offline
  • Gender: Female
  • Posts: 206
  • webstar
Re: Images not displaying (thumbs, normal, full)
« Reply #7 on: February 06, 2012, 09:07:59 pm »

It works with the hotlinking, but what if I upload the .htaccess to the /photos directory? Then the photos on public_html won't get affected, right? As it looks now, Facebook can't reach my photos from the mainpage... It's because of these .htaccess settings.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Images not displaying (thumbs, normal, full)
« Reply #8 on: February 24, 2012, 03:58:50 pm »

Please read and follow our board rules.

Marking as solved and locking.
Logged
Pages: [1]   Go Up
 

Page created in 0.06 seconds with 20 queries.