Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Bridging between SMF and Coppermine 1.5.18  (Read 6471 times)

0 Members and 1 Guest are viewing this topic.

pols1337

  • Coppermine frequent poster
  • ***
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 244
Bridging between SMF and Coppermine 1.5.18
« on: January 13, 2012, 08:03:46 am »

Hi,

I recently installed / updated / versioncheck my galleries with the newest Coppermine 1.5.18.  My CPG is bridged with SimpleMachinesForum (SMF).  Did anything affect the bridging? 

After I log-in to SMF, when I go visit my Coppermine gallery it does not recognize me.  I need to click on "Gallery Home," which I guess refreshes the page or cookies and then it shows me as being logged-in.  See attachment (using i-feel-dirty theme).  Many of my users are very confused since Coppermine does not auto-recognize the user the initial time. 

Logged

lurkalot

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 933
  • +Tinyportal Support team.
Re: Bridging between SMF and Coppermine 1.5.18
« Reply #1 on: January 13, 2012, 09:51:01 am »

pols1337  As far as I'm aware the bridging hasn't been altered, and doesn't seem to have changed anything with my setups.  There was a couple of changes made to cookie handling.  Not sure this would have anything to do with your problem though.

  • Fixed infinite loop for delayed cookie issue workaround (thread)
  • Disallow dots in cookie name (thread)

I'm assuming your using SMF 2.0.2?  you didn't say.  What settings do you have in your SMF server setting?  this is what I use,

Admin > configuration > Server settings > cookies and sessions

Enable local storage of cookies  (no tick)
Use subdomain independent cookies (no tick)
Force cookies to be secure (no tick)
Use database driven sessions (ticked)
Allow browsers to go back to cached pages (ticked)
Logged
Running SMF 2.0.15  / Tinyportal 1.6.4, bridged with Coppermine 1.6.06, plus cpmfetch 2.0.0

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Bridging between SMF and Coppermine 1.5.18
« Reply #2 on: January 13, 2012, 11:18:25 am »

Please post a link to your gallery and a test user account.
Logged

pols1337

  • Coppermine frequent poster
  • ***
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 244
Re: Bridging between SMF and Coppermine 1.5.18
« Reply #3 on: January 13, 2012, 10:50:31 pm »

Thanks for the responses @lurkalot and @Andre

1.  Yes, I am using Coppermine 1.5.18 and SMF 2.0.2. 

2.  Yes I am using the same settings as you in SMF's Server Settings > Cookies and Sessions  (see screenshot)

3.  Test account information
test256
oxdeadbeef16

SMF Forum (log-in): universeofmen.com
CPG Gallery: universeofmen.com/gallery/
Logged

pols1337

  • Coppermine frequent poster
  • ***
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 244
Re: Bridging between SMF and Coppermine 1.5.18
« Reply #4 on: January 13, 2012, 10:54:33 pm »

Something else that I've noticed ... if you take a look at my first screenshot (in post 1), you'll see Gallery Menu > "Gallery Home" and Admin Menu > "Home".  Although I'm using a custom "i-feel-dirty" theme, I'm sure the default theme has similar functionality. 

The bridging only re-establishes if you click on Gallery Home.  Clicking on Home does not refresh the bridge, even though it redirects you to the index page of the gallery too.  Very weird.   

By the way, you can test on any of my galleries:
universeofmen.com/gallery/
universeofmen.com/charly/
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Bridging between SMF and Coppermine 1.5.18
« Reply #5 on: January 18, 2012, 03:23:22 pm »

I just tested the login and it seems to work as expected for me, at least with the test account. Procedure:
- Opened the gallery
- Clicked "login" and got redirected to the SMF login form
- After submitting the form I'll get redirected to the gallery, which recognizes me and shows me all available menus
Logged

pols1337

  • Coppermine frequent poster
  • ***
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 244
Re: Bridging between SMF and Coppermine 1.5.18
« Reply #6 on: January 18, 2012, 09:34:28 pm »

[Resolved]

Yeah, I don't know what was going on with my galleries ... maybe it was after the Coppermine upgrade, the gallery doesn't recognize users the first time they re-visit although I don't know if the cache was cleared or if the bridge or cookies were affected.  Oh well.  :o
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Bridging between SMF and Coppermine 1.5.18
« Reply #7 on: January 18, 2012, 09:56:55 pm »

Logged
Pages: [1]   Go Up
 

Page created in 0.023 seconds with 20 queries.