Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: how do you chage the colour of the "browse" button text??  (Read 8782 times)

0 Members and 1 Guest are viewing this topic.

antiother

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
how do you chage the colour of the "browse" button text??
« on: December 13, 2011, 06:48:07 pm »

Good day,

  • I am using Coppermine 1.5.16 and my gallery is running on a WAMP server on my PC for testing, so I won't be able to provide you with the URL because it's "localhost/cpg/index.php".
  • I am editing the "sample" theme found in the "themes" folder in the Coppermine root directory. When I want to upload an image, the browse button that I have to click to search for the image text is nearly the same colour as the button image and barely visible as you can see in the image I attached. I found the css controlling this using Firebug extension for Firefox, but I don't know which CSS file controls this (see image).
  • Would you be so kind as to let me know which file I must edit to change this value please.

Regards,
antiother
Logged

antiother

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: how do you chage the colour of the "browse" button text??
« Reply #1 on: December 13, 2011, 07:05:21 pm »

(update on the situation!!)

It looks like I found the controlling css selector for this element.

I just added "colour: #000;" to the "div.fieldset" selector in the "style.css" file and the text now seems to be black like I was hoping for.

I appreciate your time if you read my question, but it looks like this one is solved. @antiother thanks you ^_^

Regards,
antiother
Logged

antiother

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: how do you chage the colour of the "browse" button text??
« Reply #2 on: December 13, 2011, 07:18:26 pm »

(update on the situation!!)

It looks like I found the controlling css selector for this element.

I just added "colour: #000;" to the "div.fieldset" selector in the "style.css" file and the text now seems to be black like I was hoping for.

I appreciate your time if you read my question, but it looks like this one is solved. @antiother thanks you ^_^

Regards,
antiother

Well, I hit ctrl+f5 and the button colour changed back to awful. HELP PLEASE!! I have the same problem again. Where do I edit to change the colour of this text??
Logged

antiother

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: how do you chage the colour of the "browse" button text??
« Reply #3 on: December 13, 2011, 07:46:44 pm »

HA!! fixed ^_^ I found the file I had to edit to change the colour!!

edit the line:
Code: [Select]
button_disabled_style = '.browse { font-family: Arial,Helvetica,sans-serif; color: #D0CFD0;}'; in the file: "upload.js" found at "gallery root directory > js > upload.js".

i changed the color property to #000 (shorthand hash value for black)

all solved :)) thanks again.

Regards,
antiother
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: how do you chage the colour of the "browse" button text??
« Reply #4 on: December 14, 2011, 10:44:33 am »

The button style changes automatically as soon as you choose an album. As that button is disabled if no album is selected, it's displayed accordingly.

However, thanks for resolving your thread.
Logged

JulioF

  • Coppermine newbie
  • Offline Offline
  • Posts: 1
Re: Re: how do you chage the colour of the "browse" button text??
« Reply #5 on: May 10, 2016, 01:34:45 am »

I was encountering the same problem, using the "Curves" theme. Very difficult to read the text inside that button! And yes, I had an album open/selected.

Thanks to antiother for the info! Very helpful! Saved me much wasted time.

Sorry, André. The button is displayed in "disabled" mode regardless. Someone may want to fix this issue.

The button style changes automatically as soon as you choose an album. As that button is disabled if no album is selected, it's displayed accordingly.

However, thanks for resolving your thread.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: how do you chage the colour of the "browse" button text??
« Reply #6 on: May 10, 2016, 09:30:31 am »

The button is displayed in "disabled" mode regardless. Someone may want to fix this issue.

Today it doesn't work anymore, while it in 2011. Reason:

that happens since quite a while because of some changes with the Flash player (worked until Flash player 9 or so)


However, I'll consider to change the default button text color.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: how do you chage the colour of the "browse" button text??
« Reply #7 on: May 10, 2016, 11:12:13 am »

Changed default color of flash upload button in SVN revision 8844. Will be part of cpg1.5.42.
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 2026
Re: how do you chage the colour of the "browse" button text??
« Reply #8 on: May 10, 2016, 02:09:15 pm »

The flash upload 'browse' button UI has been corrected in CPG 1.6 as well.
Logged
Pages: [1]   Go Up
 

Page created in 0.139 seconds with 19 queries.