Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Trouble Installing Forum Plugin for 1.5  (Read 4087 times)

0 Members and 1 Guest are viewing this topic.

chuckMc63

  • Coppermine newbie
  • Offline Offline
  • Posts: 1
Trouble Installing Forum Plugin for 1.5
« on: October 28, 2011, 09:26:36 am »

Everytime I try to install the forum plugin, I get this message:
Parse error: syntax error, unexpected T_ENCAPSED_AND_WHITESPACE, expecting T_STRING or T_VARIABLE or T_NUM_STRING in /home/content/m/a/s/masontheking/html/jstklsxnet/live/plugins/forum/codebase.php on line 124

Is this from just uploading the zip, or should I unzip and load via FTP? There are really no instructions in the folder. I would like to get this to work.
Thanks for the replies.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: Trouble Installing Forum Plugin for 1.5
« Reply #1 on: October 28, 2011, 12:18:21 pm »

Open codebase.php, find
Code: [Select]
if (!USER_ID && ($CONFIG['fr_guest_browse'] == 0)) {and replace with
Code: [Select]
if (!USER_ID && (\$CONFIG['fr_guest_browse'] == 0)) {
Logged

egorip

  • Coppermine newbie
  • Offline Offline
  • Posts: 1
Re: Trouble Installing Forum Plugin for 1.5
« Reply #2 on: November 13, 2011, 02:33:02 pm »

I had the same problem.
Thx it works ;)
Logged
Pages: [1]   Go Up
 

Page created in 0.015 seconds with 21 queries.