Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Upgraded to 1.5.16 and now 'upload file' and 'My Gallery' always appear  (Read 5678 times)

0 Members and 1 Guest are viewing this topic.

scohen125

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 100
    • Retina Gallery

I initially posted this problem under themes, but now realize it is a problem with my upgrade.  Something happened when I upgraded from 1.5.8 to 1.5.16.  I am getting errors in debug mode and the 'upload file' and 'my gallery' links appear to visitors even though the groups manager does not allow people not logged in to upload files. 

Just in case it might work to fix the menu problem on the home page (it didn't):

I uploaded a fresh version of Coppermine 1.5.16 (from the coppermine site),
I ran the update.php,
I checked for version problems and there were no errors or problems with my version,
I went back into group manager and made sure that anonymous users were not allowed a gallery or to upload files in group manager.
I've also disabled all plugins.

www.RetinaGallery.com still shows the 'upload file' link and 'my gallery' link on the homepage for non-logged in users.

I have set the site to debug mode.  I have also created a test user with username: 'test' and password 'test' .
I will very very very much appreciate any help.
The homepage of the site yields the following error message:

/index.php逼otice line 466: Undefined variable: FORBIDDEN_SET

over and over again in the debug mode.

I am preparing to publicize my website to potential users and would like to remove the error from the website first.

Thank you,

Steven Cohen
Logged

scohen125

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 100
    • Retina Gallery
Re: Upgraded to 1.5.16 and now 'upload file' and 'My Gallery' always appear
« Reply #1 on: October 01, 2011, 06:36:47 pm »

Also, my website www.RetinaGallery.com is not bridged nor has it ever been bridged.  I am hosted on GoDaddy and there hosting has, in the past, messed up a .php website because of their removing my /temp directory.  It could be GoDaddy messing it up.  Still, the website worked perfectly as 1.5.8 and with the upgrade to 1.5.16 is not working correctly.
Logged

scohen125

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 100
    • Retina Gallery
Re: Upgraded to 1.5.16 and now 'upload file' and 'My Gallery' always appear
« Reply #2 on: October 01, 2011, 06:40:02 pm »

Sorry to keep adding but one more thing that might be important is that I uploaded the new coppermine files using the file transfer protocol inside of Dreamweaver CS5. 
Logged

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1504
  • aka 'i-imagine'
    • Home Page

Please don't over-post. A few volunteers do what they can with their spare time here.

Do not use the method that you described to upload the cpg files to your server.
Filezilla or another reliable FTP is the only way to upload the files. Set it to binary mode. Use a good program to unzip your package. I use Peazip without issues.

You should also consider using your database backup and/or checking to see if your db is damaged. Your host probably has the tools available to you - phpMyAdmin is typically available.

scohen125

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 100
    • Retina Gallery
Re: Upgraded to 1.5.16 and now 'upload file' and 'My Gallery' always appear
« Reply #4 on: October 01, 2011, 11:20:45 pm »

Thank you for the suggestions.  I used Peazip and then Filezilla.  The erroneous menu items still appear.  When I ran update.php I got the following messages in  debug:


Notices



/update.php標arning line 33: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /home/content/52/6897452/html/update.php:2)
標arning line 33: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/content/52/6897452/html/update.php:2)
 


/include/themes.inc.php標arning line 1559: Cannot modify header information - headers already sent by (output started at /home/content/52/6897452/html/update.php:2)
標arning line 1560: Cannot modify header information - headers already sent by (output started at /home/content/52/6897452/html/update.php:2)
 


/include/functions.inc.php標arning line 162: Cannot modify header information - headers already sent by (output started at /home/content/52/6897452/html/update.php:2)
 


I am not sure how to check if my database is damaged.  I can access the database in phpMyAdmin on my site, but don't know what to look for to see if it is damaged.

Also, the site is now in debug mode.

I will continue to appreciate help in solving this problem.

Thanks,
Sorry about all the posts.
Steve
Logged

scohen125

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 100
    • Retina Gallery
Re: Upgraded to 1.5.16 and now 'upload file' and 'My Gallery' always appear
« Reply #5 on: October 02, 2011, 10:57:28 pm »

I restored an old database file from June 2011,
I used Peazip to unzip a fresh download of the coppermine package 1.5.16,
I uploaded the website using Filezilla,

and ...
the erroneous menu items still appear.  They did not appear with coppermine 1.5.8.  I can upload the older coppermine code to fix the problem, but I'd like to get my website working with the newer package.  Is it possible that there is a problem with something in the new code?  I will appreciate any help with this problem.  My website is still set to 'debug' mode and has a test user with username test and password test.

Thank you for all the suggestions so far.
Logged

scohen125

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 100
    • Retina Gallery
Re: Upgraded to 1.5.16 and now 'upload file' and 'My Gallery' always appear
« Reply #6 on: October 05, 2011, 02:20:54 pm »

It tuns out my site somehow got all messed up.  I have someone helping me from the 'freelance/paid help' board.  I'll post here when the problem is solved.
Logged

Jeff Bailey

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1322
  • Fishing relaxes me.
    • Bailey Family Co.
Logged
Thinking is the hardest work there is, which is probably the reason why so few engage in it. - Henry Ford
Pages: [1]   Go Up
 

Page created in 0.018 seconds with 21 queries.