Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Template Error 'my_profile'  (Read 3877 times)

0 Members and 1 Guest are viewing this topic.

timothy1983

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Template Error 'my_profile'
« on: September 15, 2011, 08:36:43 pm »

Hope this is the right place to post.

I've got a big problem with my gallery. Yesterday I created a new category and album and after uploading some files, I tried to log-out and now I'm always getting this error code:

Code: [Select]
Template error
Failed to find block 'my_profile' (#<!-- BEGIN my_profile -->(.*?)<!-- END my_profile -->#s) in :
            <!-- BEGIN home -->
        <a href="{HOME_TGT}" title="{HOME_TITLE}" >{HOME_LNK}</a> <img src="themes/CotedePabloNetwork/images/spacer.gif" width="1" height="1" border="0" alt="" />
  <!-- END home -->    <!-- BEGIN my_gallery -->
        <a href="{MY_GAL_TGT}" title="{MY_GAL_TITLE}" >{MY_GAL_LNK}</a> <img src="themes/CotedePabloNetwork/images/spacer.gif" width="1" height="1" border="0" alt="" />
  <!-- END my_gallery -->  <!-- BEGIN allow_memberlist -->
        <a href="{MEMBERLIST_TGT}" title="{MEMBERLIST_TITLE}" >{MEMBERLIST_LNK}</a> <img src="themes/CotedePabloNetwork/images/spacer.gif" width="1" height="1" border="0" alt="" />
  <!-- END allow_memberlist -->          <!-- BEGIN upload_pic -->
        <a href="{UPL_PIC_TGT}" title="{UPL_PIC_TITLE}" >{UPL_PIC_LNK}</a> <img src="themes/CotedePabloNetwork/images/spacer.gif" width="1" height="1" border="0" alt="" />
  <!-- END upload_pic -->  <!-- BEGIN register -->
        <a href="{REGISTER_TGT}" title="{REGISTER_TITLE}" >{REGISTER_LNK}</a> <img src="themes/CotedePabloNetwork/images/spacer.gif" width="1" height="1" border="0" alt="" />
  <!-- END register -->  <!-- BEGIN login -->
        <a href="{LOGIN_TGT}" title="{LOGIN_TITLE}" >{LOGIN_LNK}</a>
  <!-- END login --> 

I can't log-in to change the theme or do anything else. I don't know what to do

Here's my site: gallery.cote-de-pablo.com

I hope somebody can help me.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: Template Error 'my_profile'
« Reply #1 on: September 15, 2011, 10:20:28 pm »

Check with your favorite ftp client application if the the theme folder still exists. Additionally you could try to re-upload all Coppermine files to your server (don't forget to backup your anycontent.php file and any possible core code modification).
Logged

timothy1983

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Re: Template Error 'my_profile'
« Reply #2 on: September 16, 2011, 08:38:36 am »

Check with your favorite ftp client application if the the theme folder still exists. Additionally you could try to re-upload all Coppermine files to your server (don't forget to backup your anycontent.php file and any possible core code modification).

The theme folder still exists. I even tried to re-upload it but nothing changes.

I updated the gallery to the newest version with all the coppermine files but I've still got the same error message.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: Re: Template Error 'my_profile'
« Reply #3 on: September 16, 2011, 10:21:46 am »

I updated the gallery to the newest version with all the coppermine files but I've still got the same error message.
Not completely, as at least all cpg1.5.x standard themes are missing: http://gallery.cote-de-pablo.com/themes/

Anyway, you can access your gallery if you use the classic theme: http://gallery.cote-de-pablo.com/?theme=classic
Logged

timothy1983

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Re: Re: Template Error 'my_profile'
« Reply #4 on: September 18, 2011, 07:24:59 pm »

Not completely, as at least all cpg1.5.x standard themes are missing: http://gallery.cote-de-pablo.com/themes/

Anyway, you can access your gallery if you use the classic theme: http://gallery.cote-de-pablo.com/?theme=classic

I re-uploaded everything and the theme seems to be working fine again.

Do you know what caused the error?
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: Re: Re: Template Error 'my_profile'
« Reply #5 on: September 19, 2011, 12:03:12 pm »

Do you know what caused the error?
You used a theme that wasn't designed for cpg1.5.x, but for cpg1.4.x.


Please
tag your answer as "solved" by clicking on the "Topic Solved" button on the bar at the left hand side at the bottom of your thread.
Logged

timothy1983

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Re: Re: Re: Template Error 'my_profile'
« Reply #6 on: September 20, 2011, 11:39:11 am »

You used a theme that wasn't designed for cpg1.5.x, but for cpg1.4.x.

I don't think that this is the cause. I used for months before I got the error message and it was working fine and it was specifically designed for 1.5.

Can't there be another possibility?
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: Template Error 'my_profile'
« Reply #7 on: September 20, 2011, 11:47:20 am »

You got a template error. If your theme has been designed and already worked for cpg1.5.x, either your theme or include/themes.inc.php got corrupted (for whatever reason).
Logged
Pages: [1]   Go Up
 

Page created in 0.023 seconds with 20 queries.