Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: No sale la opción Mostrar/Ocultar panel de Administración  (Read 3623 times)

0 Members and 1 Guest are viewing this topic.

KchoPrro

  • Coppermine frequent poster
  • ***
  • Country: es
  • Offline Offline
  • Gender: Male
  • Posts: 205
    • Adolfo Ventas - Naturaleza Andaluza
No sale la opción Mostrar/Ocultar panel de Administración
« on: August 25, 2011, 10:09:10 am »

Hay muchas cosas que, funcionando en otros themes no me funcionan en el mío (vaya por delante que para poner el número de imagenes en el film strip tengo que tocar el archivo theme.php, la opción de superponer un gif en las imágenes para que no se roben tampoco, etc.) pero esto que me pasa es raro.

No aparece la opción Mostrar/Ocultar panel de administración (estando logueado como admin, lógicamente!). El caso es que si cambio de theme sí que aparece en la barra de menús pero en el mío no. Hasta aquí podría ser algo relacionado con mi theme, como en los casos anteriormente mencionados pero......la cuestión es que recién instalada la galería Sí que aparecía y un buen día ha dejado de aparecer.

No puedo saber qué toqué (lo siento, he tocado mucho  :P) porque no me he dado cuenta hasta hace poco en la que empecé a querer ver los resultados como usuario, alguna pista?? puede tener algo que ver la configuración de CPG??? (lo digo porque más o menos me encontraba configurando CPG cuando lo noté, puede ser algo relacionado con theme.php?? (no he borrado nada).

En fin, trataré de localizar el código en mi theme que muestra esta función a ver qué pasa, ya os cuento! tampoco es algo que me quite el sueño, sólo tengo que salir del sistema y veo la web como un usuario invitado.

KchoPrro
Logged

KchoPrro

  • Coppermine frequent poster
  • ***
  • Country: es
  • Offline Offline
  • Gender: Male
  • Posts: 205
    • Adolfo Ventas - Naturaleza Andaluza
Re: No sale la opción Mostrar/Ocultar panel de Administración
« Reply #1 on: August 28, 2011, 12:14:42 pm »

Es curioso, estoy mirando esto y en theme.php la parte que menciona esta cuestión es;

Code: [Select]
<a href="{USR_MODE_TGT}" title="{USR_MODE_TITLE}"><span>{USR_MODE_LNK}</span></a>
No veo nada raro, no está oculto ni está quitado, por qué no sale entonces???.

La cuestión es que ahora pongo el theme por defecto, curve, y tampoco sale por lo que deduzco que no es algo del template mío y de los ajustes que he ido haciendo tanto en el template.html como en el theme.php

No sé me ocurre qué puede ser, tampoco es fundamental, puedo desloguearme para ver la web como un usuario pero es un latazo   :P
Logged

KchoPrro

  • Coppermine frequent poster
  • ***
  • Country: es
  • Offline Offline
  • Gender: Male
  • Posts: 205
    • Adolfo Ventas - Naturaleza Andaluza
Re: No sale la opción Mostrar/Ocultar panel de Administración
« Reply #2 on: August 28, 2011, 12:47:53 pm »

Rectifico;

efectivamente ni en mi template ni en "curve" veo las opciones, pero si pongo cualquiera de las otras que te instala CPG por defecto (eyebal, hardwired, rainy_day, water_drop), sí que sale. Por si las moscas he borrado completamente la carpeta del theme "curve" y me la he vuelto a descargar para instalarla pero....nada, la cosa no cambia.

Voy a probar con mi template, a ver si puedo ir eliminando factores.

Saludos

KchoPrro
Logged

KchoPrro

  • Coppermine frequent poster
  • ***
  • Country: es
  • Offline Offline
  • Gender: Male
  • Posts: 205
    • Adolfo Ventas - Naturaleza Andaluza
Re: No sale la opción Mostrar/Ocultar panel de Administración
« Reply #3 on: August 28, 2011, 01:11:39 pm »

Bueno, he borrado totalemente mi theme y he puesto el original, sin modificaciones, y después de tener que refrescar unas cuántas veces la caché porque todavía me mostraba cosas del anterior, finalmente quedo operativa tal cuál es, sin modificaciones. No ví por ningún sitio la opción (aseguro que al principio apreció, pero no recuerdo si fue con una actualización o con la instalación que hice nueva en un hosting para pruebas).

Otra curiosidad es que, cuando selección el theme eyeball, por defecto no salé la barra del menú principal (donde está también el de los controles de administración), es al pasar el ratón por el botón de inicio (justo donde está la captura que adjunto) cuando se muestra. Entiendo que esto es propio de este theme.

En el resto se muestra sin problemas por lo que me quedo un poco a cuadros;

1- Por un lado descarto que pueda ser cualquier modificación que haya realizado yo ya que sólo he trabajado con los ficheros de mi theme (style.css, theme.php y template.html), a parte de cambiar las imágenes de cursores y demás del propio theme.

2- Por otro lado, si no es algo de mi theme, por qué con los demás sí que se muestra???, cualquiera diría que este theme no traía esa opción pero no es el caso porque yo lo ví. Y por qué tampoco se muestra en el theme curve?, nunca lo toqué, pero por si acaso me lo descargué de nuevo.

Tampoco son los plugins, los he desinstalado todos (aunque no los he borrado del servidor) y nada.

Podría ser por los ficheros que eliminé siguiendo las indicaciones de cpg???, pero si fuera el caso el resultado sería el mismo para todos los themes, no??

Uff! qué lío!  :o

KchoPrro
P.D. adjunto también captura de mi theme para que veáis la barra íntegra de administración.
Logged

jmatute

  • Moderator
  • Coppermine frequent poster
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 453
Re: No sale la opción Mostrar/Ocultar panel de Administración
« Reply #4 on: September 03, 2011, 09:43:59 am »

Bueno, he borrado totalemente mi theme y he puesto el original, sin modificaciones

Partimos de la base de que te has basado en el Chaotic Soul de la 1.5, ¿cierto?. Seria bueno que adjuntaras en un post los ficheros de tu tema (comprimidos, y en principio no hacen falta las imágenes).

Además puedes tener los dos (original y tuyo) simplemente teniendo dos carpetas en el directorio theme.

y después de tener que refrescar unas cuántas veces la caché porque todavía me mostraba cosas del anterior

¿Has probado a cambiar de uno a otro con
http://www.adolfoventas.es/galeria/?theme=curve
o
http://www.adolfoventas.es/galeria/?theme=eyeball

y volver al de por defecto con

http://www.adolfoventas.es/galeria/?theme=xxx (escribe xxx o el nombre de un tema que no exista. No vale dejarlo en blanco)

finalmente quedo operativa tal cuál es, sin modificaciones. No ví por ningún sitio la opción (aseguro que al principio apreció, pero no recuerdo si fue con una actualización o con la instalación que hice nueva en un hosting para pruebas).

Por aquí huele a galletas... ¿Alguien tiene hambre? En cuento te conteste voy a desayunar.

Otra curiosidad es que, cuando selección el theme eyeball, por defecto no salé la barra del menú principal (donde está también el de los controles de administración), es al pasar el ratón por el botón de inicio (justo donde está la captura que adjunto) cuando se muestra. Entiendo que esto es propio de este theme.

Cierto.

En el resto se muestra sin problemas por lo que me quedo un poco a cuadros;

1- Por un lado descarto que pueda ser cualquier modificación que haya realizado yo ya que sólo he trabajado con los ficheros de mi theme (style.css, theme.php y template.html), a parte de cambiar las imágenes de cursores y demás del propio theme.

2- Por otro lado, si no es algo de mi theme, por qué con los demás sí que se muestra???, cualquiera diría que este theme no traía esa opción pero no es el caso porque yo lo ví. Y por qué tampoco se muestra en el theme curve?, nunca lo toqué, pero por si acaso me lo descargué de nuevo.

Venga, va, fuera de broma: ¿has probado a borrar las cookies? Es posible que en una de ellas se haya quedado marcada la opción.


Tampoco son los plugins, los he desinstalado todos (aunque no los he borrado del servidor) y nada.

Podría ser por los ficheros que eliminé siguiendo las indicaciones de cpg???, pero si fuera el caso el resultado sería el mismo para todos los themes, no??

Uff! qué lío!  :o

KchoPrro
P.D. adjunto también captura de mi theme para que veáis la barra íntegra de administración.

Saludos,
« Last Edit: September 04, 2011, 10:12:27 pm by jmatute »
Logged

KchoPrro

  • Coppermine frequent poster
  • ***
  • Country: es
  • Offline Offline
  • Gender: Male
  • Posts: 205
    • Adolfo Ventas - Naturaleza Andaluza
Re: No sale la opción Mostrar/Ocultar panel de Administración
« Reply #5 on: September 04, 2011, 01:06:14 pm »

Partimos de la base de que te has basado en el Chaotic Soul de la 1.5, ¿cierto?
Cierto, cierto.
Además puedes tener los dos (original y tuyo) simplemente teniendo dos carpetas en el directorio theme
Lo sé, lo sé, hasta ahí llego  ;)
¿Has probado a cambiar de uno a otro con
http://www.adolfoventas.es/galeria/?theme=curve
o
http://www.adolfoventas.es/galeria/?theme=eyeball

y volver al de por defecto con

http://www.adolfoventas.es/galeria/?theme=xxx (escribe xxx o el nombre de un tema que no exista. No vale dejarlo en blanco)
Acabo de hacerlo, de hecho eyeball no existe (lo borré, sólo he dejado para pruebas "curve"), no veo que afecte para nada, sigue sin salir.

Venga, va, fuera de broma: ¿has probado a borrar las cookies? Es posible que en una de ellas se haya quedado marcada la opción.
No, pero lo pruebo ahora, lo único que he hecho ha sido refrescar constantemente para que nada se quede en la caché. Por otro lado, pensé que en las cookies solo se almacenaba los datos del login no sabía que se almacenaban más cosas.

Lo pruebo y lo confirmo. En cuánto a subir los archivos (supongo que te refieres al theme completo modificado), entiendo que no debe afectar ya que he probado con el original (con las dos carpetas como indicabas e incluso con el propio curve y tampoco). Está claro que es un problema que tengo yo pues no se reproduce en otro usuario que yo sepa, pero lo descarto en el tema porque me pasa con dos de ellos.

No obastante, ahora que sale una nueva versión, aprovecho y actualizo también. Os cuento.

KchoPrro
Logged

KchoPrro

  • Coppermine frequent poster
  • ***
  • Country: es
  • Offline Offline
  • Gender: Male
  • Posts: 205
    • Adolfo Ventas - Naturaleza Andaluza
Re: No sale la opción Mostrar/Ocultar panel de Administración
« Reply #6 on: September 04, 2011, 06:24:13 pm »

Pues me temo que no ha pasado nada. He actualizado ya a 1.5.16 y también he borrado todas las cookies pero todo sigue igual, veré con otros navegadores por si hay algo que puede interferir, no lo entiendo. si todo está recien actualidado ....., com no esté en config.inc??? (pero entonces por qué veo la opción en otros temas?) , es lo único que que salvo en cada actualización pues anycontent no lo uso.

Seguiremos investigando
Logged
Pages: [1]   Go Up
 

Page created in 0.024 seconds with 24 queries.