Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Problem with Plugin "External tracker"  (Read 3429 times)

0 Members and 1 Guest are viewing this topic.

DJKat

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Problem with Plugin "External tracker"
« on: August 11, 2011, 09:20:27 am »

Hi @ all!

I just updated my gallery to the current 1.5 Coppermine Version and found out, that my bbclone does not work as it did with 1.4.
So I installed the external tracker plugin. It seems to work well, but only when I'm logged in as admin.
Where can I change this?

Regards, Dany
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: Problem with Plugin "External tracker"
« Reply #1 on: August 11, 2011, 04:18:05 pm »

Have you looked at the source code as each admin, regular user and guest to find out that the tracker works just for the admin? Please post a link to your gallery.
Logged

DJKat

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: Problem with Plugin "External tracker"
« Reply #2 on: August 11, 2011, 05:02:21 pm »

I haven't looked at the source code yet for I dont know where exactly to look at,  but I noticed the effect by looking at the bbclone stats...

the gallery: http://fotos.danyalexander.de
bbclone: http://fotos.danyalexander.de/bbclone
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: Problem with Plugin "External tracker"
« Reply #3 on: August 11, 2011, 05:46:50 pm »

Please have a look at codebase.php. There's a line that reads
Code: [Select]
    if (!GALLERY_ADMIN_MODE) {
        $stats = 'yes';
    }
which usually tells the script to execute for every non-admin user. You could try to debug that variables by adding
Code: [Select]
    var_dump(GALLERY_ADMIN_MODE);
    var_dump($stats);
below that code.
Logged

DJKat

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: Problem with Plugin "External tracker"
« Reply #4 on: August 11, 2011, 09:41:57 pm »

Tried your lines but the problem is still there.
BBclone still counts only me when I'm logged in.  :-\

Any more hints?
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: Problem with Plugin "External tracker"
« Reply #5 on: August 12, 2011, 09:09:19 am »

Of course the debug code won't fix anything. I can now see the content of the variables, which is
Quote
bool(false) string(3) "yes"

So everything should work fine from the plugin side. I'm not the author of the plugin nor use it myself, so I cannot help you further with that issue.
Logged

DJKat

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: Problem with Plugin "External tracker"
« Reply #6 on: August 12, 2011, 10:23:28 am »

I think it all occurs because of the new coppermine version...  :-\

Restored my old gallery which was 1.4.23 and restore also my bbclone call I added manually to displayimage.php, index.php and thumbnails.php.

Now everything works fine again.

Thanks anyway for your work and help André!!!

Regards Dany
Logged
Pages: [1]   Go Up
 

Page created in 0.018 seconds with 19 queries.