Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Problem mit Album-Thumbnail  (Read 3239 times)

0 Members and 1 Guest are viewing this topic.

VolkerF

  • Translator
  • Coppermine frequent poster
  • **
  • Offline Offline
  • Posts: 201
Problem mit Album-Thumbnail
« on: July 20, 2011, 02:26:22 pm »

Hallo

Ich habe folgendes Problem. Ich habe heute ein neues Album angelegt und in den Albumeinstellungen bei Album-Thumbnail "Zufallsbild", wie bei allen anderen Alben auch, angeklickt. Allerdings erscheint jetzt nur noch das Eimer-Bild und nicht das Thumbnail. Bisher war das immer kein Problem und hat immer funktioniert. die anderen beiden Optionen "Letzte Datei die hochgeladen wurde" und der Bildname selbst funktionieren, nur eben das mit dem Zufallsbild nicht. Was läuft da auf einmal schief?

Danke Volker
Logged

Αndré

  • Administrator
  • Coppermine addict
  • ****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: Problem mit Album-Thumbnail
« Reply #1 on: July 20, 2011, 02:31:16 pm »

Bitte gib uns einen Link zum entsprechenden Album.
Logged

VolkerF

  • Translator
  • Coppermine frequent poster
  • **
  • Offline Offline
  • Posts: 201
Re: Problem mit Album-Thumbnail
« Reply #2 on: July 20, 2011, 02:36:55 pm »

Hi

http://www.pilzewelt.de/cpg15x/index.php und da sieht man schon was ich meine bei Cirsium-Kratzdisteln.

Ciao Volker
Logged

Αndré

  • Administrator
  • Coppermine addict
  • ****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: Problem mit Album-Thumbnail
« Reply #3 on: July 20, 2011, 02:47:13 pm »

Wechselt man in die dazugehörige Kategorie, funktioniert es: http://www.pilzewelt.de/cpg15x/index.php?cat=3

Ein entsprechender Fix existiert bereits, siehe http://forum.coppermine-gallery.net/index.php/topic,72302.msg349704.html#msg349704
Logged

VolkerF

  • Translator
  • Coppermine frequent poster
  • **
  • Offline Offline
  • Posts: 201
Re: Problem mit Album-Thumbnail
« Reply #4 on: July 20, 2011, 02:54:17 pm »

Hallo nochmal

Das was in revision 8202 steht, habe ich schon im Code drin stehen oder was soll ich da machen?

Danke Volker

Logged

Αndré

  • Administrator
  • Coppermine addict
  • ****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: Problem mit Album-Thumbnail
« Reply #5 on: July 20, 2011, 03:03:12 pm »

Diese Zeile muss an entsprechender Stelle hinzugefügt werden:
Code: [Select]
$keyword = ($album['keyword'] ? "OR (keywords like '%".addslashes($album['keyword'])."%' $forbidden_set_string)" : '');
Logged

VolkerF

  • Translator
  • Coppermine frequent poster
  • **
  • Offline Offline
  • Posts: 201
Re: Problem mit Album-Thumbnail
« Reply #6 on: July 20, 2011, 03:08:28 pm »

Hi Andre

Es hat geklappt-Danke. Wo lag die Ursache, warum ging es bei allen anderen Alben vorher?

Danke Volker
Logged

Αndré

  • Administrator
  • Coppermine addict
  • ****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: Problem mit Album-Thumbnail
« Reply #7 on: July 20, 2011, 03:21:15 pm »

Doesn't work if an album keyword is set.
also am Album-Keyword.
Logged

VolkerF

  • Translator
  • Coppermine frequent poster
  • **
  • Offline Offline
  • Posts: 201
Re: Problem mit Album-Thumbnail
« Reply #8 on: July 20, 2011, 03:51:32 pm »

Hi

Ich frag mich zwar was da so ungewöhnlich dran war oder ist, aber egal, Hauptsache es funktioniert wieder.

Danke und Ciao Volker
Logged

Αndré

  • Administrator
  • Coppermine addict
  • ****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: Problem mit Album-Thumbnail
« Reply #9 on: July 20, 2011, 03:54:26 pm »

Du darfst dir gern den Code anschauen um nachzuvollziehen, wieso genau das nicht funktioniert hat ;)
Logged

VolkerF

  • Translator
  • Coppermine frequent poster
  • **
  • Offline Offline
  • Posts: 201
Re: Problem mit Album-Thumbnail
« Reply #10 on: July 20, 2011, 04:02:28 pm »

Hi Andre

Habe ich ja, aber ich kanns nicht erkennen. Ich kann zwar Code einfügen aber auseinandernehmen und erkennen was da gemeint ist, das übersteigt meinen Horizont. Aber ich lerne gern dazu wenn man mir sagt auf was ich achten muß oder was was bedeutet etc..

Ciao Volker
Logged
Pages: [1]   Go Up
 

Page created in 0.024 seconds with 21 queries.