Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Problem with bridging with phpbb3  (Read 5339 times)

0 Members and 1 Guest are viewing this topic.

Ulenka

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 32
Problem with bridging with phpbb3
« on: July 03, 2011, 09:16:32 am »

I downloaded cpg1.5.12, intsall in data base, where is phpbb3 data base.
Everythings ok, but when I click on Itegration manager, this is an error:

Fatal error: Cannot redeclare class cpg_udb in /var/www/newsite/data/www/new.romanticcollection.ru/gal/bridge/phpbb3.inc.php on line 41

Coppermine install: http://new.romanticcollection.ru/gal/
Bridging app install: http://new.romanticcollection.ru/forum/
Coppermine version: cpg1.5.12

BridgeManager settings:
Bridge app URL:  http://new.romanticcollection.ru/forum
Relative path to your bridge app's config file:  ../forum/
Cookie name or prefix:  /
Use bridge app custom groups?:  1 

Please, help!
Logged

Ulenka

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 32
Re: Problem with bridging with phpbb3
« Reply #1 on: July 03, 2011, 09:21:10 am »

The fatal error messages appearing after the last step, after I turn on bridging.
Then, I am logout. I try to log in, and the system redirect me on my forum, I put login and password, then, system redirect me into my gallery, but I am not login there. This action is with admin and with user.
Logged

Ulenka

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 32
Re: Problem with bridging with phpbb3
« Reply #2 on: July 03, 2011, 09:33:20 am »

Line 41 in phpbb3.inc.php is:

Code: [Select]
class cpg_udb extends core_udb {
Logged

Ulenka

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 32
Re: Problem with bridging with phpbb3
« Reply #3 on: July 06, 2011, 10:08:37 pm »

And now I've found the reason:
My cookie name or prefix is phpbb3_rb33
That's work!
Logged
Pages: [1]   Go Up
 

Page created in 0.066 seconds with 19 queries.