Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: MySQL error  (Read 4173 times)

0 Members and 1 Guest are viewing this topic.

Etherus

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
MySQL error
« on: July 02, 2011, 05:39:12 pm »

Hello!

I try to install Coppermine, I created a new MySQL database and then I proceed to the installation script however what ever I try it keeps erroring out on step 8 with the following error:

Quote
MySQL error: Table 'coppermine_albums' already exists on query ' CREATE TABLE coppermine_albums ( aid int(11) NOT NULL auto_increment, title varchar(255) NOT NULL default '', description text NOT NULL, visibility int(11) NOT NULL default '0', uploads enum('YES','NO') NOT NULL default 'NO', comments enum('YES','NO') NOT NULL default 'YES', votes enum('YES','NO') NOT NULL default 'YES', pos int(11) NOT NULL default '0', category int(11) NOT NULL default '0', owner int(11) NOT NULL DEFAULT '1', thumb int(11) NOT NULL default '0', keyword VARCHAR( 50 ), alb_password VARCHAR( 32 ), alb_password_hint TEXT, moderator_group INT NOT NULL default 0, alb_hits INT( 10 ) NOT NULL default 0, PRIMARY KEY (aid), KEY alb_category (category), KEY `moderator_group` (`moderator_group`), KEY `visibility` (`visibility`) ) COMMENT='Used to store albums''


Code: [Select]
Trying to insert data in the database.

Creating table 'coppermine_albums'    Status:... Not OK


I did make a new mysql database, new mysql username, tried to change the table name to coppermine_ but nothing works it keeps giving this error. Does anyone know what I can do to fix this?
Logged

Etherus

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: MySQL error
« Reply #1 on: July 02, 2011, 07:01:30 pm »

Just to add some more information I use IIS 7.

All step 1 to 7 they are all good it has all requirement it is just at Step 8 it some how provides a error 500 after loading a while and then it gives the error above. Just to add mysql and php are working correctly on the server I have 1 other php/mysql site running with no issue.

I also once again tried making a total new database but still does wane go further then step 8.

Is there someway to manual install? I have no problem going into phpmyadmin and then run the 2 .sql files in the installation dir, so not sure why the website itself does not wane do it.
Logged

Etherus

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: MySQL error
« Reply #2 on: July 04, 2011, 12:05:07 am »

I think there is something wrong with the 1.5.* version with installing on windows we tried 3 different servers they all bug out on step 8.

However if we install the 1.4.* version then there is no problems at all, and then we could update to 1.5.12 so not sure why the direct installation of 1.5.* doesn't wane do the job.

It is resolved now but someone might wane double check the installation script on a IIS server. :)
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: MySQL error
« Reply #3 on: July 13, 2011, 01:36:27 pm »

Quote
Table 'coppermine_albums' already exists
Means the installer tries to create the tables twice, probably because of
at Step 8 it some how provides a error 500 after loading a while and then it gives the error above

If you get an error 500 and then the other error I guess you're reloading the site in your browser?
Logged
Pages: [1]   Go Up
 

Page created in 0.018 seconds with 19 queries.