Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Fatal error: Failed opening required 'bridge/coppermine.inc.php'  (Read 7640 times)

0 Members and 1 Guest are viewing this topic.

mgoldey

  • Coppermine newbie
  • Offline Offline
  • Posts: 3

Folks:

Been using Coppermine singe 1.3.2 and upgrading it from time to time since then.  Currently using 1.5.8.  Upgraded to 1.5.12.  The file copying part went fine, just like it always does. 

But, this time, when I go to http://[my gallery]/update.php I get the following: 

Quote
Fatal error: require_once(): Failed opening required 'bridge/coppermine.inc.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/[snip]/coppermine/include/init.inc.php on line 243


This sort of thing has come up before:  http://forum.coppermine-gallery.net/index.php/topic,69101.0.html and http://forum.coppermine-gallery.net/index.php/topic,70520.0.html

The suggestions in those threads have not helped. 

I don't use bridging, and the config table is set correctly:

Quote
mysql> select * from cpg132_config where name = 'bridge_enable';
+---------------+-------+
| name          | value |
+---------------+-------+
| bridge_enable | 0     |
+---------------+-------+
1 row in set (0.00 sec)

Making the following change in init.inc.php has no effect on the error message (other than changing the line # reported):

Quote
#require_once 'bridge/' . UDB_INTEGRATION . '.inc.php';
require_once 'bridge/coppermine.inc.php';

For good measure, I reverted to 1.5.8 and ran the update script, in case I'd forgotten to back when I moved to 1.5.8.  It reported "Already Done" for every single item.  And, the 1.5.8 installation works just fine.

Any thoughts would be most appreciated.  Thanks.




Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Fatal error: Failed opening required 'bridge/coppermine.inc.php'
« Reply #1 on: June 22, 2011, 12:27:25 pm »

This sort of thing has come up before
Your issue is a little bit different, so I suggest we try to start from scratch.

Quote
Fatal error: require_once(): Failed opening required 'bridge/coppermine.inc.php'
Please verify that this file exists and have set the correct permissions, so PHP can has access to it.
Logged

mgoldey

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: Fatal error: Failed opening required 'bridge/coppermine.inc.php'
« Reply #2 on: June 22, 2011, 03:05:46 pm »

Thanks.

After reading your message, I made the entire /coppermine folder and all of its contents 777, and the script ran OK.  I think that one or more folders was not +x, although I have no idea which one. 

I then scaled permissions back to 755 for directories and 644 for .php files, and 640 for include/config.inc.php.  So far, everything is working OK.  So, the problem is solved, it was a permissions problem, but I still don't know which file or directory caused it.

To answer your question (and for the benefit of those who follow), bridge/coppermine.inc was 644: 

Quote
root@[snip]:/var/www/[snip]/coppermine# ls -l bridge/c*
-rw-r--r-- 1 www-data www-data 21704 Jan  2 19:44 bridge/coppermine.inc.php

which is how it was on the working 1.5.8 install: 

Quote
root@[snip]:/var/www/[snip]/coppermine.old# ls -l bridge/c*
-rw-r--r-- 1 root root 21288 Sep 26  2010 bridge/coppermine.inc.php

The bridge directory itself was 755 on both installs. 

Thanks for your time!
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Fatal error: Failed opening required 'bridge/coppermine.inc.php'
« Reply #3 on: June 22, 2011, 03:10:18 pm »

you can tag your answer as "solved" by clicking on the little image in your initial posting on your thread.
Logged
Pages: [1]   Go Up
 

Page created in 0.03 seconds with 21 queries.