Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: User experiencing server error when trying to upload(new install)  (Read 3699 times)

0 Members and 1 Guest are viewing this topic.

dazle

  • Coppermine newbie
  • Offline Offline
  • Posts: 5

hi

I've created a normal user, which i can upload with from my pc and laptop fine, however my 1st registered user says they receive a server error when trying to upload. i created a new profile for them under them same group as the test user i created but they are receiving the same error message when uploading of...

"coppermine ErrorNo file was uploaded!If you have really selected a file to upload, check that the server allows file uploads..."

the user i created is just a normal default 'registered' user, i have not created any additonal groups, hence effective permissions are as the same of the user with this problem

i have tried a couple of tweaks as mentioned, like simple file upload creating temp / tmp root dir's with 777 permissions but to no avail

i can see this seems a bit of a hot topic, however i am yet to come across a post where this works for some users and not for others

any ideas?

i'm using  v 1.5.12

thanks in advance

d
Logged

lurkalot

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 931
  • +Tinyportal Support team.
Re: User experiencing server error when trying to upload(new install)
« Reply #1 on: June 28, 2011, 11:52:18 pm »

As per the rules, could you please provide a link to your gallery

What is the file size of the image your user is trying to upload?

http://documentation.coppermine-gallery.net/en/upload_troubleshooting.htm#upload_error_messages_no_file_uploaded
Logged
Running SMF 2.0.15  / Tinyportal 1.6.4, bridged with Coppermine 1.6.06, plus cpmfetch 2.0.0

dazle

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: User experiencing server error when trying to upload(new install)
« Reply #2 on: June 29, 2011, 12:03:06 am »

oops: http://dovecarnival.org.uk/photos/

they copied and pasted the error message, however i thought the same regarding file size too due to fancy camera filesize(2mb now) however in troubleshooting i tried uploading a file in excess of 2 meg but was prompted immediately by file size exceeds allowed
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: User experiencing server error when trying to upload(new install)
« Reply #3 on: June 29, 2011, 09:11:04 am »

Please provide a test user account which is able to upload files to your gallery.
Logged

dazle

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: User experiencing server error when trying to upload(new install)
« Reply #4 on: June 29, 2011, 09:13:32 am »

Please provide a test user account which is able to upload files to your gallery.

paul
pass

dovecarnival.org.uk/photos/
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: User experiencing server error when trying to upload(new install)
« Reply #5 on: June 29, 2011, 10:36:57 am »

I successfully uploaded some files. Please check your PHP settings upload_max_filesize and post_max_size.
Logged

dazle

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: User experiencing server error when trying to upload(new install)
« Reply #6 on: June 29, 2011, 08:22:09 pm »

upload_max_filesize  = 2mb(that's what i've set

post_max_size = 8mb
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: User experiencing server error when trying to upload(new install)
« Reply #7 on: June 30, 2011, 02:18:06 pm »

Uploading files upto 2mb worked as expected if I remember right. What's the actual issue?
Logged

dazle

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: User experiencing server error when trying to upload(new install)
« Reply #8 on: June 30, 2011, 08:43:52 pm »

yeah. i can upload fine too

i reset the users password, logged in as them and could upload fine. i created a new profile for them, which i can upload from, however they are still given the message:

"coppermine ErrorNo file was uploaded!If you have really selected a file to upload, check that the server allows file uploads..."

as i only implemented the gallery in the past week, i have no idea how many users will be denied uploads
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: User experiencing server error when trying to upload(new install)
« Reply #9 on: June 30, 2011, 09:38:55 pm »

Ask the user to upload files smaller than 2mb. I also got that error message while exceeding the PHP limit in my testbed. So I guess your users also get this message because the files they are trying to upload are too big.
Logged
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 21 queries.