Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: The Coppermine SEO tweaks broke some of my permissions settings and I was wondering why?  (Read 3496 times)

0 Members and 1 Guest are viewing this topic.

elwave

  • Coppermine frequent poster
  • ***
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 120

Hey hey :)

Basically, I made all these changes:

http://forum.coppermine-gallery.net/index.php?topic=68822.0

and all is good, but as the creator noted, permissions changes for viewing full images (such as disabling it for guests) now do not work. I intend to obviously have another good look to work out why (I tried disabling the plugin I made based on this post - http://forum.coppermine-gallery.net/index.php/topic,68822.msg340148.html#msg340148 but it didnt work!) but I'd love a pointer if anyone knows what it could be!

Wave :)
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764

permissions changes for viewing full images (such as disabling it for guests) now do not work.
Will they be stored and updated in the database? I haven't looked yet at all of those changes, but we should figure out if the permissions settings are broken or if the settings are applied wrongly.
Logged

elwave

  • Coppermine frequent poster
  • ***
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 120

yeah it's odd, and thanks for the reply - sorry about the double post (I actually didn't spot your reply when I made the second thread!)

So erm, I mean would a good move now be for me to check where the permissions changes SHOULD be being applied so I can work out if it's being done properly or not? Or can you think of a better approach?

Also, I tried limiting guest access to intermediate images instead (just because I was getting desperate to increase forum traffic!) and it still didn't work :(

I wonder which SEO change permanently affected the permissions settings (regardless of whether the SEO tweak code is still there or not) and how it can be changed back >.<
Logged

elwave

  • Coppermine frequent poster
  • ***
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 120

sorry, bump! hehe :)
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764

Use a tool like PHPMyAdmin to check if the permission settings will be stored and updated in the database.
Logged

elwave

  • Coppermine frequent poster
  • ***
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 120

ah ok, so they're just stored as normal permissions in the DB? I'll take a look! :)
Logged

elwave

  • Coppermine frequent poster
  • ***
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 120

yup, it's definitely changing the access level for guests in the usergroups table. As I said the crazy thing is I'm pretty sure I reverted back ALL the SEO changes >.<

Can you think of where else it could be breaking? I keep checking it as a guest in incognito mode in Chrome and no matter what I do it lets me access everything as a guest.. weeeird.

Thanks so much :)
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764

Try to replace all files with unmodified versions from the official Coppermine package.
Logged

elwave

  • Coppermine frequent poster
  • ***
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 120

ok cool I'll do that asap :)

I already reverted back I think everything to do with my theme, so I don't think the problem is in there (and judging by the contents of the theme files it seems unlikely o.O )

So yeah, I'll do it and see if it fixes it!
Logged
Pages: [1]   Go Up
 

Page created in 0.019 seconds with 19 queries.