Advanced search  


cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.

Pages: [1]   Go Down

Author Topic: Images not showing (old album folder with new database)  (Read 1908 times)

0 Members and 1 Guest are viewing this topic.


  • Coppermine newbie
  • Offline Offline
  • Posts: 8

I tried to find an answer for this but maybe this is a specific problem.
2 days ago I lost my Coppermine folder on public_html accidentally and the host had no backup to restre it.

Fortunately I had a database backup from the last update of coppermine in January, and I had a directory backup via ftp of maybe 1-2 years ago.
I installed the recent coppermine, injected my database via phpmyadmin and replaced the albums folder with the backup I had on my hard drive.

The problem is some of the images are not showing and some are displaying a grey bucket.
I have noticed that the table prefix in php myadmin now is cpg14x_ it is not cpg15x_

I tried to make an update end mysite/update.php and it seems that the file versions are the latest but I don't know why some images are not showing.
I also tried to recreate all the images via dmin tools but no success.
My gallery has about 7000 photos and here is the link:

here is a link of some images that are not showing correctly:

Some help would be very appreciated.
Thanks in advance


  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: Images not showing (old album folder with new database)
« Reply #1 on: May 09, 2011, 10:58:09 am »

I have noticed that the table prefix in php myadmin now is cpg14x_ it is not cpg15x_
That doesn't matter.

It's quite obvious what happened. Your database backup and your albums/ folder backup doesn't match. Your folder backup is from 2008-03-12. You can see it at that page:

All files you added after that date don't exist, so Coppermine cannot display them. If you want to restore them, you'll have to upload them manually to your FTP server (~2700 files are missing). The files have to be in the same folder, with the same name (and with the same case).
Pages: [1]   Go Up

Page created in 0.037 seconds with 19 queries.