Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Uploading issues with Batch add  (Read 59152 times)

0 Members and 1 Guest are viewing this topic.

penelope79

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 35
Uploading issues with Batch add
« on: May 02, 2011, 01:09:23 pm »

Hi,
I'm experiencing uploading issues for the first time since I installed CPG v. 1.5.12, i.e. 'Unable to create thumbnails or reduced size image' when using Image Magick library, while the error is 'The image you have uploaded is corrupted or can't be handled by the GD library' when using GD v.2.
The images are not corrupted, though.
I searched the forum, but none of those solutions was the right one for me.
I checked permissions, they're all to 777.
I installed CPG 1.5.12 by my own and not through Fanatastico.
I read and followed any step listed in "Upload troubleshooting" section and, in this way, I found out that the only issue I have is when I try to upload using Batch method; HTTP works fine (however I have several photos to upload and using HTTP would just be too long; besides I used to use Batch method with no problem whatsoever before).

My gallery is: http://www.leighton-meester.com/gallery
I set up a test user account, with uploading permissions, and a test album:
Username: tester
Password: tester

The only change done so far by my webhost was the moving my site to a new server and I don't know if this fact has anything to do with what's happening, although with the old server I never experienced this kind of issues (but then again I have another website on the same server and CPG works great as ever there). Anyway, before asking for my host's help I wanted to be sure that CPG is not the one to be blamed for.

Thanks for your help in advance
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: Uploading issues with Batch add
« Reply #1 on: May 02, 2011, 01:29:32 pm »

As expected the HTTP upload works without problems.

'The image you have uploaded is corrupted or can't be handled by the GD library' when using GD v.2.
The images are not corrupted, though.
Does it happens for all files you try to batch-add? Which file types do you want to add? Can you please post a deep link to a file that doesn't work?

Probably it's a permission issue as you said your webhost moved to a new server. Coppermine needs write access to the files in the albums/ directory. So if you're sure your images aren't corrupted your host need to check the file and folder permissions (chown/chgrp/chmod).
Logged

penelope79

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 35
Re: Uploading issues with Batch add
« Reply #2 on: May 02, 2011, 02:54:47 pm »

André, first of all, thank you for your reply.
Coincidentally, my webhost sent me an e-mail about this issue and he checked some permission as you said, now everything seems to work fine.
Thanks a lot for your help, it's been precious.
Logged
Pages: [1]   Go Up
 

Page created in 0.021 seconds with 19 queries.