Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: keyword manager error  (Read 3343 times)

0 Members and 1 Guest are viewing this topic.

Walkinman

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 376
    • Skolai Images - Nature, Travel and Adventure stock photos
keyword manager error
« on: April 04, 2011, 04:00:33 am »

hey Folks,

I'm trying to correct some keywording errors I've long had on my site. I can do it manually, but it's slow and tedious, so if I can make this work, that'll be better. I'm getting an error on the keywordmgr.php page, similar to that described in this thread

The error I get says:

Code: [Select]
Fatal error: Maximum execution time of 30 seconds exceeded in /home/skola2/public_html/stock/keywordmgr.php on line 117
I have quite a lot of keywords on my site, so I'm sure this is the problem. Is there a way to resolve this, even temporarily (just so I can fix this particular keyword issue)? I looked at the thread linked above but that fix no longers applies to cpg 1.5, from what I can tell. Is this a server side issue I'll need to adjust, or can I tweak a cpg setting to resolve it?

Thank you.

Cheers

Carl
Logged

Walkinman

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 376
    • Skolai Images - Nature, Travel and Adventure stock photos
Re: keyword manager error
« Reply #1 on: April 04, 2011, 04:32:04 am »

Hey Folks,

Sorry, I meant to add a link to my site:

http://www.skolaiimages.com/stock/

Cheers

Carl
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: keyword manager error
« Reply #2 on: April 05, 2011, 01:58:32 pm »

I cannot see a straightforward solution, as your error message differs from the one in the other thread. If you need to batch-change your keywords I suggest to do it directly in your MySQL console or ask your provider to increase the PHP execution time.
Logged

Walkinman

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 376
    • Skolai Images - Nature, Travel and Adventure stock photos
Re: keyword manager error
« Reply #3 on: April 05, 2011, 08:37:25 pm »

Hey André

OK, I'll contact the provider, or see if I can figure the mySQL end of it.

Cheers

Carl
Logged

Walkinman

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 376
    • Skolai Images - Nature, Travel and Adventure stock photos
Re: keyword manager error
« Reply #4 on: April 17, 2011, 02:47:56 am »

Hey André

Well, I had my webhost increase the execution time to 100, and I'm still getting this error:
Code: [Select]
Fatal error: Maximum execution time of 30 seconds exceeded in /home/skola2/public_html/stock/keywordmgr.php on line 117
Here's the email I got from my webhost:
Code: [Select]
I've gone ahead and increased the max execution time to 100 and this can be located in your php.ini file (max_execution_time = 100).  This should resolve the error.
But the error is no different than before.

Cheers

Carl
Logged

Flashfire

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Re: keyword manager error
« Reply #5 on: April 17, 2011, 09:15:26 pm »

I'm running into the same situation with my keywords.  Right now when I go to search I get a 500 Internal Server Error and when I go through Config I'm also running into trouble.  First I turned off the option to make keywords linkable (they used to all display below the search box), but search still crashes for me.  Also, I have the same problem trying to go in to edit keywords en masse and trim them down: the 30 second timeout.

I've been in contact with my provider and we're trying to figure out what we can do to work around this in order to at least reduce the number of keywords so search works again.

My site is:  http://lastoftheninth.com/coppermine/index.php and the error I get through the keywordmgr.php page is:

Quote
*Fatal error*: Maximum execution time of 30 seconds exceeded in */home/james/htdocs/lastoftheninth.com/coppermine/include/mb.inc.php* on line *50
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: keyword manager error
« Reply #6 on: April 18, 2011, 12:12:27 pm »

@Walkinman: regarding the error message your execution time is still 30 seconds. Regarding the email it may be necessary that you manually increase that limit somehow on your server. Please read the docs of your webspace provider

@Flashfire: please don't hijack threads. Your gallery still runs cpg1.4.x, which is unsupported since some months.
Logged

Flashfire

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Re: keyword manager error
« Reply #7 on: April 18, 2011, 06:51:32 pm »

I wasn't aware mentioning the same problem was considered hijacking a thread. Sorry.

I realized the gallery was running an older version later on, and I'm working with my provider to upgrade that first to see if it helps fix the issue. If it doesn't, I'd think discussing it in an existing thread devoted to the problem is better than creating a new one, isn't it?
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: keyword manager error
« Reply #8 on: April 18, 2011, 07:05:31 pm »

Yes, you're right Flashfire. But my answer still applies:
I cannot see a straightforward solution [to fix that error message]. If you need to batch-change your keywords I suggest to do it directly in your MySQL console or ask your provider to increase the PHP execution time.
Logged

Walkinman

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 376
    • Skolai Images - Nature, Travel and Adventure stock photos
Unlock the keyword mgr thread?
« Reply #9 on: April 19, 2011, 12:53:02 am »

Hey André

I see you locked the keyword manager thread. I would like to post this in that thread, because the issue wasn't resolved simply with the max_execution_time.

I had my webhost, lunarpages, increase the max-execution_time to 100. Then I get another error, still saying it ran out of time, and also produced a mysterious 404 error:

The error I got in cpanel said:

Code: [Select]
[error] [client xx.xx.xx.xx] Premature end of script headers: /home/user/public_html/copperminedirectory/keywordmgr.php
This was running php 1.4.4 or something .. maybe 1.4.9 .. webhosts updated the site to php 5.2.14 and now the keyword manager is working correctly.

Thank you.

Cheers

Carl
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: Unlock the keyword mgr thread?
« Reply #10 on: April 19, 2011, 10:38:29 am »

I haven't locked that thread, at least not intentionally.

Merging this thread with the existing one.
Logged

Walkinman

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 376
    • Skolai Images - Nature, Travel and Adventure stock photos
Re: keyword manager error
« Reply #11 on: April 19, 2011, 10:46:12 am »

Hey André

Oh, cool thanks. Anyway, I'll mark it resolved now, and just wanted to make sure to post that there was a separate issue that was only resolved by upgrading to php 5. Working fine now.

Thanks again for all your help.

Cheers

Carl
Logged
Pages: [1]   Go Up
 

Page created in 0.026 seconds with 21 queries.