Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Bridging problem with phpBB 3  (Read 12634 times)

0 Members and 1 Guest are viewing this topic.

girlboheme

  • Coppermine newbie
  • Offline Offline
  • Posts: 18
Bridging problem with phpBB 3
« on: April 17, 2011, 05:24:06 pm »

I just installed phpBB 3.0.8 ( http://littleblueumbrella.com/forum/ )
I also just installed Coppermine Photo Gallery v1.5.12 ( http://littleblueumbrella.com/gallery/ )

On my phpBB I have the following cookie settings:

cookie domain: littleblueumbrella.com
Cookie name: phpbb3_qkcy3
Cookie path: /
Cookie secure: disabled

I'm using bridge with phpBB version 3

URL of Bridge App: http://littleblueumbrella.com/forum
Relative Path to your bridge app's config file: ../forum/
Cookie prefix: phpbb3_qkcy3

Please note:  I was reading documentation and here it states that I must have a forward slash at the end of the URL of Bridge app but when I put it there, it does not let me go further and makes me remove it.

Cookie prefix: phpbb3_qkcy3
URL of the bridge app: http://littleblueumbrella.com/forum
Relative path to your bridge app's config file: ../forum/
Use bridge app custom groups?:    1

When I enable it, it works if I log into everything through the forum.  But it will not redirect at all and I get this if I click on login or logout in Coppermine:

Quote
Forbidden

You don't have permission to access /forum/ucp.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.2.17 (Unix) mod_ssl/2.2.17 OpenSSL/0.9.8r DAV/2 mod_fcgid/2.3.5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at littleblueumbrella.com Port 80

And this is in my browser bar:
http://littleblueumbrella.com/forum/ucp.php?mode=login&redirect=http%3A%2F%2Flittleblueumbrella.com%2Fgallery%2F

I've tried to do this ten different ways, none work.  I've also tried phpBB version 2.0.18 or higher with both the phpbb3_qkcy3 cookie settings and the phpbb2_msql ones.

I've also edited the phpbb file ucp.php per nibbler's post here:
http://forum.coppermine-gallery.net/index.php/topic,53678.0.html

I'm kind of at my wits end.  Any help would be greatly appreciated.  I feel like I must be missing something very obvious. 

If you need a test account, I have one here:
login: test
pass: testing

Thank you!
Aimee
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Bridging problem with phpBB 3
« Reply #1 on: April 18, 2011, 02:11:29 pm »

The encoded colon causes the 403 error message:
Quote
http://littleblueumbrella.com/forum/ucp.php?mode=login&redirect=http%3A%2F%2Flittleblueumbrella.com%2Fgallery%2F

If you manually remove that part from the url the login page appears as expected. It seems that you have to edit something in the ucp.php file of the board. Unfortunately I cannot give you more detailed instructions, as I don't know that file.
Logged

girlboheme

  • Coppermine newbie
  • Offline Offline
  • Posts: 18
Re: Bridging problem with phpBB 3
« Reply #2 on: April 18, 2011, 03:52:17 pm »

Unfortunately, I'm not a coder.  But I'll check it out anyway.  Just don't want to blow it up.  I honestly thought that this post by nibbler addressed this issue.  But when I changed the code it doesn't change anything.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Bridging problem with phpBB 3
« Reply #3 on: April 18, 2011, 04:10:08 pm »

I don't know which post you mean, as you always refer to the whole topic. I assume it's the initial post. Did you changed anything in your ucp.php file? If so, undo those changes.
Logged

girlboheme

  • Coppermine newbie
  • Offline Offline
  • Posts: 18
Re: Bridging problem with phpBB 3
« Reply #4 on: April 18, 2011, 04:15:10 pm »

this is the part I was referring to:
Quote
If you want to enable logout redirection it seems you need to hack phpbb to support this. This step is optional.

edit the phpbb file ucp.php

find:

Code: [Select]
meta_refresh(3, append_sid("{$phpbb_root_path}index.$phpEx"));

$message = $message . '<br /><br />' . sprintf($user->lang['RETURN_INDEX'], '<a href="' . append_sid("{$phpbb_root_path}index.$phpEx") . '">', '</a> ');

   
     
change to :

Code: [Select]
meta_refresh(3, request_var('redirect', append_sid("{$phpbb_root_path}index.$phpEx")));

$message = $message . '<br /><br />' . sprintf($user->lang['RETURN_INDEX'], '<a href="' . request_var('redirect', append_sid("{$phpbb_root_path}index.$phpEx")) . '">', '</a> ');


That tells phpbb to look for the redirect parameter being passed in the url.

And I just changed it back.  And nothing seems to have changed.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Bridging problem with phpBB 3
« Reply #5 on: April 18, 2011, 04:29:15 pm »

It's called
Quote
logout redirection
so you cannot expect any change while logging in.

You have to find out why the ucp.php file returns a HTTP 403 error. Please ask the phpBB team for support.
Logged

girlboheme

  • Coppermine newbie
  • Offline Offline
  • Posts: 18
Re: Bridging problem with phpBB 3
« Reply #6 on: April 18, 2011, 04:33:45 pm »

Okay.  Will go check that out then. Thanks.  If I find an answer, I'll post here and let you all know since this issue seems to be occurring to others as well.
Logged

girlboheme

  • Coppermine newbie
  • Offline Offline
  • Posts: 18
Re: Bridging problem with phpBB 3
« Reply #7 on: April 20, 2011, 01:14:54 pm »

It isn't a problem with the phpBB file.  It is a problem with the host, Host Gator.  Please see this post here:
http://www.phpbb.com/community/viewtopic.php?f=46&t=2127416&p=12986785#p12986785

I will post another topic asking for help with modifying the bridge, thank you!
Logged
Pages: [1]   Go Up
 

Page created in 0.022 seconds with 19 queries.