Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Critical Error/Anonymous Group missing  (Read 8447 times)

0 Members and 1 Guest are viewing this topic.

southernlady

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Critical Error/Anonymous Group missing
« on: April 08, 2011, 04:29:45 am »

Yes, I read the documents. Disabling bridging did not apply as there was no forum attached when I inherited the gallery.

I have searched and read thru each thread on this subject and tried each solution already, to no avail. Going into phpmyadmin hasn't worked yet.

http://www.scrappingyourmemories.com/gallery doesn't work because it is currently in the middle of the upgrade.

What happened...I became the owner of a zen cart store and a gallery. We just finished moving both FROM HostGator to my dedicated server. The account at HostGator no longer exists. The old information on the config file would not help as we can no longer connect to that database. It's not available even if I had the config file. The old database was on HostGator. It's gone. In order to connect to this one I have to run an upgrade script.

Now, let's start from there. Is there a way around this without losing users or albums? Would a fresh install and then running the sql file adding the users and albums back in be the best method?

Liz
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Critical Error/Anonymous Group missing
« Reply #1 on: April 08, 2011, 09:04:13 am »

Is there a way around this without losing users or albums? Would a fresh install and then running the sql file adding the users and albums back in be the best method?
Depending on your initial setup you need to import at least the categories table and maybe the comments table, too. Have a look at sql/update.sql to get an idea what has be changed in the table structure.

I don't understand why you need to upgrade if you just move your gallery from one host to another. Do you have backups/dump files of your database? Was your gallery on your old host a cpg1.4.x gallery or already a cpg1.5.x gallery? I recommend to try to perform a clean upgrade instead of manually importing old tables etc. Maybe there are some old bridge settings in your database that cause the error message.
Logged

southernlady

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: Critical Error/Anonymous Group missing
« Reply #2 on: April 08, 2011, 11:13:51 am »



I don't understand why you need to upgrade if you just move your gallery from one host to another. Do you have backups/dump files of your database? Was your gallery on your old host a cpg1.4.x gallery or already a cpg1.5.x gallery? I recommend to try to perform a clean upgrade instead of manually importing old tables etc. Maybe there are some old bridge settings in your database that cause the error message.
Because the gallery was a 1.4x version. When I began the upgrade, I had no clue it had ever been bridged. As I said, I inherited the gallery. There was no forum involved in the account at all so no need for me to assume a bridge was installed. Therefore, I went ahead with the upgrade only to find out one had been.

That's where I am now. That is why I am asking what my options are at this point. I have the SQL file still of the old gallery.

Suggestions?

Liz
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Critical Error/Anonymous Group missing
« Reply #3 on: April 08, 2011, 12:14:29 pm »

Please have a look at the bridge table in your database. Additionally, check the bridge_enable row in the config table.
Logged

southernlady

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: Critical Error/Anonymous Group missing
« Reply #4 on: April 08, 2011, 02:37:30 pm »

That is my config file and I suspect it is not what I am looking for.

Code: [Select]
<?php
/*************************
  Coppermine Photo Gallery
  ************************
  Copyright (c) 2003-2009 Coppermine Dev Team
  v1.1 originally written by Gregory DEMAR

  This program is free software; you can redistribute it and/or modify
  it under the terms of the GNU General Public License version 3
  as published by the Free Software Foundation.
  
  ********************************************
  Coppermine version: 1.4.21
  $HeadURL: https://coppermine.svn.sourceforge.net/svnroot/coppermine/trunk/cpg1.4.x/config.php $
  $Revision: 5728 $
  $Author: gaugau $
  $Date: 2009-03-02 09:25:17 +0100 (Mo, 02 Mär 2009) $
**********************************************/

define('IN_COPPERMINE'true);
require(
'include/init.inc.php');
if (!
GALLERY_ADMIN_MODEcpg_die(ERROR$lang_errors['access_denied'], __FILE____LINE__);


$redirect "admin.php";
$message = <<< EOT
You are trying to access Coppermine's <a href="admin.php">config page</a> using an outdated link - the file config.php has been renamed to admin.php. You probably updated your site and haven't changed your theme as suggested in the <a href="docs/theme/">theme upgrade guide</a>.<br />
You are now being redirected to the actual page you were looking for.
EOT;
pageheader($lang_info"<meta http-equiv=\"refresh\" content=\"100;url=$redirect\" />");
msg_box($lang_info$message$lang_continue$redirect);
pagefooter();
ob_end_flush();
?>
This is my includes/configs.inc.php file and doesn't mention anything about a bridge to my knowledge. I x'ed out the data that was sensitive.
Code: [Select]
<?php
// Coppermine configuration file

// MySQL configuration
$CONFIG['dbserver'] =                         'localhost';        // Your database server
$CONFIG['dbuser'] =                         'xxxxxxxx';        // Your mysql username
$CONFIG['dbpass'] =                         'xxxxxxxxx';                // Your mysql password
$CONFIG['dbname'] =                         'xxxxxxxxxx';        // Your mysql database name


// MySQL TABLE NAMES PREFIX
$CONFIG['TABLE_PREFIX'] =                'cpg14x_';
?>

And I have attached a screenshot of my bridge table from my phpmyadmin.

I feel like I am missing something here.

Liz
Logged

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1503
  • aka 'i-imagine'
    • Home Page
Re: Critical Error/Anonymous Group missing
« Reply #5 on: April 09, 2011, 12:34:38 am »

That is my config file and I suspect it is not what I am looking for.
Correct, and it looks like you have 1.4..x version.

This is my includes/configs.inc.php file and doesn't mention anything about a bridge to my knowledge. I x'ed bridgemgr.php

It may be incorrectly configured for your new db because your site returns this:

Quote
mySQL error: Table 'katelynn_design.cpg14x_config' doesn't exist

Recheck the names and password settings in that file. Or perhaps the db name itself is causing problems.

southernlady

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: Critical Error/Anonymous Group missing
« Reply #6 on: April 09, 2011, 12:59:33 am »

Correct, and it looks like you have 1.4..x version.

It may be incorrectly configured for your new db because your site returns this:

Recheck the names and password settings in that file. Or perhaps the db name itself is causing problems.



Joe,

The new site is set up this way
Database user name is now katelynn_xxxxxx ( I am x'ing it out because this is a public board)
Database name is now katelynn_dxxxxx(I am also x'ing the rest of that out for the same reason)

Table 'katelynn_design.cpg14x_config' <-----It is looking for the HostGator database which it will not find and never find because we are not on that server, we are on a dedicated server on WiredTree now. What it needs to find is the database on MY server, which is the one posted above.

As I mentioned in my first post, I inherited this gallery as part of a site, I moved the entire thing from HostGator within a week of inheriting it. I have my own dedicated server and had no reason to maintain a site on HostGator when I could bring the site under my own umbrella. I did not do anything with the gallery prior to the move, I just moved it. And the account at HostGator was cancelled yesterday. It's gone.

I can not go looking for something that does not exist. So let's go from that point.

My options are?

Liz
Logged

southernlady

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: Critical Error/Anonymous Group missing
« Reply #7 on: April 09, 2011, 01:49:57 am »

Question, did 1.4 have an inhouse forum? I see some tables in my phpmyadmin that have the ext _fr after them.

Liz
Logged

southernlady

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: Critical Error/Anonymous Group missing
« Reply #8 on: April 10, 2011, 01:55:37 pm »

Have we reached a standstill on this?

Does anyone have any suggestions?

Liz
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Critical Error/Anonymous Group missing
« Reply #9 on: April 11, 2011, 10:34:19 am »

Table 'katelynn_design.cpg14x_config' <-----It is looking for the HostGator database which it will not find and never find because we are not on that server, we are on a dedicated server on WiredTree now. What it needs to find is the database on MY server, which is the one posted above.
Adjust your database settings in include/config.inc.php.



Off-Topic:
Question, did 1.4 have an inhouse forum? I see some tables in my phpmyadmin that have the ext _fr after them.
There's a forum plugin for cpg1.4.x and cpg1.5.x, yes. Please respect our board rules by just asking one question per thread.
Logged

southernlady

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: Critical Error/Anonymous Group missing
« Reply #10 on: April 11, 2011, 11:57:41 am »

It's part if this problem which is why I am asking it here. I understand why you normally have the rules about one question per thread. But this is not actually a new question since part of the issue involved bridging a forum. Knowing if an in-house forum exists or not would be helpful. Asking on a second thread would be time consuming, since I would have to wait for that one to be answered as well.

However, this is affecting the issue at hand. A simple yes or no would not hurt. If I can delete the _fr tables from the database and have my issue resolve so that I may continue with my upgrade, then it would be helpful to know.

Liz
Logged

southernlady

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: Critical Error/Anonymous Group missing
« Reply #11 on: April 11, 2011, 12:04:26 pm »

And adjust my database settings in the config how? I already have it pointing to the database it will reside in on my server. It already has the correct user name, correct database name, and password. How much more adjusting can I do?

Liz
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Critical Error/Anonymous Group missing
« Reply #12 on: April 11, 2011, 12:21:44 pm »

The error message
Quote
mySQL error: Table 'katelynn_design.cpg14x_config' doesn't exist
means the following. Either your database name is wrong, your table prefix is wrong or the table is missing. Maybe more than one apply.
Logged

southernlady

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: Critical Error/Anonymous Group missing
« Reply #13 on: April 11, 2011, 05:12:53 pm »

The error messagemeans the following. Either your database name is wrong, your table prefix is wrong or the table is missing. Maybe more than one apply.

Table 'katelynn_design.cpg14x_config' <-----It is looking for the HostGator database which it will not find and never find because we are not on that server, we are on a dedicated server on WiredTree now. What it needs to find is the database on MY server, which is the one posted above.

As I mentioned in my first post, I inherited this gallery as part of a site, I moved the entire thing from HostGator within a week of inheriting it. I have my own dedicated server and had no reason to maintain a site on HostGator when I could bring the site under my own umbrella. I did not do anything with the gallery prior to the move, I just moved it. And the account at HostGator was cancelled yesterday. It's gone.

I can not go looking for something that does not exist. So let's go from that point.

My options are?
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Critical Error/Anonymous Group missing
« Reply #14 on: April 11, 2011, 08:10:36 pm »

What it needs to find is the database on MY server
As I already told you:
Adjust your database settings in include/config.inc.php.
to be exact, $CONFIG['dbname'].
Logged

southernlady

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: Critical Error/Anonymous Group missing
« Reply #15 on: April 12, 2011, 12:28:43 am »

What I did:

I saved my sql file, editing out the _fr tables that I apparently did not need from the 1.4 install. Then I deleted the entire database.
Then I deleted all the files on the server. I reinstalled a brand new set of files for 1.4 using my information for the config file and the install went perfect.
I then ran the sql file into the phpmyadmin back into the database repopulating it with the old information.
Then I ran the upgrade script fot 1.5 and it went just fine. Not a glitch.

It is possible to work around this, you just have to get creative and know your way around phpmyadmin and sql files. My config file was never the issue.

We can mark this solved now.

Liz
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Critical Error/Anonymous Group missing
« Reply #16 on: April 12, 2011, 09:57:27 am »

We can mark this solved now.
you can tag your answer as "solved" by clicking on the little image in your initial posting on your thread.
Logged
Pages: [1]   Go Up
 

Page created in 0.038 seconds with 19 queries.