Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Have Placeholders, but No Images  (Read 2832 times)

0 Members and 1 Guest are viewing this topic.

bashinsk

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 23
Have Placeholders, but No Images
« on: April 06, 2011, 01:48:00 am »

Disappointment! :(

I got CPG installed, customized, categories and albums all set up, and then loaded a bunch of pix.  PROBLEM:  No pix, just placeholders...for thumbnails, intermediates, and full-sized images.  Have looked for answers in forum and in documentation, but have no idea what I am doing wrong.

Plz help!

Thanx!

hb
Logged

bashinsk

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 23
Re: Have Placeholders, but No Images - SITE URL
« Reply #1 on: April 06, 2011, 01:51:57 am »

Logged

bashinsk

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 23
Re: Have Placeholders, but No Images
« Reply #2 on: April 06, 2011, 02:48:35 am »

More info:

The images or on the server in albums/userpics/10001.  The directory perm is 755, and the perm for the pix is 644.

Sorry for the multiple posts.  I will get better! :)

hb
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: Have Placeholders, but No Images
« Reply #3 on: April 06, 2011, 10:21:33 am »

Actual link to gallery is http://www.bajanora.info/cpg/

If I try to access one of your images, I get that error message:
Forbidden

You don't have permission to access /cpg/albums/userpics/10001/thumb_jace_0001.jpg on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.


Please contact your hosting provider regarding that permission issue.
Logged

bashinsk

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 23
Re: Have Placeholders, but No Images
« Reply #4 on: April 06, 2011, 04:37:00 pm »

Hi Andre',

Actually, the problem was my error, and it literally came to me in my sleep last nite!

I used the following script from the FAQ to create a .htaccess file to prevent direct access to my pix:

------
SetEnvIfNoCase Referer "^http://www.yourdomian.com/" locally_linked=1
SetEnvIfNoCase Referer "^http://yourdomain.com/" locally_linked=1
SetEnvIf Referer "^$" locally_linked=1
<FilesMatch "\.(gif|png|jpe?g)$">
  Order Allow,Deny
  Allow from env=locally_linked
</FilesMatch>
------

However, I forgot to change the "yourdomain.com" to my domain!  Although this is obvious when you read the script, the FAQ directions do not explicitly point this out.  They just say to "Open your text editor and add the following lines, then save the file as .htaccess".  It might be good to add that the script needs to be updated with your actual info.  Some newbies like me will just blindly follow directions and never even look at the script itself.

Thanx again for all your help on the board.  Your willingness to provide assistance is refreshing and greatly appreciated.

hb
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: Have Placeholders, but No Images
« Reply #5 on: April 06, 2011, 04:41:18 pm »

I assume you mean the 'Coppermine 1.4.x FAQ'. As the current major release is cpg1.5.x, that information won't be updated, as I doubt that there will be a next release of cpg1.4.x where we can update and publish that docs.
Logged

bashinsk

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 23
Re: Have Placeholders, but No Images
« Reply #6 on: April 06, 2011, 05:09:48 pm »

Logged
Pages: [1]   Go Up
 

Page created in 0.03 seconds with 19 queries.