Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: no thumbs showing for main category  (Read 3897 times)

0 Members and 1 Guest are viewing this topic.

Galen

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
no thumbs showing for main category
« on: February 15, 2011, 10:37:47 pm »

I have read the docs and searched posts and am still confused about how to get the structure and appearance I want on the main page of my gallery.

My gallery - http://www.tetruss.com/cpg15x

My intention is to create a place on my website where users of a product I make, can create their own albums to upload pics of how they use the product, and make them available for any visitors to the site to see, while they maintain control of the album itself

I have installed and am testing coppermine to see how it might fulfill my intention. I have set-up my admin account and 2 mock user accounts. I have created test albums in all 3. I am not setting up categories, so "no category" is the default. I have changed the default name of "user gallery" to "owner gallery".

What I am trying to resolve is why these 3 test albums I have uploaded are displaying differently from each other.

On the main page of the gallery there is a heading called "Category". Beneath this is a link called "Owner Galleries"  Beneath this there is a line of text that says, "This category contains albums that belong to Coppermine users." Two of the 3 test albums are in this "Owners Gallery", and were uploaded through the 2 mock user accounts.

The issue for me is that there are no thumbs showing in this view under the category. Only the link "owner gallery". When I click on it then I arrive at a page with the thumbs. Can I change this to where the thumbs that represent an album can be viewed on the main gallery page, instead of a visitor only seeing a text link to owner galleries. In other words I want a visitor to arrive at the "owner gallery" page when they type in the url to the page. Also can I get rid of the text that says "This category contains albums that belong to Coppermine users."

The next thing, is that on my main page below "Category" is a line of text that says ... "9 files in 3 albums and 1 categories with 0 comments viewed 5 times"

The "owner gallery" category only lists 2 albums available.

The 3rd album, called "test"  shows up right beneath the "9 files..." line of text....there is no heading for the album, just the name of the album. This is the album I loaded from my admin account.

Why is this album separate from those 2 in the owner gallery?

If I could I would want all the albums to show up on the main page with name and thumbnail the same way as  the  "test" gallery does. Is this a default way that the admins albums are displayed? How can I get the admin albums to display the same as an owner gallery? ...or vice-versa.

I also note the thumbnails in the owner galleries are about half the size as those in the "test" gallery. I have searched the different admins pages for albums, images, thumbs and have missed how to resize thumbnails.

Is there a way to resize thumbnails?

I would be greatful for any insights to help me get this project underway

regards

Galen

Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: no thumbs showing for main category
« Reply #1 on: February 16, 2011, 10:27:33 am »

The issue for me is that there are no thumbs showing in this view under the category. Only the link "owner gallery". When I click on it then I arrive at a page with the thumbs. Can I change this to where the thumbs that represent an album can be viewed on the main gallery page, instead of a visitor only seeing a text link to owner galleries. In other words I want a visitor to arrive at the "owner gallery" page when they type in the url to the page.
Please have a look at that (German only) solution: http://forum.coppermine-gallery.net/index.php/topic,70371.msg344666.html#msg344666
The modification should be self-explanatory, even if you don't speak German.


Also can I get rid of the text that says "This category contains albums that belong to Coppermine users."
Remove it in the category manager.


Why is this album separate from those 2 in the owner gallery?
Because you created it in the 'public' area. Coppermine decides between 'personal' albums (that reside in the user category) and 'public' albums that resides in any other categories. Have a look at the groups manager, you'll find options for those types.


If I could I would want all the albums to show up on the main page with name and thumbnail the same way as  the  "test" gallery does. Is this a default way that the admins albums are displayed? How can I get the admin albums to display the same as an owner gallery? ...or vice-versa.
Either you create your admin albums in the user categorie or you set the permissions in a way, that regular users are allowed to create albums in the public categories. You can do grant that permission in the category manager.


I also note the thumbnails in the owner galleries are about half the size as those in the "test" gallery. I have searched the different admins pages for albums, images, thumbs and have missed how to resize thumbnails.

Is there a way to resize thumbnails?
You can set the thumbnail size in the config and resize thumbnails with the admin tools.



Please respect our board rules. Most of your questions have already been answered in the docs and in this board. Additionally we have a 'one question per thread rule'.
Logged

Galen

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Re: no thumbs showing for main category
« Reply #2 on: March 02, 2011, 11:47:18 pm »

Hi,

Thanks for your extensive reply...I have been taking care of other obligations, and am just now able to get back to you.

First, I apologise if I am asking questions already answered in the boards or documentation. Believe me, I do not wish to take up your or my time trying to figure out how to describe my problem, and get answers. I have read the docs and boards. I have actually resolved many of my questions doing this. The questions in my previous post were ones that I could not find in the docs or boards...sometimes because I do not understand how to word the keywords to search to match how I would describe my issue.

I am still having a problem understanding despite the answers you provided, so I hope you are willing to clarify further. I did not notice the one question rule, previously and will try to limit my query to that here, as best I am able.

Your response to me referred me to a previous post in german that referred to some code in the index.php, as the method to get the owners gallery page to show up with thumbnails showing for each gallery when someone clicks the link from my website to the main gallery page. Currently a visitor arrives at my site and only sees a text link "Owner's Galleries" to the owners gallery page. I want the owners gallery page to be the first page a visitor sees. Their is another album called "test" also on the main page below the Category section. This is a gallery I posted as the admin. This section of the page has no identifier for it, such as their is "Category" above.

It was not very clear to me what the code in the index.php does, but I will assume it fixes the problem I describe above.

The code from the german post looked like this.

 if (isset($cat) && $cat != USER_GAL_CAT) {
                            starttable(-1, 'Benutzeralben');
                            echo "<tr><td>";
                            list_users();
                            echo "</td></tr>";
                            endtable();

I assume I am supposed to open index.php file,  past in this code at the right location, and then upload the edited index.php file to my server. But I also suspect their needs to be some modification of the above code that relates specifically to my website or galleries. I thought this might be replacing the word 'Benutzeralben' with something like 'owner gallery' or such, but I am not clear. Or are you saying to paste this code above as is into my index.php file? If not, what are the specifics I need to add to make it relevant to my site?

I will stop with this for my one question, tho I did not understand other parts of your reply and will wait to hear back about this one before I post another.

Thank you for your help.

Galen

Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: no thumbs showing for main category
« Reply #3 on: March 03, 2011, 09:41:20 am »

Here's the translation of the German instructions:

Open index.php, find
Code: [Select]
                    if ($breadcrumb != '' || count($cat_data) > 0) {
                        theme_display_cat_list($breadcrumb, $cat_data, $statistics);
                    }
and replace with
Code: [Select]
                    if ($breadcrumb != '' || count($cat_data) > 0) {
                        if (isset($cat) && $cat != USER_GAL_CAT) {
                            starttable(-1, 'User albums');
                            echo "<tr><td>";
                            list_users();
                            echo "</td></tr>";
                            endtable();
                        }
                        theme_display_cat_list($breadcrumb, $cat_data, $statistics);
                    }

As you can see I also translated 'Benutzeralben' to 'User albums'. It's just a string you can change to your needs.
Logged
Pages: [1]   Go Up
 

Page created in 0.022 seconds with 20 queries.