Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: Final Extract not working as I expected - any help gratefully received.  (Read 5220 times)

0 Members and 1 Guest are viewing this topic.

Johnfromhere

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 77

URL is www.metzbigband.co.uk/copp2

I did a clean installation of Coppermine 1.5.12 and uploaded photos to an album.
I then set up a new ‘Group’ called ‘Members’.  The installation has the default theme (curve).

I want to make the gallery private so don’t want anything on the ‘public’ page except perhaps the ‘Login’ button. I also wanted to restrict the buttons that the ‘members’ had access to.

Having read the blurb for Final Extract, it seemed the ideal way to accomplish this, however:-

As you can see – the ‘public’ page still has ‘Home’, ‘Album list ‘ and ‘Search’ on it (although they don’t do anything).

(See attachment 1)

The setting in Final Extract for ‘Guests’ (which I had assumed would defined what menus were available on the ‘public’ page) is:-

(See attachment 2)

The view given to a ‘member’ when they log on is :-

(See attachment 3)

Which was set in Final Extract.by :-

(See attachment 4)


Have I misunderstood how Final Extract works or is it not working like it is designed to?

Any help would be greatly appreciated.

Many thanks.

John.

Logged

Johnfromhere

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 77
Re: Final Extract not working as I expected - any help gratefully received.
« Reply #1 on: February 15, 2011, 09:45:15 pm »

Sorry, I meant to say (small point) but thought I should point it out.

The screen when setting configuring Final Extract reads 'Final Extract for CPG 1.5.x - ver 1.1, although it is actually version 1.2

Cheers.

John.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: Final Extract not working as I expected - any help gratefully received.
« Reply #2 on: February 15, 2011, 10:00:42 pm »

As you can see – the ‘public’ page still has ‘Home’, ‘Album list ‘ and ‘Search’ on it (although they don’t do anything).
It doesn't matter what's displayed for guests, as you'll always get redirected to the login page.


But regarding the display of the buttons for guests and 'members' I assume that you have renamed the old 'guest' group to 'members' and then created a new group called 'guests'?
Logged

Johnfromhere

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 77
Re: Final Extract not working as I expected - any help gratefully received.
« Reply #3 on: February 15, 2011, 10:08:49 pm »

Thanks for that about what the 'guests' see, André, I can live with that.

No, I didn't rename the 'guests' group, I just created a new group called 'Members'.

Cheers.

John.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: Final Extract not working as I expected - any help gratefully received.
« Reply #4 on: February 16, 2011, 10:45:41 am »

Final Extract removes the selected items. So your settings for the 'Members' group is wrong.
Logged

Johnfromhere

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 77
Re: Final Extract not working as I expected - any help gratefully received.
« Reply #5 on: February 16, 2011, 10:58:54 am »

Ah!  I totally misunderstood the way Final Extract works  :-[.

I got it reversed!

Many thanks for helping out a dim old man, André.

By the way - I deleted the 'Members' group as I think 'Registered' fits the requirement.

Thanks again.

I am marking the thread solved.

Cheers.

John.
Logged
Pages: [1]   Go Up
 

Page created in 0.022 seconds with 20 queries.