Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: SMF and Coppermine  (Read 5064 times)

0 Members and 1 Guest are viewing this topic.

zzuzu

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
SMF and Coppermine
« on: January 30, 2011, 07:46:14 pm »

Hello,

this problem was here many times but nothing worked for me. When I go to gallery, it redirects me to login page of forum, so I login, it redirects me to forum, then I go to gallery and it redirects me back to forum to login.

Coppermine install: http://gallery.dmd247.com or http://dmd247.com/gallery
Bridging app install: http://dmd247.com/
Coppermine version: cpg1.5.0 (I think - it's the newest one)
Bridging app version: SMF 2.0 RC4
Test user account: I don't have one

BridgeManager settings:
Bridge app URL:  http://mysite.tld/test/foo_bar
Relative path to your bridge app's config file:  ../
Cookie name or prefix:  SMFCookie11 (gallery and forum has same one but they had different ones before)
Use bridge app custom groups?:  1 

Thank you in advance
Logged

Nibbler

  • Guest
Re: SMF and Coppermine
« Reply #1 on: January 30, 2011, 08:29:42 pm »

You need to provide a test user account for us to test with.
Logged

zzuzu

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: SMF and Coppermine
« Reply #2 on: January 30, 2011, 08:48:52 pm »

Name: testing
Password: test
Logged

zzuzu

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: SMF and Coppermine
« Reply #3 on: January 30, 2011, 09:00:50 pm »

Bridge app URL is http://dmd247.com/

Sorry. I forgot to edit it. Also... I noticed that SMF saves cookie name as PHPSESSID. Even though it should be SMFCookie11. And I changed Coppermine cookie name to cpg15x
Logged

Nibbler

  • Guest
Re: SMF and Coppermine
« Reply #4 on: January 30, 2011, 09:07:13 pm »

Your forum's login is not working. You need to get that fixed before bridging will work. It's setting a cookie that expires one hour in the past, so is never valid.
Logged

zzuzu

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: SMF and Coppermine
« Reply #5 on: January 30, 2011, 09:35:07 pm »

Oh. Thank you. So is it problem of SMF or server? I'm sorry. I'm noob at this. LOL
Logged

zzuzu

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: SMF and Coppermine
« Reply #6 on: January 30, 2011, 09:41:02 pm »

Yay! I see it now! It was plugin called "HTTP Only Cookie Flag" for SMF. I uninstalled it and now it works again! Thank you so much for your help.  You have no idea through how many things I went to figure it out. You looked at it and saw the problem. You are lifesaver! Thank you so so so so much! :)
Logged
Pages: [1]   Go Up
 

Page created in 0.018 seconds with 19 queries.