Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Installation Problem: MySQL error: Table 'cpg15x_albums' already exists on query  (Read 6842 times)

0 Members and 1 Guest are viewing this topic.

edgrew

  • Coppermine newbie
  • Offline Offline
  • Posts: 3

I am trying to install Coppermine 1.5.  I am using the installation wizard to enter my information. I had to use "mysql7.000webhost.com (this is an unsolicited advert that triggered the stop-word filter)" instead of "localhost" for the host name.  When I got to screen 8 of the wizard I got the following error message:

"The following errors were encountered and need to be corrected first:
MySQL error: Table 'cpg15x_albums' already exists on query ' CREATE TABLE cpg15x_albums ( aid int(11) NOT NULL auto_increment, title varchar(255) NOT NULL default '', description text NOT NULL, visibility int(11) NOT NULL default '0', uploads enum('YES','NO') NOT NULL default 'NO', comments enum('YES','NO') NOT NULL default 'YES', votes enum('YES','NO') NOT NULL default 'YES', pos int(11) NOT NULL default '0', category int(11) NOT NULL default '0', owner int(11) NOT NULL DEFAULT '1', thumb int(11) NOT NULL default '0', keyword VARCHAR( 50 ), alb_password VARCHAR( 32 ), alb_password_hint TEXT, moderator_group INT NOT NULL default 0, alb_hits INT( 10 ) NOT NULL default 0, PRIMARY KEY (aid), KEY alb_category (category), KEY `moderator_group` (`moderator_group`), KEY `visibility` (`visibility`) ) COMMENT='Used to store albums''
Try again!"

"Trying to insert data in the database.

Creating table 'cpg15x_albums'    Status:... Not OK"

My host states that the MySQL is version 5.0.81
I would grateful for any suggestions to help finish creating the database.

Regards,
               Eddy   
Logged

Nibbler

  • Guest

If the tables already exist you should install into a different database or enter a different table name prefix.
Logged

edgrew

  • Coppermine newbie
  • Offline Offline
  • Posts: 3

If the tables already exist you should install into a different database or enter a different table name prefix.

Thank you for your quick response.  I will try another database as suggested.

Regards,
                Eddy.
Logged

edgrew

  • Coppermine newbie
  • Offline Offline
  • Posts: 3

Thank you for your quick response.  I will try another database as suggested.

Regards,
                Eddy.

I changed the default table name in the wizard (cpb15x) to coppermine and the wizard sailed through to the end without any other problem.  I can now look at getting some pictures uploaded.  Thank you.

Regards,
               Eddy.
Logged
Pages: [1]   Go Up
 

Page created in 0.014 seconds with 19 queries.