Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Old version number after upgrade to 1.5.12  (Read 6245 times)

0 Members and 1 Guest are viewing this topic.

RoarinRow

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 23
    • Avalanche Style
Old version number after upgrade to 1.5.12
« on: January 06, 2011, 10:35:53 pm »

After I did the update I went to check the versions of files that I had and I noticed that I am still running 1.4.25.  It says this on the top of the page.

You have currently installed: 1.4.25
If you think this is entirely wrong and you're supposed to be running a higher version of Coppermine, you probably haven't uploaded the most recent version of the file include/init.inc.php

I FTP'd the files using the transfer type of binary and it looks like all the files are there and are the size files sizes, etc.

I was expecting to see that I had 1.5.12 installed.  I am sure I am missing something?  I did two upgrades for different sites that I admin and both with the same results.

Any suggestions?
Logged
SMF 2.0 RC4
TP 1.0 RC1
Wordpress 3.0.4

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1503
  • aka 'i-imagine'
    • Home Page
Re: Old version number after upgrade to 1.5.12
« Reply #1 on: January 06, 2011, 11:01:46 pm »

Run update.php.

Otherwise - post a link to your gallery as the board rules require. Someone might be able to take a look.
You might have had an answer already if the link had been in the first post....

8. Post links
When posting a support request, it's helpfull for supporters in most cases to see what the actual page looks like, that's why it's mandatory that you always post a link to your coppermine gallery page when asking for support. If your site contains adult content, make sure to post a warning together with your link!

Supporters might get into issues if they accidentally visit a page that interferes with their employer's internet policy. If your site contains adult content (even mild nudity even falls into this category), post the words "not safe for work" next to the link.

RoarinRow

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 23
    • Avalanche Style
Re: Old version number after upgrade to 1.5.12
« Reply #2 on: January 06, 2011, 11:38:37 pm »

Run update.php.

Otherwise - post a link to your gallery as the board rules require. Someone might be able to take a look.
You might have had an answer already if the link had been in the first post....


Thanks Joe.  I did run the update (2x) and it's still the same version.

First post updated with link to my gallery.
Logged
SMF 2.0 RC4
TP 1.0 RC1
Wordpress 3.0.4

RoarinRow

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 23
    • Avalanche Style
Re: Old version number after upgrade to 1.5.12
« Reply #3 on: January 06, 2011, 11:39:25 pm »

After I did the update I went to check the versions of files that I had and I noticed that I am still running 1.4.25.  It says this on the top of the page.

You have currently installed: 1.4.25
If you think this is entirely wrong and you're supposed to be running a higher version of Coppermine, you probably haven't uploaded the most recent version of the file include/init.inc.php

I FTP'd the files using the transfer type of binary and it looks like all the files are there and are the size files sizes, etc.

I was expecting to see that I had 1.5.12 installed.  I am sure I am missing something?  I did two upgrades for different sites that I admin and both with the same results.

Any suggestions?

My gallery can be found here - http://www.avalanchestyle.com/cpg143/index.php
Logged
SMF 2.0 RC4
TP 1.0 RC1
Wordpress 3.0.4

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1503
  • aka 'i-imagine'
    • Home Page
Re: Old version number after upgrade to 1.5.12
« Reply #4 on: January 06, 2011, 11:52:56 pm »

You must be having FTP problems. There are indeed cpg1.4.x files running on your server.
Example: http://www.avalanchestyle.com/cpg143/update.php

Get cpg 1.5.12 here: http://sourceforge.net/projects/coppermine/files/Coppermine/1.5.x/cpg1.5.12.zip/download

Use a good FTP application. I use Filezilla with pleasant success, however there are other programs that will do the job. Confirm by your FTP app that all of the old cpg 1.4 files were replaced. Then run: http://www.avalanchestyle.com/cpg143/update.php. If you don't have write permissions on the root of your gallery, talk to your host.

Read the docs. Make backups.

RoarinRow

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 23
    • Avalanche Style
Re: Old version number after upgrade to 1.5.12
« Reply #5 on: January 07, 2011, 12:15:43 am »

You must be having FTP problems. There are indeed cpg1.4.x files running on your server.
Example: http://www.avalanchestyle.com/cpg143/update.php

Get cpg 1.5.12 here: http://sourceforge.net/projects/coppermine/files/Coppermine/1.5.x/cpg1.5.12.zip/download

Use a good FTP application. I use Filezilla with pleasant success, however there are other programs that will do the job. Confirm by your FTP app that all of the old cpg 1.4 files were replaced. Then run: http://www.avalanchestyle.com/cpg143/update.php. If you don't have write permissions on the root of your gallery, talk to your host.

Read the docs. Make backups.


Thanks I will try the upload again from home.  I currently use Filezilla.  If it continues to be a problem, then I will contact my host.

Logged
SMF 2.0 RC4
TP 1.0 RC1
Wordpress 3.0.4

RoarinRow

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 23
    • Avalanche Style
Re: Old version number after upgrade to 1.5.12
« Reply #6 on: January 07, 2011, 09:32:04 pm »

Well I was able to successfully upgrade 1 of 2 sites last night.  I am still having a problem with my main site which is http://www.avalanchestyle.com/cpg143/index.php

Here's what I've done so far:
- I've run the update several times
- I've reset back to factory defaults
- I've deleted my gallery files and uploaded fresh files
- I've cleared my Chrome browser cache and cookies
- I've tried to do an install instead of an update, but it keeps telling me that the include/install.lock is still present
       I search the include directory via Filezilla FTP and there was no install.lock any where
       I did a remote directory search throughout my whole site and there was no install.lock to be found
       I set my FTP to force to show hidden files
- I've tried to change themes

So far none of these things have worked.

Any other suggestions?  Please.
Logged
SMF 2.0 RC4
TP 1.0 RC1
Wordpress 3.0.4

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1503
  • aka 'i-imagine'
    • Home Page
Re: Old version number after upgrade to 1.5.12
« Reply #7 on: January 07, 2011, 11:35:12 pm »

2 different sites sounds like 2 different hosts from here....

Try to look for and / or upload other hidden files (.htaccess).

But something else is not right, do you have a redirect configured?

Talk to your hosting company, usually they are very helpful. Direct them towards this thread, if it helps.

RoarinRow

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 23
    • Avalanche Style
Re: Old version number after upgrade to 1.5.12
« Reply #8 on: January 08, 2011, 12:45:24 am »

2 different sites sounds like 2 different hosts from here....

Try to look for and / or upload other hidden files (.htaccess).

But something else is not right, do you have a redirect configured?

Talk to your hosting company, usually they are very helpful. Direct them towards this thread, if it helps.



Thanks Joe.  My two sites are from the same web hosts, but they recently made changes so maybe the second one has moved somewhere else or off to a different server.

In regards to other hidden files, is there another file I should be looking for or something in the .htaccess that should or should not be there?

This is what my .htaccess file looks like right now.

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress
Logged
SMF 2.0 RC4
TP 1.0 RC1
Wordpress 3.0.4

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Old version number after upgrade to 1.5.12
« Reply #9 on: January 17, 2011, 04:09:06 pm »

- I've deleted my gallery files and uploaded fresh files
If you really deleted all Coppermine files and uploaded fresh cpg1.5.12 files, it's seems that your ftp dir doesn't match the directory your website reads the files from. Try to upload a totally new file (e.g. test_2010-01-17.htm) via ftp and check if you can access it with your web browser.
Logged
Pages: [1]   Go Up
 

Page created in 0.022 seconds with 21 queries.