Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: phpbb3 bridging problem after 1.5.12 upgrade  (Read 4849 times)

0 Members and 1 Guest are viewing this topic.

teleferico

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
phpbb3 bridging problem after 1.5.12 upgrade
« on: January 16, 2011, 11:36:15 am »

Hello,

After upgrading to 1.5.12, I'm having permissions problems with bridging to phpbb3.  I searched the forum and found others having similar problems, but for reasons such as incorrect cookie prefix, etc. that do not seem to match this particular problem.  Because my phpbb3 installation was upgraded from phpbb2, I have made the change to phpbb3.inc.php to set
 
Code: [Select]
$this->admingroups = array(5);
to the correct group number.  Upon enabling bridging with the BridgeManager, when I go to groups to re-sync, I get this error:
"You don't have permission to access this page."
Further, navigating away from that, I find that I don't have any admin functions available to me.  How can I fix this?  I've repeated the steps carefully and always get the same result.

Coppermine install: http://www.greatamericaparks.com/images/
Forum install: http://www.greatamericaparks.com/forums/
Coppermine version: cpg1.5.12
Forum version: PHPBB3 v3.0.8
Test user account: cpgtest / temppass

BridgeManager settings:
Forum URL:  http://www.greatamericaparks.com/forums
Relative path to your BBS's config file:  ../forums/
Use post-based groups?:  yes
Cookie name/prefix (if applicable): phpbb3_2mk86

Regarding "Forum URL:" in the BridgeManager settings, the documentation and the help say that the trailing slash must be included.  However, if I include the trailing slash, the BridgeManager tells me that I cannot include it.  These are the same bridge settings that I had before the upgrade and they were previously working.

Steven
Logged

Nibbler

  • Guest
Re: phpbb3 bridging problem after 1.5.12 upgrade
« Reply #1 on: January 16, 2011, 11:59:35 am »

What's the 5 for?
Logged

teleferico

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: phpbb3 bridging problem after 1.5.12 upgrade
« Reply #2 on: January 16, 2011, 10:23:40 pm »

According to the bridging documentation at http://documentation.coppermine-gallery.net/en/bridging.htm#integrating_individual_bridge_issues_phpbb3 , the "5" in phpbb3.inc.php in this line:

Code: [Select]
$this->admingroups = array(5);
must be changed to the number which is determined by this method:

Quote
Go to your forum, log into AdminCP; click on the tab "Users and Groups" and go to "Manage groups". you'll see all your forum groups now and next to them 3 links (Settings/Members/Delete); click on "Settings" next to the group you want to give portal admin permissions. now take a look at the address line, which should similarly to this: http://yourdomain.com/phpbb3/adm/index.php?i=groups&sid=[randomnumbersandletters]&icat=12&mode=manage&action=edit&g=64 In our example above, the group's ID is 64;

I changed the 5 to the correct number and have compared it to the backup version I had of phpbb3.inc.php from before the upgrade to 1.5.12.  The 5 is the group number for the admin group in phpbb3 new installations and is what phpbb3.inc.php has by default.  For phpbb3 installations that were upgrades from phpbb2, the admin group is likely a different number and must be determined using the procedure above and phpbb3.inc.php must be changed to that number, instead of 5.  For some reason, it's not working now because after enabling bridging, I have no admin rights.

Steven
Logged

teleferico

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: phpbb3 bridging problem after 1.5.12 upgrade
« Reply #3 on: January 17, 2011, 12:44:17 am »

I have resolved this.

I repeated the upgrade process and the problem has finally been eliminated.  This issue can now be closed.

Steven
Logged
Pages: [1]   Go Up
 

Page created in 0.017 seconds with 19 queries.