Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Very Basic Upgrade Question  (Read 4416 times)

0 Members and 1 Guest are viewing this topic.

waltg

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Very Basic Upgrade Question
« on: January 07, 2011, 10:47:59 pm »

I plan to upgrade from 1.4.25 to 1.5.12

My basic question is, when uploading the new version folders and files to the server, do I just overwrite the old version files (excluding Albums, config.inc.php etc) that are already there? Sorry if this should be obvious but I don't want to screw up the upgrade by overwriting files I shouldn't.

I've read about the issues with auto installers (my original version was auto installed) so I do plan to do the upgrade as advised on the Coppermine site.

Thanks for any advice.

Cheers
Logged

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1504
  • aka 'i-imagine'
    • Home Page
Re: Very Basic Upgrade Question
« Reply #1 on: January 08, 2011, 12:02:23 am »

Use the links at the top of the page to start with.

Download the latest stable version.

Documentation >> Documentation for cpg 1.5.x (or the docs in your downloaded package)

Make certain not to skip any of the steps, including making backups and theme updating. You will do fine.

Auto installers / upgrades are not supported for the very reason you mentioned: Trouble.

Remember the board rules the next time that you post a request.

8. Post links
When posting a support request, it's helpfull for supporters in most cases to see what the actual page looks like, that's why it's mandatory that you always post a link to your coppermine gallery page when asking for support. If your site contains adult content, make sure to post a warning together with your link!

Supporters might get into issues if they accidentally visit a page that interferes with their employer's internet policy. If your site contains adult content (even mild nudity even falls into this category), post the words "not safe for work" next to the link.

waltg

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Very Basic Upgrade Question
« Reply #2 on: January 08, 2011, 03:51:11 pm »

Thanks for the quick reply.

sorry for the slip of etiquette -  My site is at http://waltg.net/wpics

I backed up my database and critical files (config.inc.php etc) and copied over all the files from 1.5.12 to my server and ran the update script.

Now when I go to the site page I get a message "Critical Error - There was an error while processing a database query".

I've checked the server files and the config.inc.php file contents are still as they were before the upgrade.

When I try to login I get the message - Warning your browser does not accept script's cookies -  I have not changed my browser cookie settings!

Any idea where I can go from here?   
Logged

Nibbler

  • Guest
Re: Very Basic Upgrade Question
« Reply #3 on: January 08, 2011, 03:57:05 pm »

You didn't upload all the new files. That update script is the old version.
Logged

waltg

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Very Basic Upgrade Question
« Reply #4 on: January 08, 2011, 05:25:52 pm »

I downloaded cpg1.5.12.zip from the Coppermine Gallery home page and installed that!

Where do I get the latest update script from if not from that archive?
Logged

Nibbler

  • Guest
Re: Very Basic Upgrade Question
« Reply #5 on: January 08, 2011, 05:32:09 pm »

It's in the archive, you just need to upload it to the server, overwriting the old one.
Logged

waltg

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Very Basic Upgrade Question
« Reply #6 on: January 08, 2011, 05:48:53 pm »

 DOH! I just needed a slap!

I had uploaded all files and folders APART from the files for the root directory of my site!

Sorry for wasting folks time and thanks for the tolerance - I can now log in with no errors or cookie issues!

Cheers
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: Very Basic Upgrade Question
« Reply #7 on: January 17, 2011, 04:10:56 pm »

Marking accordingly.
Logged
Pages: [1]   Go Up
 

Page created in 0.017 seconds with 21 queries.