Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: User menu disappears when I hover over it.  (Read 3599 times)

0 Members and 1 Guest are viewing this topic.

randelld

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
User menu disappears when I hover over it.
« on: January 03, 2011, 06:59:10 pm »

Hi All,
I am having issues with the user menu. It's the one that has the following links.
Home|Contact|My Gallery|Sidebar|Upload Files|Logout

This menu seems to appear when I hover over it, then it disappears and does not re-appear.

Can anyone tell me where the CSS is for this menu please.

thank you
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4849
    • Windsurf.me
Re: User menu disappears when I hover over it.
« Reply #1 on: January 03, 2011, 08:52:42 pm »

Can you post a link to your site please?
Logged
It is a mistake to think you can solve any major problems just with potatoes.

randelld

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
Re: User menu disappears when I hover over it.
« Reply #2 on: January 04, 2011, 05:13:58 pm »

Hi Phill,
I've noticed that the menu appears when I hover over the home icon. If I'm not logged in then only Home|Login appears.

Is this the correct way for this menu to behave?
We are planning to let a certain usergroup upload images from events. I can see a lot of support questions coming through for this. I think I'd rather have the menu permenantly visible if that's possible.

The domain is www.bsmaonline (dot) com
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4849
    • Windsurf.me
Re: User menu disappears when I hover over it.
« Reply #3 on: January 04, 2011, 05:26:27 pm »

The menu should only be there when you hover over it. Do you want it visible all the time when logged in?
Logged
It is a mistake to think you can solve any major problems just with potatoes.

randelld

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
Re: User menu disappears when I hover over it.
« Reply #4 on: January 04, 2011, 08:44:03 pm »

I think in my case for this particular site it would be better.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: User menu disappears when I hover over it.
« Reply #5 on: January 05, 2011, 10:22:34 am »

Simple (but not clean) solution: open themes/eyeball/template.html, find
Code: [Select]
<div id="Menu1" class="topmenu">and replace with
Code: [Select]
<div id="Menu1b" class="topmenu">
Open themes/eyeball/template.html, find
Code: [Select]
#Menu1 {
     position:relative;
     width:780px;
     height:15px;
     top: 3px;
     left: 20px;
     visibility: hidden;
}
and replace with
Code: [Select]
#Menu1b {
     position:relative;
     width:780px;
     height:15px;
     top: 3px;
     left: 20px;
}
Logged

randelld

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
Re: User menu disappears when I hover over it.
« Reply #6 on: January 06, 2011, 08:53:19 am »

Thank you for your help and time Andre.

cheers
Logged
Pages: [1]   Go Up
 

Page created in 0.018 seconds with 20 queries.