Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Thumbnails repeat - not all images show up  (Read 2368 times)

0 Members and 1 Guest are viewing this topic.

MrMatt

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 21
Thumbnails repeat - not all images show up
« on: December 06, 2010, 11:43:22 pm »

When browsing through an album, this one for example: http://troopphoto.troop101.net/thumbnails.php?album=188, page 3 for some reason has repeat images from the first page.  If you browse all three pages some images repeat, if we go through the gallery one image at a time  you can find the other photos.  This photo: http://troopphoto.troop101.net/displayimage.php?album=188&pid=10175 doesn't show in the gallery when looking through the thumbnails, but it is definitely in there.  I think this occurred when I upgraded from 1.4.x to 1.5.x, but I'm not sure.  It is happening in every gallery I have, even the 2 pagers.

Site: http://troopphoto.troop101.net/
Test Username: testusr
Test Password: test101

Things I have tried so far:

I made sure I had the latest release, 1.5.10
Updated the database and checked version, all OK
Tried three different Themes that are included by default
Uploading a new Album of Photos - This new Album had the same problem.
Admin Tools > Update Thumbnails
Disable all Plugins

Yet it seems that the photos are doomed to repeat.  Any help fixing this is greatly appreciated.  Please let me know if there is any information you need in addition to the above.  Thanks!

-Matt
Logged

sharpo

  • Coppermine frequent poster
  • ***
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 332
Re: Thumbnails repeat - not all images show up
« Reply #1 on: December 07, 2010, 01:52:42 am »

I'm not one of the experts on here, but just had a look at your album 188. To make it easier to see repeating thumbnails I put them into filename order & the filenames are consecutive without any repeats. Some thumbnails look similar but are different images.

That image 10175 you mention is there, the filename is http://troopphoto.troop101.net/albums/oct06/normal_October20060060.jpg & it appears at position 61 in the gallery when in fileame order. I can't see a problem.

I'm sure one of the more knowledgable people will check it out later.
Logged
Sharpo (not an expert, just a Coppermine user)
3 live galleries, first started in 2006.
http://www.sharpos-world.co.uk/BB3cpg/ with over 8,000 images.
http://www.sharpos-world.co.uk/cpg/ with over 25,000 images. 1.6.25
http://www.sharpos-world.co.uk/kc/ with over 300 images. 1.6.25

MrMatt

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 21
Re: Thumbnails repeat - not all images show up
« Reply #2 on: December 07, 2010, 02:16:38 am »

I switched it from sorting by Title and sure enough that fixed it.  Changed the default gallery setting, so all should be good with the world.  Thanks for the tip.  That works for now.  I only have 1 album that required the title sorting, so I will set that one differently.  Thanks!
Logged
Pages: [1]   Go Up
 

Page created in 0.023 seconds with 20 queries.