Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: stop original from resizing.  (Read 3060 times)

0 Members and 1 Guest are viewing this topic.

xxserenity

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
stop original from resizing.
« on: November 29, 2010, 01:54:54 am »

I have been looking through the search and can't find anything so I'm gonna post my question.

The images that I'm uploading to my gallery are quite large and when I click to view original picture, it's resizing it. How do I stop this? I have been trying to play with the file settings but nothing seems to work.

Sample:

http://a-eckhart.org/img/displayimage.php?album=56&pid=22#top_display_media

When you click on that, that isn't the original size of the photo and you can tell. How do I make it so the original picture of the size is what pops up?
Logged

StrongEagle

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: stop original from resizing.
« Reply #1 on: November 29, 2010, 02:44:26 am »

Under Config, go to the Files settings.  Set the max size and max width/height to a value large enough to include your photos.
 
Then, set 'auto resize' to No.
Logged

xxserenity

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: stop original from resizing.
« Reply #2 on: November 29, 2010, 02:51:31 am »

I tried all that. These are the settings.

http://i51.tinypic.com/inygp1.png
Logged

StrongEagle

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: stop original from resizing.
« Reply #3 on: November 29, 2010, 03:16:30 am »

When you get the pop up 'full size' image, right key it (I am using Firefox).  One of the menu options is 'Image Info'.  When I click this in Firefox, I can see that the original image size is correct, and it has been resized by the browser.  (In Internet Explorer you only see the resized dimensions).
 
Again, in Firefox, I can right click 'View Image'.  This presents me with the image and a zoom magifying glass.  If I click the image, then I see it full size.  I cannot do this in IE.
 
So... the question becomes... who is doing the scaling?  The browser software or the javascript?  The full image has been sent to my local PC because I can view it in FF as noted above.  If I take a look at the page source for the intermediate image, the javascript shows the correct fullsize... so I don't know where the resize is occurring.

Quote
<td align="center" style="{SLIDESHOW_STYLE}">
                                                <a href="javascript:;" onclick="MM_openBrWindow('displayimage.php?pid=787&amp;fullsize=1','12829121994cf30c90b826a','scrollbars=yes,toolbar=no,status=no,resizable=yes,width=3077,height=2307')"><img src="albums/vietlao/brian/normal_DSC01223.JPG" width="400" height="300" class="image" border="0" alt="Click to view full size image" /><br /></a>

Logged

xxserenity

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: stop original from resizing.
« Reply #4 on: November 29, 2010, 03:26:34 am »

Exactly, older versions of the gallery I've had doesn't scale once I click on the resized picture to see the fullsize. I know I can do the view image thing but I don't want to have to resort to that.
Logged

StrongEagle

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: stop original from resizing.
« Reply #5 on: November 29, 2010, 04:02:30 am »

For fun, I set resizeable to NO in displayimage.php but that didn't work... was still yes in page source. 
Logged

Brooklyn

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 33
Logged
Pages: [1]   Go Up
 

Page created in 0.041 seconds with 21 queries.