Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Fatal error  (Read 4617 times)

0 Members and 1 Guest are viewing this topic.

Yoav1987

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Fatal error
« on: November 21, 2010, 05:21:29 pm »

Hello,

I've installed witj success the last version of Coppermine - 1.5.8. But I got a Fatal error : when I'm saving my plugin's configuration.

Here is my site : http://photo.webkef.com/
Logged

Nibbler

  • Guest
Re: Fatal error
« Reply #1 on: November 21, 2010, 05:31:55 pm »

Enable debug mode in config.
Logged

Yoav1987

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Fatal error
« Reply #2 on: November 21, 2010, 05:34:44 pm »

Activated !
Logged

Yoav1987

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Fatal error
« Reply #3 on: November 21, 2010, 05:36:38 pm »

While executing query 'UPDATE `cpg15x_mod_SlideShowIt` SET slideshowit_albumid=('')' in plugins/slideshowit/codebase.php on line 34

mySQL error: Table 'eretzisr_PHOTOS.cpg15x_mod_SlideShowIt' doesn't exist

Ok, I see what is the problem.
Logged

Gene-2008

  • Contributor
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 188
Re: Fatal error
« Reply #4 on: November 22, 2010, 01:41:19 am »

While executing query 'UPDATE `cpg15x_mod_SlideShowIt` SET slideshowit_albumid=('')' in plugins/slideshowit/codebase.php on line 34

mySQL error: Table 'eretzisr_PHOTOS.cpg15x_mod_SlideShowIt' doesn't exist

Ok, I see what is the problem.

This is my plugin and you are correct the problem is the Uppercase letters on the cpg15x_mod_SlideShowIt.
Change it to cpg15x_mod_slideshowit ...apparently new mysql is now case sensitive.

Also while you are at it look for any places where <? is used instead of <?php

I will be releasing a new versions with these a and a few other fixes soon.

Gene

Logged

Yoav1987

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Fatal error
« Reply #5 on: November 22, 2010, 01:47:20 am »

Ok, I'll be patient  ;)
Logged

Gene-2008

  • Contributor
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 188
Re: Fatal error
« Reply #6 on: November 22, 2010, 01:51:27 am »

Ok, I'll be patient  ;)

No need to be patient...just edit plugins/slideshowit/codebase.php on line 34

Find:
 $s="UPDATE `{$CONFIG['TABLE_PREFIX']}mod_SlideShowIt` SET slideshowit_albumid=('$slideshowit_albumid')";
Replace it with:
 $s="UPDATE `{$CONFIG['TABLE_PREFIX']}mod_slideshowit` SET slideshowit_albumid=('$slideshowit_albumid')";

Gene


Logged

Yoav1987

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Fatal error
« Reply #7 on: November 22, 2010, 01:53:43 am »

Okay I'll test that ;) Thank you  ::)
Logged
Pages: [1]   Go Up
 

Page created in 0.03 seconds with 27 queries.